1.3.11 and old recordings

  • is it a bug or what might be wrong, when shutting down vdr machine it loses older all recordings from list.
    I checked and recordings exist in /video -directory.


    My installation is:
    - vdr 1.3.11 with vdr-1.3.11-enAIO-1.3.diff.gz and - - - -
    - vdr-1.3.11-subtitles-0.3.3-and-ttxtsubs-0.0.5.diff.gz patches.
    - dxr3 plugin 0.23pre1 with uncommented usleep
    - text2skin 0.7
    - DVB subtitles 0.3.3


    nova-t card and hollywood+

  • Hi,
    hast Du möglicherweise mal mit VFAT=1 und mal ohne compiliert?
    Did You compile with VFAT=1 or wihout?


    Dann unterscheidet sich die Verwendung der Punkte ( . ) oder
    Doppelpunkte ( : ) in dem Datums/Zeit-Verzeichnis.
    Then the separators in the directorystructure
    are different, either dot ( . ) or colon? ( : ).



    Falls es das ist: ist Deiner letzter Zustand der richtige: dann
    Verzeichnisse von Hand umbenennen.
    Falls der alte Zustand derrichtig: Sorry, neu übersetzen!
    If so, decide wether to manually exchange the separators or
    to recompile with Your favourite VFAT-setting


    Vorschlag an die Entwickler:
    da jetzt die Verzeichnisse im Speicher
    gehalten werden, kann man da nicht tolerant beide Schreibweisen
    lesend akzeptieren? Achtung rename-recording!!!!


    Viel Erfolg
    Harvey

  • Hi!


    Like winni said it's a Bug or a feature, that the scanning of the video-directory is to constrained (no wrong symlinks or files greater than 2GB allowed).
    Take a look at the second page of the thread winni posted. Frank99 attached a recordings.c which is "more tolerant". Maybe it helps.


    Bye,
    Brougs78

    - -- --- ================================================================ --- -- -
    Antec Fusion, Intel E5200, Asus P5N7A-VM (VDPAU), DD CineS2 v6 + DD DuoFlex CI // yavdr-0.6.1
    - -- --- ================================================================ --- -- -

  • I did try that recording.c from here, it didn't compile, but I did check same file in my VDR machine. And now it works !!


    I did these changes, commented lines which follows text THIS from line 708 to line 755, there is one return false, but it wasn't commented in file that found here.