Hardware-Wakeup - Software

  • Renegadesworld
    Ich hatte das gleiche Problem (gleiche Fehlermeldungen). Wenn ich mich recht erinnere war es aber ein Problem beim beenden von Lirc. Weiß ich aber nicht mehr genau. Ich versuche mal daran zu denken und schaue zu Hause nach.
    Wenn Du in zwei Tagen (heute schaffe ich es wohl nicht) nichts von mir gehört hast, dann schick mir mal 'ne Erinnerungsmail.


    Andreas

  • Hallo,


    das Problem liegt wohl kaum an LIRC. Eventuell hast du nur ein abgespectes date Kommando (Stichwort busybox). Pack doch mal set -x an den Anfang und poste die Ausgabe.


    Tschüß Frank


    PS: Leider kein Urlaub, nur Stress. ;)


  • Ich habe mal nachgeschaut. Ich habe bei mir nach "sleep 1" ein "setserial /dev/ttyS0 uart 16550A" eingefügt. Danach hat es funktioniert. Ich habe keine Ahnung warum...


    Andreas

  • Quote

    Original von elinmerl
    Ich habe mal nachgeschaut. Ich habe bei mir nach "sleep 1" ein "setserial /dev/ttyS0 uart 16550A" eingefügt. Danach hat es funktioniert. Ich habe keine Ahnung warum...


    Andreas


    Danke für den Hinweis, aber wie du vieleicht kurz vor dem echo Befehl siehst, wird dies auch bei mir gemacht (Zeile 127)


    Meine eingestellte 'IDLE-Time' für EPG Scan wird nun auch gesetzt (48 Stunden). Aber leider nicht der Timer für die Aufzeichnung.


    Hier mal der Output der durch 'set -x' erzeugt wurde:



    So sieht derzeit meine shutdown90..... aus (mit 'debugging' Befehlen ;) )


    und so meine config-Datei:

    Renegade's World, Golf 4 Cabrio
    MEPIABOX: Silverstone LC02s, EPIA M10000B, 512MB Ram, 16GB CompactFlash-IDE, 160GB Samsung SP1614N, FS FF DVB-S rev1.6, TS SkyStar2, AVBoard 1.3, HITACHI DVD-ROM GD-S200 - VDR-Wakeup (K-Data, Jepsen 1.6beta, 4x20 DIL-LCD) - Futaba VFD 2x40 - LinVDR Mahlzeit 3.2
    TV: Samsung LE-46F86BD - 46'' LCD, Full HD, 100Hz

  • Hallo,


    hier ist das entscheidende


    Das Datum wird in deutsch ausgegeben, aber es wird nicht in deutsch wieder eingelesen. Setzte man export LANG=C an den Anfang. Wundert mich, dass es bei mir zu funktionieren scheint.


    Tschüß Frank

  • Hab hinter 'set -x' mal das 'export LANG=C' eingefügt, trotzdem setzt er nur den 48 Std. Timer.


    und die gleiche Meldung in der set -x Ausgabe.


    ------


    UPDATE:


    Hab eben mal die Daily Timer in der Config deaktiviert. Damit klappt es nu!


    Danke für die Hilfestellung.


    Und ne Stressfreie-Woche für dich Frank ;)

    Renegade's World, Golf 4 Cabrio
    MEPIABOX: Silverstone LC02s, EPIA M10000B, 512MB Ram, 16GB CompactFlash-IDE, 160GB Samsung SP1614N, FS FF DVB-S rev1.6, TS SkyStar2, AVBoard 1.3, HITACHI DVD-ROM GD-S200 - VDR-Wakeup (K-Data, Jepsen 1.6beta, 4x20 DIL-LCD) - Futaba VFD 2x40 - LinVDR Mahlzeit 3.2
    TV: Samsung LE-46F86BD - 46'' LCD, Full HD, 100Hz

  • Hallo,


    nach export LANG=C sollte date '+%d %b %Y' 15 Oct 2007 statt 15 Okt 2007 ausgeben. Sonst hast du vielleicht LC_TIME auf de_DE gesetzt. Poste doch mal die Ausgabe von set und versuch es mal mit export LC_TIME=C.


    Tschüß Frank

  • Hab schon wieder was neues ?!?!
    Timer wurde für 15.10. 20:00 gesetzt (heut morgen programmiert) gucke gerade nach meinem VDR und was ist? Der ist aus?????


    Jetzt bin ich etwas baff?!


    -----


    set gibt aus:


    Werd jetzt mal LC_TIME auf C setzen lassen beim aufruf.

    Renegade's World, Golf 4 Cabrio
    MEPIABOX: Silverstone LC02s, EPIA M10000B, 512MB Ram, 16GB CompactFlash-IDE, 160GB Samsung SP1614N, FS FF DVB-S rev1.6, TS SkyStar2, AVBoard 1.3, HITACHI DVD-ROM GD-S200 - VDR-Wakeup (K-Data, Jepsen 1.6beta, 4x20 DIL-LCD) - Futaba VFD 2x40 - LinVDR Mahlzeit 3.2
    TV: Samsung LE-46F86BD - 46'' LCD, Full HD, 100Hz

  • Hallo,

    Code
    1. LC_ALL=de_DE


    LC_ALL hat wohl Vorrang vor LANG. LC_TIME sollte aber auf jeden Fall gehen.


    Tschüß Frank

  • Bleibt trotzdem noch das Problem das der VDR nicht aufwacht?!


    Hab heute nochmal Timer gesetzt. Um 16:05 sollte er an gehen, jetzt steht immer noch die Timer Zeit im LCD?! Und hat wieder nix aufgezeichnet.


    Aber über FB lässt sich der VDR anschalten!


    Noch ne Idee?


    So wie ich das sehe ist die richtige Uhrzeit/Datum gesetzt, und die Timer Startzeit stimmt von Datum/Uhrzeit auch

    Renegade's World, Golf 4 Cabrio
    MEPIABOX: Silverstone LC02s, EPIA M10000B, 512MB Ram, 16GB CompactFlash-IDE, 160GB Samsung SP1614N, FS FF DVB-S rev1.6, TS SkyStar2, AVBoard 1.3, HITACHI DVD-ROM GD-S200 - VDR-Wakeup (K-Data, Jepsen 1.6beta, 4x20 DIL-LCD) - Futaba VFD 2x40 - LinVDR Mahlzeit 3.2
    TV: Samsung LE-46F86BD - 46'' LCD, Full HD, 100Hz

  • Hallo,


    zur programmierten Weckzeit passiert das gleiche wie beim Empfang des mit IRO programmierten IR-Befehls. Im Display erscheint VDR startet .... Dabei müsste außerdem LED1 zweimal blinken und der programmierte Port (normal RING) schalten. Anschließend geht LED1 aus und die programmierte Zeit wird gelöscht.


    Was läuft bei dir denn anders?


    Tschüß Frank

  • Tjoar, gute Fräge.


    Ich werd wohl morgen (heute ^^) abend noch ein paar tests machen. Und mal nen Timer auf ne Zeit setzen wo ich auch im Raum anwesend bin.


    Wie gesagt über FB lässt er sich einschalten.


    Kommt erst VDR startet und 1-2 Sek. später geht die Kiste an und das Sternchen wird dann auch angezeigt (PowerON erkennung).


    Meld mich nochmal, mich wundert es halt, weil's bisher gelaufen hat.


    Wenn's so weitergeht, stopf ich wieder meine Alte 512MB CF-Card rein. Das System dadrauf lief 1a.
    Aber nein, man will ja was aktuelleres haben.
    Wie war es doch gleich? (N)Ever touch a running System :D

    Renegade's World, Golf 4 Cabrio
    MEPIABOX: Silverstone LC02s, EPIA M10000B, 512MB Ram, 16GB CompactFlash-IDE, 160GB Samsung SP1614N, FS FF DVB-S rev1.6, TS SkyStar2, AVBoard 1.3, HITACHI DVD-ROM GD-S200 - VDR-Wakeup (K-Data, Jepsen 1.6beta, 4x20 DIL-LCD) - Futaba VFD 2x40 - LinVDR Mahlzeit 3.2
    TV: Samsung LE-46F86BD - 46'' LCD, Full HD, 100Hz

  • hallo, also ich hab mit die platine auch mal aufgebaut und muss gleich ma 2 anmerkungen machen.


    1.: lirc "hört" bei mir standartmäsig auf der DSR leitung, deshalb musste ich pin1 vom board mit pin6 an com1 verbinden


    2. im schaltplan ist imho ein fehler: beim max232 chip gehört pin2 über nen kondensator gegen masse und nicht gegen 5V


    mit wake-on-ring & powersense( wie wird dieser port gesetzt, geschieht das automatisch von lirc?)
    hab ich auch noch einige problemchen, aber da muss ich erst noch ein bisschen testen :)


    gruß red

  • Hallo,


    1.
    Sicher? RTS wird beim Standard zur Stromversorgung genutzt. Siehe hier:
    http://www.lirc.org/receivers.html


    2.
    Pin2 ist V+ und gehört, wie in jedem Datenblatt zu sehen über einen Kondensator gegen +5V.


    3.
    Für Powersense gibt es drei Möglichkeiten der Beschaltung. Das hat mit LIRC nichts zu tun. Ist alles auf meinen VDR-Seiten beschrieben.


    Tschüß Frank

  • 1) hat mich vorhin verschrieben und gleich ausgebessert wusste net dass du so schnell bist :)
    meinte natürlich DSR, über DCD funktionierts zumindest bei mir nicht mit dem lirc aus cvs
    (auf der hp von igor cesko findet sich auch die schaltung über dsr)


    2.) laut diesen fatanblatt: http://www.ortodoxism.ro/datas…xasinstruments/max232.pdf
    gehörts imho an gnd, hab aber jetzt mal geschaut und bei http://www.elektronik-kompendi…ublic/riederer/max232.htm
    gehörts an 5v, hmmm


    3.) naja auf deiner seite steh:

    Quote

    Bei dieser Möglichkeit wird zur Erkennung des PC-Zustands die DTR-Leitung der seriellen Schnittstelle benutzt. Diese wird von LIRC beim Einschalten des PCs gesetzt. Ein freier Port des MAX232 führt die notwendige Pegelanpassung auf 0-5V durch (1),(2),(3). Der Pullup-Widerstand sorgt für eine Minimalspannung auch bei ausgeschaltetem PC.


    nun mein ich nur, ob lirc dass immer und automatisch macht oder man dafür irgentwas konfigurieren muss, ausserdem hab ich das problem, dass bei der LED ~1,8V ankommen,wenn com1 nicht angeschlossen ist. aber vllt hängt das mit 2.) zusammen, werd da mal noch ein wenig testen


    gruß red

  • Hallo,


    1:
    Wenn das bei dir anders ist änder es ab. Ich würde mal tippen, dass man das auch bei LIRC softwareseitig ändern kann, aber da musst du selber gucken.


    2:
    Das Datenblat ist ja auch von TI. Außerdem steht im kleingedruckten:
    C3 can be connected to VCC or GND


    3.
    Beim letzten Modul, dass ich installiert habe, bin ich einfach mit Powersense direkt an 5V (nicht Standby) gegangen. Dort habe ich das Modul mit Schneidklemmen direkt am ATX-Kabel angeschlossen. Das geht so am einfachsten und schnellsten. Normalerweise wird DTR beim öffnen des Comport gesetzt. Ob dein LIRC das macht weis ich nicht. Mess nach oder achte auf die LED.


    Tschüß Frank


  • Problem beseitigt, die Kiste ist zur getimedten Zeit angegangen. Allerdings waren die Timerpausen im VDR anscheinend zu klein gewesen, weshalb der VDR gleich wieder runterfährt?!?


    Hab bisschen mit den Zeitabständen in den Einstellungen rumgespielt und nu klappt auch wieder die Timer aufnahme.


    So long

    Renegade's World, Golf 4 Cabrio
    MEPIABOX: Silverstone LC02s, EPIA M10000B, 512MB Ram, 16GB CompactFlash-IDE, 160GB Samsung SP1614N, FS FF DVB-S rev1.6, TS SkyStar2, AVBoard 1.3, HITACHI DVD-ROM GD-S200 - VDR-Wakeup (K-Data, Jepsen 1.6beta, 4x20 DIL-LCD) - Futaba VFD 2x40 - LinVDR Mahlzeit 3.2
    TV: Samsung LE-46F86BD - 46'' LCD, Full HD, 100Hz

  • so also wollt mich nochmal melden, jetzt sind alle probleme beseitigt und es lüppt alles :)


    für alle die nach mir kommen, hier nochma meine probleme : :)


    1.) lirc hört bei mir auf pin6 anstatt pin1


    2.) falls led2 ständig leuchtet und die "echo" befehle nicht ankommen, kontrolliert doch mal, ob ihr am max die pins 15(gnd) und 16(+5V) angeschlossen habt.
    ich hatte nur gnd vergessen und sehr seltsame fehler^^


    FrankJepsen : bei gelegenheit vllt mal diese 2pins im schaltplan mit einzeichnen, danach hab ich nämlich gebastelt:)
    PS: mich würden auch die sources mal reizen, kannst mir plz das passwort mal senden?



    so bin dann mal scripte schreiben für meinen archlinux-eigenbau-vdr :)


    gruß red

  • Hallo,


    also gut, weil du schon der zweite bist, dem das passiert ist, habe ich einfach mal das GIF entsprechend editiert. Die Original Eagle-Dateien habe ich leider nicht.


    Schön, dass es jetzt auch bei dir läuft.


    Tschüß Frank

  • So nach ner langen nacht hab ich nun endlich rausgefunden, wie ich die kommunikation zwischen archlinux und dem wakeup board hinbekomm, anscheinend werden hier standartmässig andere schnittstellenparameter verwendet.


    lange rede kurzer sinn, so funktionierts bei mir (nach lirc beenden):


    setserial /dev/ttyS2 uart 16550A


    (das A is hier wichtig, bei meinem ubuntu-system gings auch ohne,warum weiß ich noch net :))


    mir fehlt btw ttyS0 und ttyS1 ist comport1, warum weiß ich net :)
    entsprechender comport sowie hardware addresen müssen natürlich angepasst werden, sollten sich per "dmesg|grep ttyS" rausfinden lassen


    mein system:
    Linux server 2.6.23-ARCH #1 SMP PREEMPT Sat Oct 27 09:04:14 UTC 2007 i686 AMD Athlon(tm) AuthenticAMD GNU/Linux


    gruß red