[vdr] VDR developer version 1.3.11

  • Von: Klaus Schmidinger
    An: ML
    Datum: Heute 16:08


    VDR developer version 1.3.11 is now available at


    ftp://ftp.cadsoft.de/vdr/Developer/vdr-1.3.11.tar.bz2


    There won't be any new versions before July 11 because I'm going on vacation :-)


    *** NOTE THAT THE WARNINGS REGARDING THE USE OF VPS CONTROLLED
    *** TIMERS FROM PREVIOUS RELEASE NOTES STILL APPLY!


    The changes since version 1.3.10:


    - In order to avoid problems on NPTL systems, VDR now checks for the presence
    of NPTL at program start, and if it is, exits and tells the user to do
    'export LD_ASSUME_KERNEL=2.4.1' before starting VDR.
    - Revisited the "Fixed missing audio after replaying a DVD" change because it
    introduced a sound disturbance when switching between channels on the same
    transponder (thanks to Marco Schlüßler).
    - In order to avoid problems on UTF-8 systems, VDR now checks for the presence
    of UTF-8 at program start, and if it is, exits and tells the user to turn off
    UTF-8 before starting VDR (thanks to Ludwig Nussel for pointing out a problem
    with systems that are set to use UTF-8). There are also problems in case the
    video partition is mounted with "iocharset=utf8" (thanks to Jörg Knitter for
    reporting this one).
    Please also read the "IMPORTANT NOTES" section in the INSTALL file!
    - Some changes to the SPU decoder interface (thanks to Sven Goethel).
    - Some improvements in cOsd creation (thanks to some suggestions by Jouni Karvo).
    - Fixed calculating the OSD width and height (thanks to Olaf Henkel for reporting
    a problem with long event texts in the "Classic VDR" skin).
    - Fixed switching channels while an encrypted channel is being recorded, because the
    channel was switched if the new channel was on the same transponder and was
    a radio channel or an unencrypted channel (thanks to Martin Dauskardt for reporting
    this one).
    - No longer using the external 'find' command to scan the video directory for
    recordings (based on a suggestion by Mirko Dölle).
    - The list of recordings is now kept statically in memory to avoid long delays
    when opening the "Recordings" menu. As a side effect, external modifications to
    the video directory are no longer immediately reflected in the "Recordings" menu.
    If a plugin manipulates the video directory in any way, it can call the function
    Recordings.TriggerUpdate() to trigger an update of the list of recordings.
    If some external tool manipulates the video directory, it can touch the file
    '.update' in the video directory to trigger an update of the list of recordings.
    - Fixed a memory leak in theme description handling (thanks to Sascha Volkenandt).
    - Added cDevice::Flush() to make sure that all data in the video card's buffers
    has been processed (thanks to Reinhard Nissl). Currently this is not yet actually
    implemented for FF DVB cards.
    - Fixed handling the color button texts in cMenuEditStrItem (thanks to Maynard
    Cedric for reporting this one).
    - Fixed the description of cRingBufferLinear (thanks to Ludwig Nussel for pointing
    out this one).
    - Fixed cRingBufferLinear::Get() in case the buffer wraps around (thanks to Ludwig
    Nussel for reporting this one).


    The DVB driver I am currently using can be found at


    ftp://ftp.cadsoft.de/vdr/Devel…ux-dvb.2003-11-08.tar.bz2


    which is the CVS 'HEAD' version from 2003-11-08, made available as a complete archive for your convenience. Of course, you can also use any newer version from the CVS.


    Have fun!


    Klaus

    Gruß
    Habib


    --------------------------------
    Aufnahme-Server:
    Silverstone Lascala SST-LC10M
    Reel Stable 11.12.2, HDe, 1x 2TB HDD als Aufnahme Server, iVDR 0.3.2 (manuelle Fixe f. Aufnahmeverz.)
    Netceiver mit 3x DUAL DVB-S2
    Clients:
    3x REEL NetClients
    Reel Stable 11.12.2

  • Hallo Klaus,
    vielen Dank, wird noch heute getestet.
    Und viel Spass im Urlaub!!!:prost2
    Gruß
    steini

    1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
    mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
    2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

  • Ich hab den Fehler gefunden, glaube ich.
    Bei mir war auch alles leer, bis auf eine einzige Aufnahme (Zufall...)
    Ich hatte in /video/video_rip/dvd ein 4 GB grosses ISO Image, daran verschluckt er sich wohl....

    Intel D875PBZ, P4 3 GHz (WaKü), 1 GB RAM, TT FF 1.6 (4MB), 3 x TT Nova CI, STB's AVBoard 1.3, CrystalFontz LCD 40x4
    Kernel 2.6.23.9, Fw F12623, ReiserFS, VDR 1.5.12, UFO's refactoring driver
    Plugins: dvd, dvdselect, mp3, mplayer, streamdev, remote, lcdproc, femon, director, vdrrip, epgsearch, graphtft
    Sonstiges: vdradmin, vdrconvert, noad, acpi-wakeup

  • Neue Aufnahmen werden bei mir im Recordings Menü angezeigt. Wenn ich den VDR dann aber neu starte, ist die Übersicht wieder leer...?

    VDR1: Dign HV5 mit Noritake GU 256x64C-3900 VFD,Asus P4B-E, P4 1,8 GHz, 160 GB Samsung SP1614N + 200 GB Samsung SP2014N, 2 FF DVB-S (1x4MB MOD), AV-Board 1.3, WLAN, Debian Sarge 2.6.15, VDR 1.5.2
    VDR2: OrigenAE X15e, Asus P5Q, Intel E5200, MSI N9500 GT, 1 TB Samsung HD103SI, TT S2-3200 + Nova HD-S2, Ubuntu 8.10 + VDR 1.7.0


    VDR3: Mediacenter-Gehäuse mit L4M-Display, DFI LANPARTY JR GF9400-T2RS, Intel E8400, 1 TB Samsung HD103UJ, Digital Devices Cine S2 Rev 5.5, yavdr 0.3.0a

  • JOOOOOO

    Code
    1. - No longer using the external 'find' command to scan the video directory for
    2. recordings (based on a suggestion by Mirko Dölle).


    Darauf habe ich ich schon lange gewartet ;) Und noch ein GRund mehr bald auf die 1.3.x zu wechseln :)


    Tobias

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Quote

    Original von Oxygen
    Neue Aufnahmen werden bei mir im Recordings Menü angezeigt. Wenn ich den VDR dann aber neu starte, ist die Übersicht wieder leer...?


    Stell bitte sicher, daß in deinem Video-Directory nirgens eine Datei ist die größer
    als 2GB ist. Falls du keine solche Datei dort hast, bau bitte mal in cRecordings::ScanVideoDir()
    einige Testausgaben ein um zu sehen, wie weit er da kommt.


    Falls es nicht das 2GB-Problem ist, kann ich mir im Moment nicht recht vorstellen
    woran es liegen könnte...


    Klaus

  • Das mit dem Video Directory ist ja ne schöne Verbesserung. :)





    Kommt irgendwann auch noch ne bessere Verwaltung für doppelte Sender aus verschiedenen DVB-Quellen, wie beispielsweise Kabel+Terrestrisch?

  • @ kls


    Ich habe den VDR eben noch einmal neu gemaked, ohne Plugins und Patches. Jetzt läuft es. Ich werde die anderen Sachen jetzt noch einmal nach und nach einspielen. Eventuell lag es auch daran, dass ich vorhin die .conf Dateien von der 1.3.10 weiterbenutzt hatte.

    VDR1: Dign HV5 mit Noritake GU 256x64C-3900 VFD,Asus P4B-E, P4 1,8 GHz, 160 GB Samsung SP1614N + 200 GB Samsung SP2014N, 2 FF DVB-S (1x4MB MOD), AV-Board 1.3, WLAN, Debian Sarge 2.6.15, VDR 1.5.2
    VDR2: OrigenAE X15e, Asus P5Q, Intel E5200, MSI N9500 GT, 1 TB Samsung HD103SI, TT S2-3200 + Nova HD-S2, Ubuntu 8.10 + VDR 1.7.0


    VDR3: Mediacenter-Gehäuse mit L4M-Display, DFI LANPARTY JR GF9400-T2RS, Intel E8400, 1 TB Samsung HD103UJ, Digital Devices Cine S2 Rev 5.5, yavdr 0.3.0a

  • Ich habe mkdir /video0/old dann mv alles um minimal vdr neu zum starten im /video0 und dann alle dir wieder zur /video0 : ich bekomme dann fast alle meiner Recording???


    Und dann habe ich die Unsichtbar zur old mv : ich kann die im old sehen...

  • den Patch für VDR >=1.3.7 hast aber schon versucht?


    Schau sonst nochmal in Patches Forum, da ist ein Thread mit allen möglichen Patches.... Bei mir läuft das Plugin seit 1.3.7 ohne Probleme mit dem Patch und hat auch unter 1.3.11 keine Auffälligkeiten gezeigt.

    Gruß
    Habib


    --------------------------------
    Aufnahme-Server:
    Silverstone Lascala SST-LC10M
    Reel Stable 11.12.2, HDe, 1x 2TB HDD als Aufnahme Server, iVDR 0.3.2 (manuelle Fixe f. Aufnahmeverz.)
    Netceiver mit 3x DUAL DVB-S2
    Clients:
    3x REEL NetClients
    Reel Stable 11.12.2

    The post was edited 1 time, last by Habib ().

  • Was für Fehler bekommst du denn? Wie gesagt läuft hier ohne Probs...

    Gruß
    Habib


    --------------------------------
    Aufnahme-Server:
    Silverstone Lascala SST-LC10M
    Reel Stable 11.12.2, HDe, 1x 2TB HDD als Aufnahme Server, iVDR 0.3.2 (manuelle Fixe f. Aufnahmeverz.)
    Netceiver mit 3x DUAL DVB-S2
    Clients:
    3x REEL NetClients
    Reel Stable 11.12.2

  • Folgendes steht im log:
    Jun 20 10:59:41 MuMi vdr[12573]: loading plugin: ./PLUGINS/lib/libvdr-streamdev-server.so.1.3.11
    Jun 20 10:59:41 MuMi vdr[12573]: ERROR: ./PLUGINS/lib/libvdr-streamdev-server.so.1.3.11: undefined symbol: _ZN11cRecordings4LoadEb


    Ich hab allerdings den gepatchten Plugin-Source von der 1.3.10 einfach rüberkopiert. Aber da der Patch ja nur PLugin interna patched, sollte das ja kein Problem sein, oder?