Tonstörungen bei Aufnahme

  • Hallo,


    gestern habe ich zum ersten Mal das Teil aufnehmen lassen. Heute habe cih es mir angeschaut.


    In unregelmässigen Abständen, kackt und zirpt der Ton.


    Ich habe folg. Ausstattung

    - DVB-S Karte
    - Epia 6000
    - 30gb HDD (2,5") --> event. zu langsam ????
    - 128MB --> event. zuwenig ???
    - Suse 8.1
    - Treiber ud Software aktuell von dieser Seite !


    Hat jemand eine Idee ?


    Danke
    R.

  • Hi


    128MB sollten langen!
    die HDD könnte sein


    mach mal


    hdparm -tT /dev/hdx
    (hdx ist die platte)


    hda -> IDE1, Master
    hdb -> IDE1, Slave
    .......


    Werte unter 5MB/s sollten bedenklich sein, da sonst der Datenstrom nicht ohne aussetzer aufgenommen werden kann!
    Meine Platten haben 32 bzw 28 MB/s


    Es kann aber auch eine nicht ganz Optimal ausgerichtete Schüssel sein!

  • Hi Dirk,


    hier das Ergebniss des Drive Tests ...


    Timing -Buffer-Cache-reads : 128MB in 1,27 sec = 64,97MB/s


    Timing-Buffer-Disk-reads : 64MB in 21,49 sec = 2,98MB/s


    mmmmmhhhh.....


    Ist der 2'te Wert zu niedrig ?


    Gruss
    R.

  • Hi


    EINDEUTIG!!!!!


    gibt mal nur


    hdparm /dev/hdx


    ein!


    Dann kannst du sehen, ob der DMA-modus eingeschalten ist :D:D:D

  • Hallo


    Hab das vorhin auch mal gemacht


    Festplatte: 24,15 MB/s (ok, aber mit Aufnhemen hatte ich nie probs)


    Aber mit (S)VCDs hatte ich des öfteren Probleme mit meinem CD-Rom


    herausgekommen ist: 3,72 MB/s


    Ist das eventuell zu wenig? Der Film spinnt bei SVCDs immer nach einer Zeit. Wenn ich ein anderes Laufwerk einbaue, geht das aber.

    PIII 500, 128 MB RAM, Voodoo Banshee
    Nexus-s, Nova-s, SB Live 1024, 40x4 LCD, 80 GB Festpaltte

  • Hi


    3,7MB/s (ca. 24fach-Laufwerk) reicht bei (S)VCD


    Es kann aber sein, das das Laufwerk evtl. etwas Probleme mit der Fehlerkorrektur hat und die geschwindigkeit an den Stellen zu weit drosseln muß.

  • Ich glaube das waar's !


    Das Ergebniss :


    multicount = 0 (off)
    IO Support = 0 (16 Bit)
    unmaskirq = 0 (off)
    using_dma = 0 (off)
    keepsettings = 0 (off)
    readonly = 0 (off)
    readahead = 8 (on)


    DMA schalte ich im BIOS ein, richtig ? Oder gibt es bei Linux die möglichkeit das auch so zu enablen ???


    Thx
    R.

  • Hi


    kannst ja mal schauen, ob es für das Laufwerk ne neue Firmware gibt!
    Kann sich oft positiv auswirken(aber vorher das alte sichern!!!)!

  • Quote

    Original von rur
    DMA schalte ich im BIOS ein, richtig ? Oder gibt es bei Linux die möglichkeit das auch so zu enablen ???


    R.


    Hi,


    hdparm -d1 /dev/hdx ist dein Freund. Im BIOS sollte DMA aber enabled sein.


    Gruß


    Sven


    Link: Richtig fragen

  • Hi


    Danach auf alle Fälle nochmal die Geschwindigkeit mit


    hdparm -tT /dev/hdx


    testen

  • So ....


    mom ....


    Das ist das Ergebnis _


    - Setting using DMA to 1 (on)
    - HDIO_SET_DMA failed : operation not permitted
    - using_dma = 0 (off)


    Im Bios ist DMA eingeschaltet, habe ich gerade nachgesehen.


    8-(((
    R.

  • Hi


    Puhhh, da wirds jetzt zu viel für mich!!!


    ich seh da jetzt nur 2 möglichkeiten


    1. der Kernel unterstützten den IDE-Kontroller nicht richtig (Typ???, eingebunden???)
    2. die Platte macht kein DMA (wäre nicht gut)


    ansonst, muß jemand anderes ran!!!

  • Hier mal die Produktbeschreibung der Platte (Fujitsu MHS2030)
    ------------------------------------
    Das Laufwerk verfügt über modernste Fujitsu `Head Load/Unload´ Kopf-Technologie und `Fluid Dynamic Bearing´ Flüssigkeitslager. Entsprechend sind die geringen Geräuschpegel von 2,7 bels kaum hörbar. Die Festplatte unterstützt die Ultra ATA100 Schnittstelle, bietet eine durchschnittliche Zugriffszeit von 12 ms und eine maximale Datenübertragungsrate von 38,1 MB/s.


    Im Vergleich zu Vorgängermodellen überzeugt diese neue Version durch höhere Leistung und Robustheit mit einer Stoßfestigkeit von 900G. Zu den MHS2 Einsatzbereichen gehören u.a. industrielle Steuerungssysteme, Computeranlagen in Autos, MP3-Players, Spielkonsolen sowie Videoanwendungen in Notebooks und Desktop-PCs.
    ------------------------------------
    ATA 6
    ------------------------------------


    Wie kann ich nachschauen ob im Kernel der IDE DMA eingebunden ist ? War das menuconfig ???


    Der IDE Controller ist ein VIA Chip. Daran habe ich auch gedacht. Die Patches sind die allerletzten die SUSE rausgebarcht hat. Gibt's event aktuellere VIA Treiber direkt für Linux ???


    Gruss
    R.

  • Quote

    Original von rur
    Wie kann ich nachschauen ob im Kernel der IDE DMA eingebunden ist ? War das menuconfig ???


    Ja, "make menuconfig" oder, wenn Du X am laufen hast, "make xconfig"


    Die Optionen findest Du unter "ATA/IDE/MFM/RLL support" -> "IDE,ATA and ATAPI Block devices"

  • Er gibt mir


    - no rule to make menuconfig


    aus. ich denke ab hier lasse ich besser n Profi ran ...
    Ich bin ja schon froh, das das Teil so läuft.


    Abschiessen durch mein 1/100 Wissen möchte ich es nicht !


    Danke Euch schon mal vorab, die Richtung wo ich suchen muss ist abgesteckt ...


    Aber ich ahbe es zumindest geschafft den VDRadmin zu installieren 8-)) wenigsten ein Erfolgserlebis


    Thx
    R.

  • Hi


    make menuconfig


    must du in


    /usr/src/linux


    ausführen! sonst geht nix!

  • hallo,
    ich weiß nicht, ob Ihr die letzte ct gelesen habt. Dort wird im Beitrag über den VDR nochmal über die IDE Probleme in aktuellen Kerneln hingewiesen. Ich zitiere mal: ct 7/2003 Seite 198.
    "........... Im Lauf der Zeit hat sich herausgestellt, das der Linux-Kernel 2.4.20 immer noch Probleme mit IDE und UDMA hat. Beim Start handelt das BS für identische Platten unterschiedliche UDMA-Modi aus. Vor allem Platten mit UDMA 5 meldeten dann unter Last Fehler (CRC Error) was zur Folge hat, das der Kernel DMA für diese Platten ganz abschaltet. Das senkte die Leserate auf inakzeptable 2 MByte/s. Nachdem wir beim Systemstart UDMA mit /sbin/hdparm -d1 -X67 /dev/hd[c-h] auf den konservativen Mode 3 fixierten, verschwand der Spuk und die Leserate stabilisierte sich auf 30 MByte/s. Da der Video Server keine hohen Anforderungen stellt, reicht das vollkommen aus.........."


    vielleicht hat Deine Platte auch so ein Problem.


    Gruß lola

  • Hi


    6MB ist zwar uch noch wenig, aber schon viel besser!!!


    Hmm, ich weis jetzt nicht, wo das unter Susi geht, aber bei Gentoo, kannst du solche sachen in der local.start eintragen.
    Bei mir ist die unter /etc/conf.d