vdradmin ????

  • Wenn ich meinen VDR neu starte, kann ich bei vdradmin zwar die Autotimer Liste, den Fernseher, die Ferbedienung, die Aufnahmen sehen und auch bedienen.


    Das laufende Fernsehprogramm und die Übersicht werden aber nicht angezeigt.


    Was ist da los ??? Was mach ich falsch ???

  • Keine Panik, nach dem Einschalten des VDR benötigt vdradmin etwa 10 Minuten, bis alle Daten da sind. In diesen 10 Minuten funktioniert in der Tat die Programmvorschau nicht. Einfach warten!


    PS: Der Grund ist, dass vdradmin sich die Daten nicht aus einer Datei ausliest, sondern mühsam per Abfragen an den VDR einzeln zusammenbauen muss.

  • Quote

    Original von Demnos
    PS: Der Grund ist, dass vdradmin sich die Daten nicht aus einer Datei ausliest, sondern mühsam per Abfragen an den VDR einzeln zusammenbauen muss.


    hm? da wäre ich mir nicht so sicher, den du gibst ja in der vdradmin.conf exakt an wo das epg-File liegt. Diese Einstellung wäre dann ja vollkommen unsinnig :)

  • Danke für die Hilfe ! (Diesmal nur eins !!!!!!)


    Hat sich mittlerweile erledigt. Die Daten sind wieder da ! Hat zwar etwas länger als 10 min gedauert, aber das macht ja nix, wenn man weiß, daß es halt einen Moment dauert.

  • Quote

    hm? da wäre ich mir nicht so sicher, den du gibst ja in der vdradmin.conf exakt an wo das epg-File liegt. Diese Einstellung wäre dann ja vollkommen unsinnig


    Laut diversen Threads macht vdradmin einen connect auf den vdr port 2001 und gibt ein svdrp Kommando LSTE. Daraufhin erhält er eine Liste der Daten, kann man also auch per Telnet selber mal ausprobieren.


    Vielleicht legt er sich dann diese Daten in eine Datei, die man in "vdradmin.conf" angeben kann?


    Im übrigen habe ich auf meiner gesamten Festplatte (mit vdradmin 0.95 c't/Tobi) keine Datei namens vdradmin.conf (gerade mit find gesucht). Allenfalls eine vdradmind.conf, aber dort findet sich KEINE angabe bzgl. eines epg files....Was steht denn in Deiner Datei drin?

  • Quote

    Im übrigen habe ich auf meiner gesamten Festplatte (mit vdradmin 0.95 c't/Tobi) keine Datei namens vdradmin.conf (gerade mit find gesucht). Allenfalls eine vdradmind.conf, aber dort findet sich KEINE angabe bzgl. eines epg files....Was steht denn in Deiner Datei drin?


    Ja, ich meinte die vdradmind.conf.
    Bei mir gibt's da eine Zeile:

    Code
    1. EPG_FILENAME = /video/epg.data

    Gruß, Nugman

  • Interessant, diese Zeile fehlt bei mir. Aber die Daten landen trotzdem in /video/epg.data, muss also ein Default sein. Nichtsdestotrotz ist das wohl die Zieldatei wo vdradmin die Daten hinschreibt, nachdem es sie über LSTE empfangen hat...glaube ich ;-)

  • Quote

    Original von dr.Jones
    Wenn ich meinen VDR neu starte, kann ich bei vdradmin zwar die Autotimer Liste, den Fernseher, die Ferbedienung, die Aufnahmen sehen und auch bedienen.


    Das laufende Fernsehprogramm und die Übersicht werden aber nicht angezeigt.


    Was ist da los ??? Was mach ich falsch ???


    Hallo,


    ich habe exakt das gleiche Problem.


    VDRadmin startet nach der Methode von Hubertus.


    Nur wenn ich den VDRadmin über /etc/init.d/vdradmind restart neu starte
    werden "was läuft jetzt?" und die "Programmübersicht" angezeigt.


    - Also keine Wartezeit nötig -



    Hier ein Auszug aus meiner vdradmind.log:


    Nach dem Start des VDR:
    21.06.2004 17:08:33: Auto Timer: Scanning for events...
    21.06.2004 17:08:33: Auto Timer: Done.
    21.06.2004 17:10:39: Auto Timer: Scanning for events...
    21.06.2004 17:10:39: Auto Timer: Done.
    21.06.2004 17:12:06: 192.168.0.55 - vdr [21/Jun/2004:17:12:06 +0100] "GET / HTTP/1.1" 200 573 "/" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8"
    21.06.2004 17:12:06: 192.168.0.55 - vdr [21/Jun/2004:17:12:06 +0100] "GET /vdradmin.pl?aktion=prog_summary HTTP/1.1" 200 1534 "/vdradmin.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8"
    21.06.2004 17:12:08: 192.168.0.55 - vdr [21/Jun/2004:17:12:08 +0100] "GET /vdradmin.pl?aktion=prog_summary HTTP/1.1" 200 1534 "/vdradmin.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8"
    21.06.2004 17:13:05: 192.168.0.55 - vdr [21/Jun/2004:17:13:05 +0100] "GET /vdradmin.pl?aktion=prog_summary HTTP/1.1" 200 1534 "/vdradmin.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8"
    21.06.2004 17:13:44: 192.168.0.55 - vdr [21/Jun/2004:17:13:44 +0100] "GET /vdradmin.pl?aktion=prog_summary HTTP/1.1" 200 1534 "/vdradmin.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8"


    Nach dem Restart:
    21.06.2004 17:14:14: Auto Timer: Scanning for events...
    21.06.2004 17:14:14: Auto Timer: Done.
    21.06.2004 17:14:16: 192.168.0.55 - vdr [21/Jun/2004:17:14:16 +0100] "GET /vdradmin.pl?aktion=prog_summary HTTP/1.1" 200 34668 "/vdradmin.pl" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8"



    Kann man aus dem Logfile was ersehen?


    Wie könnte man das Problem lösen? - Hab leider hier im Forum nichts gefunden.


    Gruß
    beko


    VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
    VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
    VDR 3: Samsung SMT7020, Zen2VDR > Tochter

  • Hat keiner eine IDEE?


    VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
    VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
    VDR 3: Samsung SMT7020, Zen2VDR > Tochter

  • Quote

    Original von beko
    Hat keiner eine IDEE?


    Hi,
    doch, aber das wurde in diesem Board schon öfters durchgekaut, und es wundert mich, dass Du bei Deiner Suche nix gefunden hast.


    Erklärung in Stichworten:
    - vdradmin liest in festen Zeitintervallen die EPG-Daten vom vdr.
    - Wird er vor dem vdr gestartet, findet er nix, und es ist erst ein paar Minuten nix zu sehen.
    - Wird er nach vdr gestartet, ist sofort was zu sehen.

  • Ja - Hab nach erneuter Suche doch was gefunden.


    Ich starte jetzt vdradmin über die runvdr nach der Methode von gigabit:
    (http://www.vdrportal.de/board/thread.php?threadid=8692&sid=&hilight=VDRadmin+nach+VDR+starten)



    Danke an TheAlamo und an gigabit für die ausführliche Beschreibung.


    VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
    VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
    VDR 3: Samsung SMT7020, Zen2VDR > Tochter

  • hi,
    um das ganze ein wenig aufzuklären:
    der "normale" vdradmin nimmt die daten über LSTE über svdrp. das kann etwas länger dauern.
    aber der gepatchte vdradmin (z.B. BigPatch, diverse andere versionen) haben den DirectEPG-Patch mit drin. damit greift der vdradmin direkt auf die epg.data zu. das ist scheinbar schneller - da hab cih aber keine erfahrung mit.

  • Hi Folks,


    bei mir ist immer alles sofort da. Das war aber nicht immer so, denn früher habe ich vdradmin vor vdr gestartet und dann durfte ich manchmal auch recht lange warten.


    Also: Einfach vdradmin starten, NACHDEM vdr gestartet wurde, und siehe da:


    Alle Einträge sind sofort da . :]


    Gruß, Martin

    eXperience - vdr: P4S-533MX, 512 MB RAM, 2,4 GHz Cel., 120 GB Samsung, AVBOARD, Feegy 240x128, Gehäuse Marke Eigenbau
    Fedora Core 1 - vdr 1.2.6 - Kernel 2.4.25 - TT DVB-S 1.5

  • Hallo Kaiserm,


    Du schreibst, das bei der Reihenfolge, zuerst Start vdr dann vdradmin sofort alle EPG-Daten vorhanden sind. Ich habe bei dieser Reihenfolge trotzdem noch das Problem, das im vdradmin für einige Sender für einen gewissen Zeitraum keine EPG-Daten angezeigt werden während sie im OSD sofort vorhanden sind. Gibt es hierzu auch Erfahrungen?

    Gruß Martin
    ____________________
    Mein VDR: KBBV3+/66-Board, AMD K6 2-450, 524MB, 80GB, Suse 8.1, VDR 1.2.6, Nexus s

  • Hi,


    EPG-Daten werden nur aktualisiert, wenn du auch mal auf den dazugehörigen Sender (oder auf den Transponder) zappst.


    Manche Sender liefern nur EPG-Daten für 1 Tag im voraus. Wenn du dann einen Tag mal nicht auf diesen Sender zappst, sind auch keine EPG-Daten mehr für vdradmin vorhanden.


    Sobald du auf den Sender zappst, holt er sich die EPG-Daten und zeigt sie dir auch im OSD an.

    vdr1: MediaPortal mit AVT-Board, Celeron 566, 256MB, 2 x 120GB Samsung SV1203N, DVB-S Rev. 1.3 mit AV-Board unter SuSE 10.1, vdr 1.4.3, vdradmin-am 3.4.7
    vdr2: Coolermaster ATC600 mit K7VM4, Duron 1600, 256 MB, 2 x 160GB Samsung, 2 x Activy Budget, SuSE 10.1, vdr 1.4.1, vdradmin-am 3.4.7 (reines Aufnahmegerät)
    Dbox: Nokia Dbox2 mit Neutrino