Mal wieder Skystar2

  • Hallo Kollegas,


    ich weiss das das Thema Skystar schon mehrfach besprochen wurde, aber irgendwie haben mir die gefundenen Beitraege nicht so recht geholfen. Aus diesem Grund, neuer Threat-neues Glueck? ;D


    Also, hab seit ein paar Tagen ne Skystar 2 neben einer Nexus eingebaut. Als vdr ist die ct Version, Multipatch 1.2.6-18 installiert.


    Da die Skystar mit den alten DVB Treibern nicht lief, hab ich die aktuellsten installiert. Ein insmod skystar2 klappt auch fehlerfrei.


    Also modconf aufgerufen und die skystar2 im misc Paket ausgewaehlt und neu gebootet. Nun mosert aber der vdr beim starten.

    Code
    1. Mar 26 10:31:51 tyvdr001 vdr[632]: no DVB device found
    2. Mar 26 10:31:51 tyvdr001 vdr[632]: ERROR: invalid primary device number: 1
    3. Mar 26 10:31:51 tyvdr001 vdr[632]: ERROR: no primary device found - using first device!
    4. Mar 26 10:31:51 tyvdr001 vdr[632]: ERROR: invalid primary device number: 1
    5. Mar 26 10:31:51 tyvdr001 runvdr: stopping after fatal fail (vdr: no primary device found - using first device!)


    dmesg sagt aber, das beide Karten gefunden werden


    lsmod gibt aus:


    Was laeuft da falsch? Was kann ich tun?


    Piti

  • Quote

    Original von 8N1
    Hi


    versuch mal die DVB-Karten umzustecken ( Plätze tauschen ). Hat bei mir geholfen.


    Gruß Tom


    hoi
    ging bei mir genauso ... Karte tauschen oder anderen PCI Slot nehmen


    bei mir läuft unter Linvdr06 Sky2.6C + Nexus2.1 1a


    HJS

  • Hi,


    brachte leider nichts.
    Ich hab bei der Installation der DVB Treiber einen Hinweis gesehen das man Firmware Dateien braucht.....wo krieg ich denn die her? Oder sind die bei dem Treiberpaket dabei?


    Nochwas ist mir aufgefallen. Es gibt bei modconf noch ein modul dvbdev, das kann ich nicht einbinden. Keine Ahnung ob das so muss?!


    Code
    1. /lib/modules/2.4.24-ctvdr-2/misc/dvbdev.o: init_module: Input/output error
    2. Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
    3. /lib/modules/2.4.24-ctvdr-2/misc/dvbdev.o: insmod /lib/modules/2.4.24-ctvdr-2/misc/dvbdev.o failed
    4. /lib/modules/2.4.24-ctvdr-2/misc/dvbdev.o: insmod dvbdev failed
    5. Installation ging schief.


    hjs , kannst du mal lsmod ausfuehren und mir das ergebniss schreiben?



    Piti

  • Hallo Leutz!


    piti
    Die Firmware gibts bei linuxtv.org oder Du ziehst Die Dpram und Root
    aus ner älteren Treiberversion und erstellst Dir deine Firmware selbst.
    Im Unterverzeichnis scripts gibts dazu ein Tool.


    Ausserdem scheinst Du für die Skystar das falsche Frontend geladen zu
    haben, bis rev. 2.3 ist es mt312, ab rev.2.6* stv0299.
    Schau mal in die README zum Treiber.

    FSC Primergy TX 300 S4 | 2 x Intel(R) Xeon(R) CPU X5460 @ 3.16GHz | RAM 16GB | VDR-SERVER | Centos 7 Kernel-4.19.0 | DVBSky S952 v3 & DVBSKy S950 v3 | VDR-2.2.0 | iptv, dummydevice, dvbhddevice, svdrposd, streamdev-server.
    Raspbery Pi 1 Model B + | Debian wheezy Kernel-4.4.50+ | VDR-2.2.0 | epgsearch, remotetimers, skinsoppalusikka, svdrpservice, mailbox, rpihddevice, sleeptimer, osdteletext, streamdev-client
    Raspbery Pi 2 - Model B | Debian jessie Kernel-4.4.50-v7+ | VDR-2.2.0 | epgsearch, remotetimers, skinsoppalusikka, svdrpservice, mailbox, rpihddevice, sleeptimer, osdteletext, streamdev-client


  • Quote

    Original von piti
    hjs , kannst du mal lsmod ausfuehren und mir das ergebniss schreiben?
    Piti


    sicherlich , aber bedenke : habe linvdr installiert , das hat in der 0.6er Version den 2.6er Kernel


    Geduld Rechner zu haus , hier Arbeit , folgt :D

  • Moin,


    armageddon , Danke, schau ich mir an. Auch die ReamMe, versprochen. Mal schauen ob ich daraus schlau werd. :D


    hjs , kein Problem. Mittlerweile weiss ich an welcher Stelle ich drehen muss damit zumindest die Haupauge laeuft.


    wenn ich in /etc/modules skystar2 zufuege ist die Haupauge aus dem rennen.


    Nur zur Info, ich lese normal ungern readme Dateien, ich probier normal alles einfach aus. Da wird mal da gedreht, mal da was geaendert. Bisher bin ich da gut mit gefahren. Aber hier spielen vermutlich mehrere Komponenten zusammen, es reicht augenscheinlich nicht an nur einer Stelle was zu aendern........


    Bloed. :rolleyes:

  • Quote

    Original von piti
    hjs , kein Problem. Mittlerweile weiss ich an welcher Stelle ich drehen muss damit zumindest die Haupauge laeuft.


    wenn ich in /etc/modules skystar2 zufuege ist die Haupauge aus dem rennen.


    hier trotzdem meine lsmod , soweit für dvb zuständig :
    Module Size Used by
    budget_av 7040 0
    budget_ci 7424 0
    budget 6272 0
    budget_core 7808 3 budget_av,budget_ci,budget


    dvb_ttpci 300704 5
    ttpci_eeprom 3200 2 budget_core,dvb_ttpci


    skystar2 24960 0
    saa7146_vv 46208 3 budget_av,dvb_ttpci
    saa7146 18716 6 budget_av,budget_ci,budget,budget_core,dvb_ttpci,saa7146_vv
    mt312 7424 0
    cx24110 8192 0
    grundig_29504_491 6016 0
    grundig_29504_401 6400 0
    tda1004x 14340 0
    ves1820 7684 0
    stv0299 12416 0
    alps_tdmb7 6016 0
    alps_tdlb7 8452 0
    ves1x93 7428 0
    dvb_core 60544 56 budget,budget_core,dvb_ttpci,skystar2,mt312,cx24110,grundig_29504_491,grundig_29504_401,tda1004x,ves1820,stv0299,alps_tdmb7,alps_tdlb7,ves1x93
    video_buf 20864 1 saa7146_vv
    v4l2_common 6656 1 saa7146_vv
    v4l1_compat 14080 1 saa7146_vv
    videodev 10240 2 saa7146_vv
    evdev 10368 1


    vielleicht ist die Reihenfolge des Ladens noch interessant :


    ich füge sky vor ttpci eeprom in die runvdr ein

  • Hi Piti,


    den Fehler hatte ich zu Beginn auch. Wichtig ist, dass die alten Treiber alle entfernt wurden. Bei mir hat das über modconf ganz gut geklappt (dort unter: /misc). Da die einzelnen Kernelmodule voneinander abhängen muss man ein wenig probieren.


    Kannst auch noch einmal hier schauen:
    http://www.vdrportal.de/board/thread.php?threadid=13617&sid=


    Außerdem habe ich gleich auf die Treiber-Version 1.1.1 gewechselt. Seitdem läuft eigentlich alles super!


    Ich hoffe das hilft dir irgendwie weiter!


    Viele Grüße,
    Max


    VDRClient [MLD] auf RaspberryPi mit LIRC+IR-Einschalter (mit Arduino Pro Mini)
    Amazon FTV 2 [Kodi 15.x] als VDR-Streaming-Client
    Headless VDR [Ubuntu 14.04LTS mit VDR 2.2.0] mit Digital Devices Octopus mit 2x DVB-S2 DuoFlex-Karten

  • Nabend,


    ich hatte schon versucht auf die 1.1.1 Treiber upzudaten, leider auch ohne Erfolg.
    Diemal hab ich mich an die README gehalten, hat mir auch nichts geholfen.
    Die Treiber soll man ja mit make kompilieren. Die stiegen recht schnell mit "Hey Daemel, installier doch mal die Kernelsourcen" aus.
    Kein Problem, hab ich die runtergeladen und unter /usr/src entpackt.
    Als naechstes kam dann, ich muesse in den Kernel nachladbare Module einrichten. Also make menuconfig, make dep, make modules und make modules install eingegeben, nachdem ich den Modulsupport aktiviert hatte. Oh Wahnsinn, nachdem der Kernel fertig uebersetzt war konnte ich neu booten, ohne Fehler! Nun meinten aber die DVB Treiber sie waeren fuer Kernel 2.4.24 kompiliert, es waere aber Kernel 2.4.24-ct-2 installiert. Da hab ich dann aufgegeben.


    Ich denke ich warte einen Monat, bis dahin gibts die Treiber sicher zum "atp-get upgrade"n.


    Helfen koennte mir aber evtl. noch deine modules, modules.conf und runvdr.
    Ich werd das Gefuehl nicht los das das der Knackpunkt bei meinem Problem ist.


    Piti

  • Juchuuuuu,


    geschafft. Nachdem ich dann bemerkt hab das es den 1.1.1 Treiber schon per apt-get zum installieren gibt, hab ich nun meine Skystar am start.


    Vielen Dank an alle die geholfen haben!


    Dafuer geb ich ein virtuelles Bier aus. :prost2


    Piti

  • Quote

    Original von piti


    geschafft. Nachdem ich dann bemerkt hab das es den 1.1.1 Treiber schon per apt-get zum installieren gibt, hab ich nun meine Skystar am start.


    Piti


    hallo,


    welches repository hast du eingestellt. ich kann den 1.1.1 -treiber nicht finden.


    pfiffi

    Baustelle: MSI 760GM-P33, Phenom II X2, 4GB, 2TB
    TT S2-6400 + TT Budget S2-1600
    Ubuntu HD VDR mittels TechnoTrend S2-6400


    Noch in Betrieb:
    MSI Hermes 651, Celeron 2GHz, WINTV Nexus-s, Twinhan VisionPlus,
    HD 160GB Samsung + 300GB Diamondmax
    VDR c't-vdr 6

  • Nabend,


    hier meine sources.list:


    tyvdr001:~# cat /etc/apt/sources.list
    # See sources.list(5) for more information, especialy
    # Remember that you can only use http, ftp or file URIs
    # CDROMs are managed through the apt-cdrom tool.


    # public servers
    deb http://ftp.de.debian.org/pub/debian stable main
    deb http://ftp.de.debian.org/pub/debian-non-US stable/non-US main


    # Mirror of Security updates for "stable"
    deb http://security.debian.org/ stable/updates main contrib non-free


    # Tobi's Repository
    deb http://www.e-tobi.net/vdr/testing/binary vdr/multipatch/
    deb http://www.e-tobi.net/vdr/testing/binary addons/
    deb http://www.e-tobi.net/vdr/testing/binary backports/
    deb http://www.e-tobi.net/vdr/testing/binary base/


    # neues c't-Repository
    deb ftp://ftp.heise.de/pub/ct/projekte/vdr/testing/binary base/
    deb ftp://ftp.heise.de/pub/ct/projekte/vdr/testing/binary backports/
    deb ftp://ftp.heise.de/pub/ct/projekte/vdr/testing/binary addons/


    # Christian Marillats Repository für einige Multimedia-Bibliotheken
    deb ftp://ftp.nerim.net/debian-marillat/ stable main


    # Source-Pakete Tobi's Repository
    deb-src http://www.e-tobi.net/vdr/testing/source/ vdr/
    deb-src http://www.e-tobi.net/vdr/testing/source/ base/
    deb-src http://www.e-tobi.net/vdr/testing/source/ backports/
    deb-src http://www.e-tobi.net/vdr/testing/source/ addons/


    # Source-Pakete neues c't-Repository
    deb-src ftp://ftp.heise.de/pub/ct/projekte/vdr/testing/source vdr/
    deb-src ftp://ftp.heise.de/pub/ct/projekte/vdr/testing/source base/
    deb-src ftp://ftp.heise.de/pub/ct/projekte/vdr/testing/source backports/
    deb-src ftp://ftp.heise.de/pub/ct/projekte/vdr/testing/source addons/


    dann
    apt-get update
    apt-get install linuxtv-dvb-modules-2.4.23-ctvdr-3


    Schau auch mal hier, das hat mich gehelft. :]
    http://www.vdr-portal.de/board/thread.php?threadid=14134&sid=&hilight=skystar2


    Piti

  • Quote

    Original von piti
    Nabend,


    hier meine sources.list:


    Piti


    Danke!


    Leider funzt es bei mir noch nicht.


    Ich habe kräftg upgedatet, mit dem erfolg, dass ich mit modconf die skystar 2 rev 2.6c einbinden kann. die treiber werden offensichtlich auch geladen, aber die nexus geht dann nicht mehr. wenn ich in /etc/modules die skystar2 auskommentiere, geht die nexus wieder, aber natürlich nicht die skystar2. auch das tauschen der steckplätze hat nix genutzt.


    wenn ich die diskussion richtig verfolgt habe, kann das an der reihenfolge des ladens liegen, aber wo verändere ich die?


    gr.
    pfiffi

    Baustelle: MSI 760GM-P33, Phenom II X2, 4GB, 2TB
    TT S2-6400 + TT Budget S2-1600
    Ubuntu HD VDR mittels TechnoTrend S2-6400


    Noch in Betrieb:
    MSI Hermes 651, Celeron 2GHz, WINTV Nexus-s, Twinhan VisionPlus,
    HD 160GB Samsung + 300GB Diamondmax
    VDR c't-vdr 6

    The post was edited 1 time, last by pfiffi ().

  • Hi,


    also ich kann leider nicht viel dazu sagen, nur auf obigen Threat verweisen. Ich hab den vdr gestoppt, den neuen Kernel eingespielt, die DVB Treiber ebenfalls. Dann wirst du gefragt ob du nach Karten scannen lassen willst. Das habe ich bejaht. Danach lief alles.
    Die Probleme die du beschreibst hatte ich genauso, es lag zu 100% an den falschen Treibern fuer die Karte.


    Viel Glueck noch!


    Piti