[cecremote] Neuer SamsungTV nur mit laufenden CEC-CLIENT?

  • Hallo,


    viele Jahre hat die VDR-Steuerung mit cec-remote über meinen alten 40 Zoll Samsung TV tadellos funktioniert. Nun musste dieser aber weichen und wurde durch einen neuen Samsung Q60B ersetzt.

    Mal abgesehen, dass die Fernbedienung nix taugt (hab glücklicherweise noch die alte) geht erst mal die VDR-Steuerung nicht mehr. Beim alten TV wurde mein Raspberry Pi 3B+ ganz alleine erkannt, beim neuen irgendwie nicht mehr bzw. nicht mehr richtig. Auch im Log vom cec-remote sehe ich nichts besonderes, aber auch keinen Tastendruck von der Fernbedienung mehr.

    Beim Fehlersuchen hab ich testweise mal cec-client gestartet und dort sehe ich wenn ich eine Taste drücke.


    Nun aber der komische Effekt:

    Solange cec-client auf dem RPI läuft, funktioniert auch die VDR-Steuerung. Beende ich cec-client, dann geht auch sofort die VDR-Steuerung nicht mehr. Dies kann ich auch reproduzieren.

    Initialisiert eventuell cec-client die Verbindung richtig bzw. besser als cec-remote das macht? Ich werde nun als Workaround versuchen das cec-client per Startskript mit zu starten, aber eine dauerhafte Lösung ist das vermutlich nicht.


    Hat Jemand, insbesondere Ulrich eine Idee warum ich cec-client starten muss, damit die Steuerbefehle am vdr-Plugin ankommen?

    Der Versuch einen anderen HDMI-Anschluss zu verwenden oder die N400 Soundbar ab zu stecken hat keine Änderung gebracht.

    Hier mal noch ein paar Infos zum System:

    - 2x RPI 3B+ mit Raspbian OS Buster und rpihddevice + 1x Headless-VDR-"Server" mit Dual-DVB-S2 (im Keller)

    Installierte Pakete (Auszug):

    ii vdr 2.4.1-4~etobi2 armhf Video Disk Recorder for DVB cards

    ii vdr-plugin-cecremote 1.4.0+git20200824-1 armhf VDR Plugin to support remotes via CEC

    ii cec-utils 4.0.4+dfsg1-2+rpi1+rpt1 armhf USB CEC Adaptor communication Library

    ii libcec4:armhf 4.0.4+dfsg1-2+rpi1+rpt1 armhf USB CEC Adaptor communication Library

    Da ich jedoch mit manchen Updates Probleme habe, insbesondere mit rpihddevice und/oder kodi (vermutlich wegen kms?) habe ich schon länger kein Update mehr gemacht. -> Never change a running system. Deswegen will ich jetzt idealerweise nicht alles neu aufsetzen sondern lieber gezielt nach der Ursache suchen. Logischerweise kann ich aber testen indem ich ein Backup der SD-Karte mache.

    Detaillierte Logs kann ich auch noch liefern wenn gewünscht/sinnvoll.


    Viele Grüße

    Sinclair

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!