Softhddevice aktuelle Version 1.9.5: ZDF HD und ZDF Neo HD ruckeln...

  • Hollo Zusammen,


    ich nutze mittlerweile MLD 5.5 testing auf einigen meiner VDR's und habe zusammen mit anderen MLD-Usern das Problem, dass seit einigen Tagen nach einem Dist-Upgrade bei den Sendern ZDF HD und ZDF Neo HD sofort nach dem Umschalten auf diese Sender das Bild zu ruckeln beginnt.

    Außerdem gibt es Artefakte und Tonstörungen.


    Wir konnten im MLD-Forum eingrenzen, dass dieses Problem seit dem Update von softhddevice auf die Version 1.9.5 besteht.

    Bei den Versionen 1.9.3 und 1.9.4 tritt das Fehlerbild noch nicht auf.


    Hier mal der Link zu diesem Thema im MLD-Forum

    ZDF HD und ZDF Neo HD ruckeln...


    Meine Vermutung war, dass diese Änderung vom 01.11.2022 die in Version 1.9.5 eingeflossen ist, evtl. das Problem verursacht.

    Fixed interlace detection. Fixed VDPAU half resolution (720x288, 1920…

    Wie man hier sieht ist nicht nur VDPAU sondern auch VA-API von den Änderungen betroffen.

    Wir konnten das Problem auch sowohl auf Systemen mit nVidia-GPU (VDAPU) als auch mit Intel-GPU (VA-API) eingrenzen.


    Kann jemand, der nicht MLD aber die aktuelle Version 1.9.5 von softhddevice nutzt, dieses Problem bestätigen?

    Evtl. ist das Problem ja auch schon beim Entwickler von softhddevice bekannt.


    Gruß

    Klaus

    Mehrere HD-VDRs mit Intel- bzw nVdia-GPU und MLD z.B.:

    VDR-Server - ITX-MB mit N3150 und CineS2+DuoFlexS2 mit MLD 5.4 stable

    Intel-VDR H110 ITX-MB mit i3-7300 (UHD630) mit CineS2 - MLD 5.5 testing

    Intel-VDR J5040 ITX-MB (UHD605) mit CineS2 - MLD 5.5 testing

    Intel-VDR Asus N4020 MiniPC (UHD600) SatIP Client - MLD 5.5 testing

    Intel-VDR NUC6CAYH (HD500) Sat-IP Client - MLD 5.5 unstable

    + weitere Test-Systeme mit Intel i3 8300, NUC7 und 8, i3-10110, i5-11500 ...

    teils mit nVidia GraKa GT630 bzw. GT1030 mit MLD 5.5

    + einige ältere VDRs mit Gen2VDR V6 bzw. Activys mit AE

  • Bei mir laufen beide genannten 720p-Sender im Kabelnetz von Vodafone problemlos. Sowohl Live-TV als auch Wiedergabe von Aufzeichnungen.

    Softhddevice Version 1.9.5 mit vdpau. Ubuntu 20.04 mit nvidia 470.141.03

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • There is a problem when playing a record or only in live mode?

    If there is a problem when playing a record, please upload the record.

    The problem is more critical in live mode but I have it also in recordings.

    When playing recordings the sound problems are starting after some seconds but it takes often more than a minute till the video also starts stuttering and problems with artefacts are starting.


    I did some tests with the ZDF HD channels by recording and then playing the recordings on a system with softhddevice 1.9.3

    On this system (va-api) live tv an playback of all recordings are OK.

    In the recording list of the plugin live these recordings are all marked as OK.


    Then I transfered this recordings to a second system (va-api) with softhddevice 1.9.5.

    When playing this recordings on this systems after a few seconds the problems are starting with the stuttering sound.


    One of these recordings i uploaded on my dropbox

    https://www.dropbox.com/scl/fo…4u6fanj480okmk9pgz3by1upl


    I can provide other recordings if needed.

    Mehrere HD-VDRs mit Intel- bzw nVdia-GPU und MLD z.B.:

    VDR-Server - ITX-MB mit N3150 und CineS2+DuoFlexS2 mit MLD 5.4 stable

    Intel-VDR H110 ITX-MB mit i3-7300 (UHD630) mit CineS2 - MLD 5.5 testing

    Intel-VDR J5040 ITX-MB (UHD605) mit CineS2 - MLD 5.5 testing

    Intel-VDR Asus N4020 MiniPC (UHD600) SatIP Client - MLD 5.5 testing

    Intel-VDR NUC6CAYH (HD500) Sat-IP Client - MLD 5.5 unstable

    + weitere Test-Systeme mit Intel i3 8300, NUC7 und 8, i3-10110, i5-11500 ...

    teils mit nVidia GraKa GT630 bzw. GT1030 mit MLD 5.5

    + einige ältere VDRs mit Gen2VDR V6 bzw. Activys mit AE

  • Die Aufnahme wird bei mir völlig normal abgespielt.

    Du verwendest ja eine nVidia GT1030 mit nVidia-Treiber 470.141.

    Evtl. gibt es ja das Problem mit einer aktuelleren nVidia-GPU und einem aktuelleren Treiber wie dem 470.141 nicht.

    Verwendest du bei softhddevice VDPAU oder CUVID?


    Ich selbst habe das Problem noch nicht versucht mit nVidia-GPUs zu testen.

    Ich verwende derzeit produktiv nur Intel-GPUs (HD500, HD630, UHD605 und UHD630) und bei allen tritt das Problem auf.

    Ein MLD-User der das Problem mit einer nVidia-GPU (GT710) berichtet hat, verwendet einen alten Legacy nVidia-Treiber 340.108.


    Ich baue mal heute Abend ein Testsystem auf nVidia um und teste mal mit einer älteren GT630 und einer GT1030 sowie den jeweils passenden Treibern.

    Als neuere Treiber für die GT1030 sind 515.76 und 390.144 in MLD 5.5 enthalten

    Die GT630 kann ich mit dem Legacy nVidia-Treiber 340.108 und dem 390.144 testen.


    Ich werde berichten, was dabei herauskommt.

    Mehrere HD-VDRs mit Intel- bzw nVdia-GPU und MLD z.B.:

    VDR-Server - ITX-MB mit N3150 und CineS2+DuoFlexS2 mit MLD 5.4 stable

    Intel-VDR H110 ITX-MB mit i3-7300 (UHD630) mit CineS2 - MLD 5.5 testing

    Intel-VDR J5040 ITX-MB (UHD605) mit CineS2 - MLD 5.5 testing

    Intel-VDR Asus N4020 MiniPC (UHD600) SatIP Client - MLD 5.5 testing

    Intel-VDR NUC6CAYH (HD500) Sat-IP Client - MLD 5.5 unstable

    + weitere Test-Systeme mit Intel i3 8300, NUC7 und 8, i3-10110, i5-11500 ...

    teils mit nVidia GraKa GT630 bzw. GT1030 mit MLD 5.5

    + einige ältere VDRs mit Gen2VDR V6 bzw. Activys mit AE

  • Va-api confirmed, I'll look it.

    Vdpau and cuvid no problems, I'll test yet.

    As I wrote in my post before, I will do some tests with nvidia.

    The MLD user who reported the Problem with a GT710 used an older nvidia driver 340.108.

    Maybe this old driver causes the problem and the newer drivers not.

    Mehrere HD-VDRs mit Intel- bzw nVdia-GPU und MLD z.B.:

    VDR-Server - ITX-MB mit N3150 und CineS2+DuoFlexS2 mit MLD 5.4 stable

    Intel-VDR H110 ITX-MB mit i3-7300 (UHD630) mit CineS2 - MLD 5.5 testing

    Intel-VDR J5040 ITX-MB (UHD605) mit CineS2 - MLD 5.5 testing

    Intel-VDR Asus N4020 MiniPC (UHD600) SatIP Client - MLD 5.5 testing

    Intel-VDR NUC6CAYH (HD500) Sat-IP Client - MLD 5.5 unstable

    + weitere Test-Systeme mit Intel i3 8300, NUC7 und 8, i3-10110, i5-11500 ...

    teils mit nVidia GraKa GT630 bzw. GT1030 mit MLD 5.5

    + einige ältere VDRs mit Gen2VDR V6 bzw. Activys mit AE

  • Thanks a lot.

    In the meantime version 1.9.3 is a workaround for MLD 5.5

    Mehrere HD-VDRs mit Intel- bzw nVdia-GPU und MLD z.B.:

    VDR-Server - ITX-MB mit N3150 und CineS2+DuoFlexS2 mit MLD 5.4 stable

    Intel-VDR H110 ITX-MB mit i3-7300 (UHD630) mit CineS2 - MLD 5.5 testing

    Intel-VDR J5040 ITX-MB (UHD605) mit CineS2 - MLD 5.5 testing

    Intel-VDR Asus N4020 MiniPC (UHD600) SatIP Client - MLD 5.5 testing

    Intel-VDR NUC6CAYH (HD500) Sat-IP Client - MLD 5.5 unstable

    + weitere Test-Systeme mit Intel i3 8300, NUC7 und 8, i3-10110, i5-11500 ...

    teils mit nVidia GraKa GT630 bzw. GT1030 mit MLD 5.5

    + einige ältere VDRs mit Gen2VDR V6 bzw. Activys mit AE

  • Verwendest du bei softhddevice VDPAU oder CUVID?

    VDPAU.

    Mit Cuvid verpixelt das Bild beim Umschalten kurz. Nicht doll, aber doch störend. VDPAU läuft perfekt.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • VDPAU.

    Mit Cuvid verpixelt das Bild beim Umschalten kurz. Nicht doll, aber doch störend. VDPAU läuft perfekt.

    Ich habe mittlerweile die ersten Tests mit einer nVidia GT630 und GT1030 und VDPAU gemacht.

    CUVID kann ich mit MLD sowieso nicht testen, da es aufgrund von Problemen mit dem alten Legacy Treiber deaktiviert wurde.


    Ich kann deine Aussage bestätigen, dass die GT1030 (Pascal GPU) das Problem nicht hat.

    Ich habe sowohl den 390.144 (Paket xorg-nvidia) als auch den 515.76 (xorg-nvidia.latest) positiv getestet.

    Der alte Legacy Treiber 340.108 (xorg-nvidia.legacy) läuft mit der GT1030 sowieso nicht.

    Update: Beim 390.144 tritt das Problem mit der GT1030 doch sporadisch auf.
    Nur beim 515.76er Treiber tritt das Problem nicht auf.


    Bei der GT630 (Keppler GPU wie bei GT710) tritt das Problem sowohl mit dem Treiber 340.108 als auch 390.144 auf.

    Mit dem 390.144 gibt es außerdem OSD-Probleme, von denen im MLD-Forum schon vorher in Verbingung mit älteren nVidia-GPUs (GT7XX und GT6XX) berichtet wurde, weshalb dieser Treiber für diese GPUs nicht geeignet ist.

    Noch ältere GPUs laufen sowieso nur mit dem Legay-Treiber und haben somit auch alle das Problem.


    Es hängt also von der Kombination aus nVidia Treiber und nVidia-GPU ab, ob das Problem auftritt oder nicht.

    Mehrere HD-VDRs mit Intel- bzw nVdia-GPU und MLD z.B.:

    VDR-Server - ITX-MB mit N3150 und CineS2+DuoFlexS2 mit MLD 5.4 stable

    Intel-VDR H110 ITX-MB mit i3-7300 (UHD630) mit CineS2 - MLD 5.5 testing

    Intel-VDR J5040 ITX-MB (UHD605) mit CineS2 - MLD 5.5 testing

    Intel-VDR Asus N4020 MiniPC (UHD600) SatIP Client - MLD 5.5 testing

    Intel-VDR NUC6CAYH (HD500) Sat-IP Client - MLD 5.5 unstable

    + weitere Test-Systeme mit Intel i3 8300, NUC7 und 8, i3-10110, i5-11500 ...

    teils mit nVidia GraKa GT630 bzw. GT1030 mit MLD 5.5

    + einige ältere VDRs mit Gen2VDR V6 bzw. Activys mit AE

    The post was edited 1 time, last by franky93128 ().

  • Habe ein ähnliches Problem:
    Probleme beim Umschalten ARD zu ZDF


    Tritt aber nur auf, wenn ich von Das Erste oder anderen ARD HD Sendern zu ZDF umschalte.

  • Va-api confirmed, I'll look it.

    Vdpau and cuvid no problems, I'll test yet.

    I can confirm this problem for vdpau on you test branch. I use your test branch because of 720p problem with vaapi. So vaapi runs fine here, but as there are some buffer full problems (va-api-glx-und-720p-kein-bild) which block me to use vaapi daily, i added an nvidia GT730 card (with driver 470) and used your softhddevice in test branch. In that configuration i got the same problem if switching to ZDF HD.

    VDR: OrigenAE X15E, E5300, 4GB RAM, Ubuntu 18.04, vdr 2.2.0, 60GB SSD, 8TB SSD, DVB-S2 TT S2-6400 + TT S2-3200

    Im Aufbau: Silverstone SG05 Lite, ASRock MB H510M-HDV R2.0, I3 10100, 8GB RAM, Ubuntu 22.04, vdr 2.6.1, 120GB SSD, 8TB SSD, Digital Devices Max S8X, FLIRC, Nvidia GT730 als temp. vaapi-softhddevice-Bug-Workarround

  • @ Inj

    I just tested new Version 1.9.6 in MLD 5.5 unstable and it works fine.

    Thanks a lot!

    Mehrere HD-VDRs mit Intel- bzw nVdia-GPU und MLD z.B.:

    VDR-Server - ITX-MB mit N3150 und CineS2+DuoFlexS2 mit MLD 5.4 stable

    Intel-VDR H110 ITX-MB mit i3-7300 (UHD630) mit CineS2 - MLD 5.5 testing

    Intel-VDR J5040 ITX-MB (UHD605) mit CineS2 - MLD 5.5 testing

    Intel-VDR Asus N4020 MiniPC (UHD600) SatIP Client - MLD 5.5 testing

    Intel-VDR NUC6CAYH (HD500) Sat-IP Client - MLD 5.5 unstable

    + weitere Test-Systeme mit Intel i3 8300, NUC7 und 8, i3-10110, i5-11500 ...

    teils mit nVidia GraKa GT630 bzw. GT1030 mit MLD 5.5

    + einige ältere VDRs mit Gen2VDR V6 bzw. Activys mit AE

  • @Inj

    Thank you for that information.

    If you mean with latest Intel GPU the UHD7xx of the 11th and 12th generation of Intel CoreI CPUs, needing the iHD driver for va-api, it is a problem to test that with the current version of MLD.

    The current version 5.5 of MLD does only support va-api on Intel-GPUs up to the 9th generation of Intel CoreI CPUs, because the used mesa version (18.3.6) does not yet have the iHD driver.

    Mehrere HD-VDRs mit Intel- bzw nVdia-GPU und MLD z.B.:

    VDR-Server - ITX-MB mit N3150 und CineS2+DuoFlexS2 mit MLD 5.4 stable

    Intel-VDR H110 ITX-MB mit i3-7300 (UHD630) mit CineS2 - MLD 5.5 testing

    Intel-VDR J5040 ITX-MB (UHD605) mit CineS2 - MLD 5.5 testing

    Intel-VDR Asus N4020 MiniPC (UHD600) SatIP Client - MLD 5.5 testing

    Intel-VDR NUC6CAYH (HD500) Sat-IP Client - MLD 5.5 unstable

    + weitere Test-Systeme mit Intel i3 8300, NUC7 und 8, i3-10110, i5-11500 ...

    teils mit nVidia GraKa GT630 bzw. GT1030 mit MLD 5.5

    + einige ältere VDRs mit Gen2VDR V6 bzw. Activys mit AE