[softhddevice-drm] LibreELEC / AMLGX

  • Zabrimus Ich habe nochmal was eingecheckt. Damit sollte jetzt (hoffentlich) zumindest drm und OpenGL richtig starten. Evtl. funktioniert ja damit auch schon mal OSD...

  • Auf die Idee mit Patch 0005 kam ich auch schon:

    Code
    1. odroid2:~ # cat /sys/firmware/devicetree/base/compatible
    2. hardkernel,odroid-n2-plusamlogic,s922xamlogic,g12b

    Und jetzt wird es etwas seltsam. Ich verstehe nicht, wie ffmpeg gebaut wird.


    Das Original ffmpeg mit deinen Patches liefert:


    Und mit meiner (schräg und auf die schnelle) gepatchten Version des ffmpeg/package.mk erhalte ich diese Ausgabe

    Das sieht auch soweit gut aus. Nur, daß ich jetzt kein Bild mehr habe. Das OSD geht aber weiterhin.


    Im Moment tendiere ich zur ungepatchen ffmpeg Version, weil ich nicht, welche Auswirkungen das z.B. auf Kodi hätte.

  • Was bzw. wie patchst du da ffmpeg? Der Fehler im ersten Log kommt von drm. Da stimmt noch was nicht. Den wirst du bei zillerbaers Version wahrscheinlich nicht bekommen.

  • Was bzw. wie patchst du da ffmpeg?

    Ich patche nicht ffmpeg. Das war vielleicht etwas mißverständlich. Aber ich verstehe das package.mk für amlogic nicht.

    Es wird wohl nicht das offizielle ffmpeg, sondern ein rpi-ffmpeg verwendet und dann wird erst V4L2_REQUEST eingeschaltet um dann doch wieder abgeschaltet zu werden.

    Wie gesagt: Ich verstehe es nicht und lass lieber die Finger davon ;)

  • Hm, lese ich nicht so. Amlogic verwendet wie RPi einen v4l2_m2m Treiber, der wird gebaut und lt. logs auch genutzt.

    Ich warte noch auf meine S905 Box, dann kann ich auch selbst testen.

    Ansonsten kann ich versuchen herauszufinden, warum drm in den abort läuft - falls du testwillig bist.

  • Hm, lese ich nicht so. Amlogic verwendet wie RPi einen v4l2_m2m Treiber, der wird gebaut und lt. logs auch genutzt

    Genau deshalb denke ich, ich habe irgendwo einen Denkfehler und finde den nicht. Ich habe das package.mk mal gekürzt

    Ansonsten kann ich versuchen herauszufinden, warum drm in den abort läuft - falls du testwillig bist.

    Ich habe extra dafür eine Kiste auf Standby ;)

    Seit über einer Woche will ich mich mal dransetzen den Dev/Test-Zyklus zeitlich stark zu verkürzen (oder es zumindest zu versuchen), aber ich komme nicht dazu. Immer die vielen Images bauen, Update, Reboot, Test- Zyklen dauern mir zu lange für solche Sachen.

  • v4l2request brauchst du nicht, sondern v4l2m2m und das ist aktiviert. Das siehst du auch in deinen Logs:

  • Zabrimus Ich habe nochmal 2 patches hinzugefügt. Damit wird das Log wohl zwar ziemlich voll, aber evtl. kann ich sehen, was an den Werten für den Commit nicht passt. Gerne testen und das Log schicken.

  • Ich bin jetzt hier an einem Showstopper angekommen. Der Decoder liefert die Bilder in V4L2_PIX_FMT_NV12M (NM12) aus. DRM kann mit dem Format aber nicht umgehen. FFMPEG behauptet daher es wäre NV12. Das Ergebnis sieht bescheiden aus.

    Weißt, du wie kodi das macht?


    EDIT: Die rendern das auf ein texture, oder?

    The post was edited 1 time, last by rell ().

  • v4l2request brauchst du nicht, sondern v4l2m2m und das ist aktiviert.

    Okay. Denkfehler gefunden. Ich dachte ich hätte irgendwo gelesen v4l2request wäre Pflicht und deshalb ....



    Zabrimus Ich habe nochmal 2 patches hinzugefügt. Damit wird das Log wohl zwar ziemlich voll, aber evtl. kann ich sehen, was an den Werten für den Commit nicht passt. Gerne testen und das Log schicken.

    Das journal habe ich angehängt.


    softhddevice-drm-journal.txt

  • Zabrimus So, damit sollte es laufen. Bitte nochmal probieren. Wenns geht, kannst du die beiden letzten natürlich weglassen.

    Bliebe dann noch die Sache mit NM12 und DRM...

  • Zabrimus So, damit sollte es laufen. Bitte nochmal probieren. Wenns geht, kannst du die beiden letzten natürlich weglassen.

    Bliebe dann noch die Sache mit NM12 und DRM...

    Soooo. VDR startet und ich habe ein HD Bild. Aber. Ich meine, es sieht cool aus, aber wahrscheinlich nicht so gewollt.

    Es liegen 2 gleiche Bilder übereinander, das zweite mit seltsamen Farben, vertikal nach unten verschoben und leicht gestreckt.


    Auf der Konsole habe ich permanent diese Ausgabe:

    CodecVideoSendPacket: send_packet ret: Resource temporarily unavailable

    CodecVideoSendPacket: send_packet ret: Resource temporarily unavailable


    Das Journal sieht am Ende dann so aus: