osd2web - Port 4444 nur für IPV6

  • Bis jetzt hatte ich den vdr mit IPV4 und IPV6 IP-Adressen laufen. Da hier alles nur per IPV4 läuft habe ich ubuntu auf nur IPV4 umgestellt. Ergebnis: der Browser verbindet sich nicht mehr mit Port 4444. Ein Aufruf von netstat -tupln zeigt auch keinen Port 4444 an. Im Log keine Fehler, der vdr sagt:


    Code
    1. vdr vdr: osd2web: Listener at port (4444) established


    Wenn IPV6 erlaubt ist , zeigt netstat dies:


    Code
    1. tcp6 0 0 :::4444 :::* LISTEN 1063/vdr


    Also nur IPV6. Wieso wird nicht auf einem IPV4 Port gelauscht? Irgendwelche Ideen dazu?

    VDR: OrigenAE X15E, E5300, 4GB RAM, Ubuntu 18.04, vdr 2.2.0, 60GB SSD, 8TB SSD, DVB-S2 TT S2-6400 + TT S2-3200

    Im Aufbau: Silverstone SG05 Lite, ASRock MB H510M-HDV R2.0, I3 10100, 8GB RAM, Ubuntu 22.04, vdr 2.6.1, 120GB SSD, 8TB SSD, Digital Devices Max S8X, FLIRC, Nvidia GT730 als temp. vaapi-softhddevice-Bug-Workarround

  • Da ich nicht glaube, das ich der einzige bin der osd2web nutzt, mal folgende Frage: kann mal bitte jemand dies aufrufen:

    Code
    1. netstat -tulpn | grep 4444

    Ich würde gern wissen, ob osd2web + vdr generell auch den IPV4 Port nutzt. Danke.

    VDR: OrigenAE X15E, E5300, 4GB RAM, Ubuntu 18.04, vdr 2.2.0, 60GB SSD, 8TB SSD, DVB-S2 TT S2-6400 + TT S2-3200

    Im Aufbau: Silverstone SG05 Lite, ASRock MB H510M-HDV R2.0, I3 10100, 8GB RAM, Ubuntu 22.04, vdr 2.6.1, 120GB SSD, 8TB SSD, Digital Devices Max S8X, FLIRC, Nvidia GT730 als temp. vaapi-softhddevice-Bug-Workarround

  • Besten Dank. Sieht so aus als ob nur der IPV6-Port genutzt wird. Wäre natürlich ungünstig für IPV4-Only-Systeme :/

    VDR: OrigenAE X15E, E5300, 4GB RAM, Ubuntu 18.04, vdr 2.2.0, 60GB SSD, 8TB SSD, DVB-S2 TT S2-6400 + TT S2-3200

    Im Aufbau: Silverstone SG05 Lite, ASRock MB H510M-HDV R2.0, I3 10100, 8GB RAM, Ubuntu 22.04, vdr 2.6.1, 120GB SSD, 8TB SSD, Digital Devices Max S8X, FLIRC, Nvidia GT730 als temp. vaapi-softhddevice-Bug-Workarround

  • Bei mir dasselbe.

    Aber:

    # telnet -4 127.0.0.1 4444

    Trying ::1...

    Connected to localhost.woodpecker.selfhost.eu.

    Escape character is '^]'.


    Seltsam.

    Und das funktioniert (mit -4 und IP) auch vom Linux-Desktop aus.

  • In der Tat merkwürdig. Vielleicht wird telnet trotz -4 intern auf IPV6 gemappt? jedenfalls werden alle anderen vom vdr genutzten Ports an IPV4 gebunden. Nur osd2web nicht, und das will ja auch mit nur IPV4 nicht... Vielleicht ein websocket-Thema?

    VDR: OrigenAE X15E, E5300, 4GB RAM, Ubuntu 18.04, vdr 2.2.0, 60GB SSD, 8TB SSD, DVB-S2 TT S2-6400 + TT S2-3200

    Im Aufbau: Silverstone SG05 Lite, ASRock MB H510M-HDV R2.0, I3 10100, 8GB RAM, Ubuntu 22.04, vdr 2.6.1, 120GB SSD, 8TB SSD, Digital Devices Max S8X, FLIRC, Nvidia GT730 als temp. vaapi-softhddevice-Bug-Workarround

  • Da hier alles nur per IPV4 läuft habe ich ubuntu auf nur IPV4 umgestellt.

    Wie genau hast du das gemacht? Per Boot-Parameter für den Kernel (ipv6.disable=1) oder auf einem anderen Weg?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ja, ich habe das zum Bootparameter GRUB_CMDLINE_LINUX hinzugefügt + grub update. Dann läuft das System nur mit IPV4 (problemlos) nur osd2web will nicht mehr.

    VDR: OrigenAE X15E, E5300, 4GB RAM, Ubuntu 18.04, vdr 2.2.0, 60GB SSD, 8TB SSD, DVB-S2 TT S2-6400 + TT S2-3200

    Im Aufbau: Silverstone SG05 Lite, ASRock MB H510M-HDV R2.0, I3 10100, 8GB RAM, Ubuntu 22.04, vdr 2.6.1, 120GB SSD, 8TB SSD, Digital Devices Max S8X, FLIRC, Nvidia GT730 als temp. vaapi-softhddevice-Bug-Workarround