SATIP-Plugin Patches

  • Ich hab das letzt mal parallel hier abgelegt: https://github.com/rofafor/vdr-plugin-satip/pull/82

    So ist der aktuelle Stand mal "festgehalten". Wenn die Patches noch aktualisiert werden sollten, dann würde ich die bisherige Version vorher rückgängig machen und dann erst die neue Version einbauen. So wird zumindest ab jetzt etwas besser nachvollziehbar was sich noch ändert.


    Hat auch den Vorteil das es ab jetzt "indirekt" einen Sammelpatch gibt: https://patch-diff.githubuserc…lugin-satip/pull/82.patch


    Danke vielmals an FireFly für die Arbeit die dahinter steckt!

  • FireFly  
    Vielen Dank für die Arbeit.
    Die Fehlermeldung "Transfer-Mode kann nicht gestartet werden" sehe ich seit Beginn der Nutzung des SatIP Plugins in regelmäßigen Abständen. Da hilft immer nur ein Neustart des VDR.
    Ich bin gespannt, wie sich der VDR jetzt verhält. Von gestern bis heute liefen alle Aufnahmen fehlerfrei.

    Gehäuse: Intertech 4U 4416, Board: Supermicro X11SAE; Kathrein EXIP418; OS: Ubuntu 18.04; Plugins: xineliboutput, satip, burn, femon, live, streamdev-server, text2skin:anthra-1920

    2x RPI2/3; Plugins: rpihddevice; videodir via NFS


  • Komisch ... und wenn Du den secfilter_fix Patch weglässt?

    werde ich morgen mal testen.

    so ich habe etwas weiter getestet -- und zwei der Patches laufen mit dem Ausgabe-Plugin softhddrm 3.6.1 ohne Fehler.


    Die Problem mit dem Ausgabe-Plugin "Softhdrm" kommen von oben aus dem

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2022)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65G29LA

  • Deswegen mag ich Patches, die man beim Lesen verstehen und beurteilen kann. Patche mit potentiellen Nebenwirkungen machen einfach zu viel Arbeit später.

  • Die Problem mit dem Ausgabe-Plugin "Softhdrm" kommen von oben aus dem

    satip_retune_fix.diff

    Probiere doch mal stattdessen den angehängten Patch. Anstatt als Workaround immer neu zu tunen sollte der jetzt die eigentliche Ursache beheben. Außerdem werden nutzlose Requests an den SATIP-Server unterdrückt.

    Intensiv getestet habe ich den Patch bisher nicht, also besser noch nicht in Produktivsysteme einspielen ;-)

  • Probiere doch mal stattdessen den angehängten Patch. Anstatt als Workaround immer neu zu tunen sollte der jetzt die eigentliche Ursache beheben. Außerdem werden nutzlose Requests an den SATIP-Server unterdrückt.

    Intensiv getestet habe ich den Patch bisher nicht, also besser noch nicht in Produktivsysteme einspielen ;-)

    Hm, ich denke diese Version vom Patch das lasse ich mal beim Ausgabe-Plugin "Softhddrm" weg


    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2022)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65G29LA

  • Poste doch mal die Zeilen VOR den Fehlermeldungen - die Meldungen sind ja immer die gleichen


    Welche VDR-Version und SATIP-Version nutzt Du ? Welchen SATIP-Server?

    - Ubuntu 22.04

    - Kernel 5.18.0

    - VDR-2.6.1

    - VAAPI auf softhddrm 3.6 aktueller Git-Stand

    - satip aus Git-Stand

    mit

    [satip]

    -d 3

    -s 192.168.xx.xx|DVBS2-3|OctopusNet:0x08


    Den Fehler konnte ich ein kreisen -- tritt bei einem oder mehren TV Kanälen auf - muß noch rausfinden bei welchen

    Der Fehler startet so im Log

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2022)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65G29LA

  • Der Transponder 12226 beinhaltet nur SD-Sender, hauptsächlich von RTL Austria. Auffällig ist, dass alle Deine Section Pakete die maximale Länge von 4096 haben (also nicht wirklich "incomplete" sind aber halt die Länge nicht mit der im Paket angegebenen übereinstimmt)

    Bild und Ton hast Du aber, oder?

    Bei mir treten mit keinem Sender des Transponders Probleme auf weshalb ich da nicht wirklich unterstützen kann.

    Aber Du kannst ja zuerst mal den Error Code vom fehlgeschlagenen send section data ausgeben lassen:


    Edit: hast Du es mal ohne den Quirk 0x08 probiert? Also mit -s 192.168.xx.xx|DVBS2-3|OctopusNet

  • Bild und Ton hast Du aber, oder?

    Ja ist beides da


    Edit: hast Du es mal ohne den Quirk 0x08 probiert? Also mit 

    geht auch, muß aber noch einmal das syslog checken ob da dieser Fehler auch auftritt


    Edit: auch ohne 0x08 tritt der Fehler auf

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2022)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65G29LA

    The post was edited 1 time, last by cinfo ().