gelöst - yavdr-ansible mit Intel UHD 730 [yavdr-xorg : intel xorg config snippet] - Fehler - fehlender Treiber? - nicht mit 22.04 jammy

  • Hallo,


    meine alte VDR-Hardware mit einer AMD 4300 Fx CPU ist bei UHD trotz GT1050Ti am Limit und als Dauerläufer nicht gerade stromsparend....

    Neue, stromsparende Hardware in Form eines i3-12100 (12. Generation) mit Intel® UHD-Grafik 730 sollte es sein. Im Test mit einer GT1030 lief das Test-System in UHD recht gut - Sinn der Sache wäre es aber, die stromsparende interne UHD-Grafik 730 zu nutzen. Das Test-System lief auch schon mit alternativer UHD-Grafik 630. Leider konnte ich es nicht nutzen, da sich das 730-System nur im EFI Modus starten läßt. Eine Konvertierung von Bios auf EFI mit chroot ist mir leider nicht gelungen, daher habe ich eine Neuinstallation auf Basis von focal 20.04 gewählt.

    Das Playbook läuft nicht durch:

    Code
    1. TASK [yavdr-xorg : intel xorg config snippet] *******************************************************************************************************
    2. fatal: [localhost]: FAILED! => {
    3. "changed": false
    4. }
    5. MSG:
    6. AnsibleUndefinedVariable: 'dict object' has no attribute 'primary'

    Der x-server startet nicht. Ich habe HDMi- und Display-Port getestet. Aus meiner Sicht fehlt der richtige Grafiktreiber mit der Beschleunigung, siehe auch:

    Hat vielleicht jemand Erfahrungen mit dieser relativ neuen Hardware und kann mir einen Hinweis zur Treiberinstallation geben? Im Netz bin ich nicht fündig geworden.

    Gruß von Steato

  • Ich würde es mal mit Ubuntu Server 22.04 als Basis probieren, da stehen die Chancen besser, dass der Kernel und Mesa aktuell genug sind - du musst dafür nur die PPAs für jammy angeben, also in einer host_vars/localhost sowas setzen (wenn du die repositories Variable unangetastet lässt):

    Code
    1. branch: jammy
    2. ppa_owner: 'ppa:seahawk1986-hotmail'

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo Seahawk1986,

    vielen Dank für Deine schnelle Antwort. Jammy hatte ich getestet - mache gerade eine Rücksicherung. Hier hatte ich mit Probleme mit den Standard- ppa's (yavdr-experimental usw.). Diese waren für jammy nicht verfügbar. Genaueres aus der Fehlermeldung folgt nach der Rücksicherung.

    Ich hatte in der host_vars/localhost Deine ppa's

    ppa:seahawk1986-hotmail/jammy-main

    ppa:seahawk1986-hotmail/jammy-vdr

    ppa:seahawk1986-hotmail/jammy-kodi

    eingebunden.

  • Hier hatte ich mit Probleme mit den Standard- ppa's (yavdr-experimental usw.). Diese waren für jammy nicht verfügbar

    Genau - deswegen muss man dem Playbook andere PPAs vorgeben, damit es ohne Fehler durchlaufen kann (und falls man z.B. durchein Upgrade von focal noch die anderen PPAs aktiv hat, sollte man die Dateien in /etc/apt/sources.list.d/ abräumen, bevor man das Playbook laufen lässt).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo Seahawk,

    Dein Hinweis war (wie immer) der Richtige. Mit den Einträgen:


    Code
    1. branch: jammy
    2. ppa_owner: 'ppa:seahawk1986-hotmail'
    3. # add the following PPAs
    4. repositories:
    5.   - 'ppa:seahawk1986-hotmail/jammy-main'
    6.   - 'ppa:seahawk1986-hotmail/jammy-vdr'
    7.   - 'ppa:seahawk1986-hotmail/jammy-kodi'

    in der group_vars/all lief alles sauber durch. Dann noch das Ausgabeplugin vdr-plugin-softhddevice gegen vdr-plugin-softhdvaapi ausgetauscht und das Bild war da.

    Vielen Dank! Gruß von Steato