Installation eines VDR+Plugins nativ auf CoreELEC Boxen

  • rmmod amlvideodri

    Ich würde da eher modprobe -r amlvideodri  nutzen. Da werden dann auch die Abhängigkeiten berücksichtigt.

    Ich nutze kein Kodi und fahre den vdr unter chroot. Da tritt das Problem nicht auf. Ich baue mir nun mal eine komplette

    Version mit VDR und teste das auf meinem X96. Vielleicht finde ich ja etwas.


    Das umschalten der Displayauflösung hat hiermit nichts zu tun. Und das maskieren von Kodi ist ebenfalls hier nicht relevant.

  • Zabrimus Ich habe nun mal dein Release 0.2.1 genommen. Aber da funktioniert das umschalten zw. Kodi und VDR noch nicht. Da sind noch Probleme in des scripten.

    Ich habe unter /opt nichts und da wird aber /opt/tmp/switch_kodi_vdr gesucht.


    Edit:

    Habe nun rausgefunden das /storage .opt gefehlt hat. Jetzt wird zwar alles angelegt aber das script switch_kodi_vdr.sh wird nicht aktiviert.



    Aber ich kannes ja zum testen auch manuell erstmal machen.

  • . Start mit VDR, Wechsel nach Kodi. Ansehen eines Videos aus der Mediathek -> Kernel Crash

    So nun habe ich es genau so gemacht wie beschrieben. Nur leider crashed da nix :-(


    Was mir aufgefallen ist, die Version wo alles unter CE läuft (ohne chroot) ist deutlich langsamer als mit Ubuntu unter chroot.

  • Habe nun rausgefunden das /storage .opt gefehlt hat. Jetzt wird zwar alles angelegt aber das script switch_kodi_vdr.sh wird nicht aktiviert.

    Mist. Da muss ich nochmal ran. Ich habe entware recht früh installiert und nicht in Betracht gezogen, daß /storage/.opt (oder eben der Link /opt -> /storage/.opt) nicht existieren muss.


    So nun habe ich es genau so gemacht wie beschrieben. Nur leider crashed da nix


    Was mir aufgefallen ist, die Version wo alles unter CE läuft (ohne chroot) ist deutlich langsamer als mit Ubuntu unter chroot.

    Okayyy. Die 0.2.1 ist das letzte Release. Ich glaub danach kam nur noch dein Cleanup in softhdodroid. Ich brauche eine neue SD Karte und muss ganz frisch anfangen. Vielleicht habe ich zu oft hin und her geflasht und irgendwas (de)installiert.


    Aber was meinst du mit langsamer und dann auch noch deutlicher? Wo sollte denn da eine Bremse sein? Hmm... Da muss ich mal nachdenken.


    Trotzdem Danke für den Test. Ich schnapp mir jetzt eine neue SD Karte und fang neu an. Dann kann ich auch direkt die Scripte/Pfade korrigieren.

  • So. Neue SD Karte und ganz frische Installation mit dem Generic Image aus dem Repository.

    Die Fehler in den Pfaden sollten gefixed sein und das install script sollte keine Fehlermeldung mehr anzeigen.


    Zum Thema VDR->Kodi->Mediathek:

    Das Fehlerbild ist jetzt leicht anders. Es kommen ein paar Sätze Ton allerdings ohne Bild, bevor wieder der Trace im Log zu sehen ist.

  • Ja so hatte ich das auch gemacht mit einer neuen SD Karte. Mir ist nur unklar wie der start von switch_kodi_vdr.sh getriggert wird.

    Ich sehe nur wo du die Variable von vdr auf Kodi änderst, aber nicht wo das script zum umschalten gestartet wird.


    Ich habe einen X96 und du wohl einen Tanix X3. Ob es da evtl. einen unterschied gibt ?


    Edit:

    Nun konnte ich es auch reproduzieren. Allerdinsg fällt es mir schwer hier nun zu basteln. Das Filesystem ist Readonly und ich kann an den scripten nix ändern :-(

    Der vdr braucht das amlvideodri nicht. Da könnte man es entladen und vor dem start des Kodi wieder laden. Da finded ja der crash statt.

    Nur wie baue ich das nun in das switch_kodi_vdr.sh ein ???

  • Der Trigger zum wechseln zwischen Kodi/VDR ist die systemd unit switch_kodi_vdr.path. Sobald die Datei

    /storage/.cache/switch_kodi_vdr geändert wird, wird das systemd unit switch_kodi_vdr.service gestartet, welches ihrerseits dann das Script switch_kodi_vdr.sh aufruft. Das entscheidet dann zwischen dem Wechsel Kodi <-> VDR.


    Aber es gibt tatsächlich etwas, was du in softhdodroid ändern könntest ;)

    Ich habe mir die Werte von /sys/class/* angeschaut: Direkt nach dem Booten, nach dem Start von Kodi, Beenden von Kodi, Beenden von VDR um Unterschiede festzustellen.

    Und nach ein paar Testläufen kam ich auf folgendes Kommando, das nach dem Beenden von VDR den Player in Kodi nicht mehr abstürzen lässt:

    echo rm pip0 > /sys/class/vfm/map

    Die Map scheint ursächlich für das Problem zu sein. Ich könnte das in die Scripte einbauen, aber sinnvoller wäre es m.E. in softhdodroid. Damit wird wieder fast der Zustand Boot = Ende von VDR hergestellt.

  • Das pip0 wird auch ohne pip gebraucht. Ist nur ein schlechter Name :-) Aber klar kann ich das löschen beim beenden und baue es gleich ein.


    Edit:

    Ich habe mir das nun mal in meinen Quellen angeschaut und ich lösche pip0 beim beenden. Ich lösche alle Routings und setze die default Routings neu.

    Könnte natürlich sein das es hier ein Timing Problem gibt weil ich alles direkt hintereinander mache.

    Ich baue da mal ein Verzögerung ein.


    Edit2:

    Habs nun mal eingecheckt.

  • irgendwie hat das das Umschalten rasant beschleunigt, aber auch etwas hakeliger genacht. Das neue Bild kommt jetzt fast sofort, stockt dann einen Moment (wohl wegen Synchronisation mit Audio) und läuft dann weiter.
    Ich weiter nichts verändert außer heute den neuen Stand kompiliert + installiert.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • ich muss mich korrigieren: Heute morgen nach dem Booten (direkt in vdr) war die Umschaltgeschwindigkeit wieder wie vorher. Aber nachdem ich zu kodi gewechselt habe, dort kurz einen Film abgespielt, gestoppt und zu vdr zurückgewechselt habe, ist das turboschnelle Umschalten wieder präsent.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • ich muss mich korrigieren: Heute morgen nach dem Booten (direkt in vdr) war die Umschaltgeschwindigkeit wieder wie vorher. Aber nachdem ich zu kodi gewechselt habe, dort kurz einen Film abgespielt, gestoppt und zu vdr zurückgewechselt habe, ist das turboschnelle Umschalten wieder präsent.

    Das ist seltsam. Hinterlässt Kodi vielleicht doch irgendwelche Einstellungen, die nicht zurückgesetzt werden?

    Vielleicht muss ich nochmal alles und noch mehr vergleichen.

  • ich habe jetzt mal vor und nach dem Start von kodi+Filmwiedergabe die Ordner sysy/class... kopiert und dann ein diff gemacht. Ich weiss nicht, ob das weiterhilft. In beiden Situationen lief TV vom vdr, und natürlich sind diverse Werte naturgemäß dennoch anders.


    Mir fällt aber auf, dass nachdem kodi einmal lief und einen Film abgespielt hat, auch nach Rückkehr zu vdr an mehreren Stellen

    decoder.h264.dec_control=4 statt decoder.h264.dec_control=0 steht.


    und in/sys/class/media-configs/vfm sowie /sys/class/vfm/map steht zusätzlich[06] default_amlvideo2 { vdin1(0) amlvideo2.1}

    Files

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Mir fällt aber auf, dass nachdem kodi einmal lief und einen Film abgespielt hat, auch nach Rückkehr zu vdr an mehreren Stellen

    decoder.h264.dec_control=4 statt decoder.h264.dec_control=0 steht.

    Viel findet man dazu ja nicht.

    Quote

    It is Amlogic hardware decoder parameter called DEC_CONTROL_FLAG_DISABLE_FAST_POC. What does it do exactly I don't know apart from improving LiveTV playback. ;)

    linux-amlogic/vh264.c at amlogic-3.14.y · LibreELEC/linux-amlogic · GitHub

    Was du machen könntest, wäre in der /storage/.config/autostart.sh so ziemlich am Anfang bevor das andere Script aufgerufen wird das hier einfügen

    echo 4 > /sys/module/amvdec_h264/parameters/dec_control

    Damit der Parameter vor dem VDR/Kodi Start gesetzt wird und mal schauen, ob das Auswirkungen hat.

  • ich hätte vielleicht schreiben sollen, dass ich gar nicht Dein image verwende sondern die chroot-Lösung von beta. Sorry.

    Ich habe dort jetzt auch das Problem, das nach Rückkehr von kodi zu vdr dort das Bild ruckelt. Das fängt sich erst wieder beim nächsten Umschalten. Den obigen echo-Befehl habe ich im laufenden Betrieb schon ausprobiert, bringt nichts. Ich werde jetzt nochmal versuchen, den vor dem attachen von softhdodroid auszuführen.


    Grundsätzlich wäre es vielleicht besser, wenn man beim Wechseln von vdr zu kodi doch den Playmode pmExtern_THIS_SHOULD_BE_AVOIDED verwendet. Und dann müsste jojo61 in softhdodroid bei Wechsel von diesem playmode zu einem anderen sämtliche Erstinitialisierungen, die es beim Start durchgeführt hat, nochmal an die Hardware schicken. (Es generell beim attachen durchzuführen macht m.E. keinen Sinn). Ich fürchte, das wird sonst auf Dauer die Suche nach der Nadel im Heuhaufen.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Das Ruckeln bekommst Du in den Griff, wenn Du im Umschalt-Skript folgendes einfügst:

    Code
    1.        systemctl stop kodi
    2. $PFAD/svdrpsend.sh REMO on
    3. $PFAD/svdrpsend.sh PLUG softhdodroid ATTA -a hw:CARD=AMLAUGESOUND,DEV=2
    4. sleep 1
    5. $PFAD/svdrpsend.sh chan +
    6. sleep 1
    7. $PFAD/svdrpsend.sh chan -
    8. NEXT=vdr;
  • beta : ja, das war die Lösung, die Du ursprünglich in Deinem HowTo schon beschrieben hattest. Aber der Stand war damals, dass es nach einer Änderung von jojo61 am Plugin nicht mehr notwendig war. Vielleicht eine Regression?


    Der o.g. echo-Befehl müsste wenn dann übrigens mit 0 statt 4 ausgeführt werden, denn 0 ist der Wert im vdr-Betrieb, ehe kodi einen Film abgespielt hat. Die 4 kommt erst durch kodi.

    Ich habe also in der softoggle vor dem attachen von softhdodroid einecho 0 > /sys/module/amvdec_h264/parameters/dec_control eingefügt, aber das verhindert das Ruckeln auch nicht.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • jojo61 Ich kann die Beobachtung von Dr.Seltsam bestätigen. Wenn ich unter KODI zuerst einen Film abspiele (chroot), dann läuft VDR deutlich flüssiger und mein Problem mit der hakeligen Fernbedienung bei verschlüsselten Sendern ist auch passe.


    Edit: Das Problem tritt nur bei 4K auf.

  • Also ich sehe hier bei mir keinen Unterschied ob ich dec_control auf 4 oder auf 0 setze. Wenn es bei euch hilft dann könnt ihr das ja in softoggle einbauen.


    Das das Bild beim zurückschalten von Kodi ruckelt und man erst mal umschalten muss, das habe ich hier auch. Die Ursache dafür habe ich bisher nicht gefunden.

    Das einbauen des deinterlacers und korrigieren der PTS übergaben scheint nicht geholfen zu haben. Auch wenn es erst mal danach aussah.

    Da ist dann wohl weiterhin das umschalten in softoggle nötig.


    Was mir nun noch fehlt ist ein Feedback von Zabrimus ob das löschen von pip0 und verzögern des rm all in der reinen CE Variante geholfen hat.