yavdr-ansible auf NUC11i3 TASK [yavdr-xorg : intel xorg config snippet] schlägt fehl

  • Hi,


    ich versuche gerade, yavdr auf einem neuen NUC11i3 mit frisch installiertem und aktualisiertem Ubuntu 20.04 zu installieren.

    Das Playbook schlägt aber leider beim Durchlaufen fehl:

    Code
    1. TASK [yavdr-xorg : intel xorg config snippet] *****************************************************************************************
    2. fatal: [localhost]: FAILED! => {
    3. "changed": false
    4. }
    5. MSG:
    6. AnsibleUndefinedVariable: 'dict object' has no attribute 'primary'

    Kann mir jemand weiterhelfen?


    Vielen Dank

    Stubi

  • War ein Bildschirm angeschlossen und eingeschaltet, als das Playbook gelaufen ist? Wie sehen die Dateien in /etc/ansible/facts.d/ aus, die das Playbook schreiben sollte, wenn es die Bildschirm-Infos ausgelesen hat?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Moin,


    der Fernseher war angeschlossen und eingeschaltet. Ich habe sogar das Playbook direkt von dort gestartet...

    Das ist die Ausgabe, sie liest sich irgendwie ziemlich leer:


    Viele Grüße

    Stubi

  • Probiere das nochmal am anderen HDMI Anschluss…

  • Es gibt nur noch einen Mini-Displayportanschluss an dem NUC11. Schließe ich ihn darüber an (Mini-DP auf HDMI-Buchse-Adapter) bekomme ich leider das gleiche Ergebnis.


    Stubi

    VDR: easyVDR 5.0, Intel NUC6CAYH, 4GB, 3x TechnoTrend CT2-4400, Intel VAAPI

    The post was edited 1 time, last by stubi ().

  • Bei einem NUC11 würde ich den Ubuntu 22.04 Server als Basis nehmen, da sind der Kernel und die Grafiktreiber hoffentlich aktuell genug.

    Die Paketquellen müssen dann noch im Playbook angepasst werden: yavdr-ansible focal auf NUC10i3 etc.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • welcher NUC11 wird denn genutzt der NUC11TNH oder NUC11PAH?

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Hi,


    es ist ein NUC11PAHi3 - der mit eingebautem CIR-Empfänger.

    Jetzt habe ich einfach eine 22.04. installiert und damit habe ich ein Bild bekommen. Vielen Dank also schonmal.

    Leider höre ich noch nichts :)

    Ich vermute, dass irgendwo ein falsches HDMI-Gerät benutzt wird. Leider weiß ich nicht, wo ich nachsehen kann.

    ein aplay -l gibt auch eine lange Liste aus, aus der ich nicht so recht schlau werde:

    Wie finde ich denn raus, welches das Richtige ist und vor allem, wo ändere ich es? :)


    Viele Grüße

    Stubi

  • Standardmäßig ist die Ausgabe über den Klinkenstecker durch Pulseaudio aktiv - du kannst entweder über das pulsecontrol-Plugin (über das VDR-OSD unter dem Menüpunkt System erreichbar - da musst du sowohl den Stream auf das gewünschte Ausgabegerät verschieben als das zum neuen Default-Gerät machen), pavucontrol (ist über das desktop-Plugin, Menüpunkt "Applikationen" -> Zubehör) oder über das dbus-Interface von dbus_pulsectl gehen - also Ausgabesinks auflisten lassen - das sieht z.B. so aus:

    Und dann den gewünschten Namen angeben, um die laufende Ausgabe auf den Sink zu bewegen und den als Default-Device zu setzen:

    Code
    1. dbus-send --system --type=method_call --dest=org.yavdr.PulseDBusCtl --print-reply /org/yavdr/PulseDBusCtl org.yavdr.PulseDBusCtl.SetDefaultSink string:"alsa_output.pci-0000_01_00.1.hdmi-stereo"

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Quote

    Jetzt habe ich einfach eine 22.04. installiert und damit habe ich ein Bild bekommen. Vielen Dank also schonmal.

    Leider höre ich noch nichts :)

    vielleicht hilft es

    Beim NUC11PAH wird beim Start HDMI-A-1 i. Grub genutzt und dann wechselt der NUC11PAH auf DP-3 (z.B. für die xorg.conf für Kodi etc..,)

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Vielen Dank für deine Hilfe.

    Leider klappt es immer noch nicht, auch wenn ich hdmi-stereo oder hdmi-surround auswähle bleibt es leider stumm.

    Auch im Kodi bleibt es stumm :(

    Hat noch jemand eine Idee?


    Viele Grüße

    Stubi

  • war ist immer noch ein Thema z.B. bei softhdcuvid - (softhdrm und softhdvapi)

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • vielleicht hilft es

    Beim NUC11PAH wird beim Start HDMI-A-1 i. Grub genutzt und dann wechselt der NUC11PAH auf DP-3 (z.B. für die xorg.conf für Kodi etc..,)

    Leider kann ich damit nicht viel anfangen :)


    Im Pulsceontrol habe ich hdmi-stereo, hdmi-surround, hdmi-surround71 zur Verfügung, zusätzlich alle Varianten jeweils noch mit angehängtem "-extra1" (1-10, wie die Anzahl der HDMI-Geräte, die aplay -l ausgegeben hat)


    Viele Grüße

    Stubi

  • Quote

    Ich vermute, dass irgendwo ein falsches HDMI-Gerät benutzt wird. Leider weiß ich nicht, wo ich nachsehen kann.

    ein aplay -l gibt auch eine lange Liste aus, aus der ich nicht so recht schlau werde:

    das Problem am Ton (NUC11PAH) liegt im jedem Ausgabe-Plugin was der VDR nutzt (softhddevice, softhddrm, softhdvaapi)


    Dies kann man leicht testen --- einfach mal in der *.conf vom Ausgabe-Plugin den Ton auskommentieren und das MPV Plugin laden.

    Nach einem Neustart hat man Bild am TV (ohne Ton) dann mit dem MPV-Plugin eine Bsp. MP4-Datei laden und abspielen und schon hat man Bild & Ton am

    NUC11PAH.

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Hängt der NUC11 denn direkt am TV oder ist da ein Receiver dazwischen?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Laut https://forums.linuxmint.com/viewtopic.php?f=48&t=360524 könnte es einen Versuch wert sein mal SecureBoot abzuschalten.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Moin Leute,


    vielen Dank für die vielen Ideen.

    Es hängt noch ein Receiver zwischen TV und NUC. Ich kann es später testweise mal direkt anhängen. Secureboot habe ich bereits deaktiviert. Das löst das Problem also nicht.

    Den Test mit dem mpv-Plugin konnte ich leider wegen meiner Unfähigkeit nicht machen. Nach dem Start sehe ich das mpg-Fenster mit dem Hinweis, etwas hineinzudroppen. Leider weiß ich nicht, von wo ich droppen soll - ich habe keine weiteren Fenster. 😊


    Jetzt muss ich erst einmal den österlichen Pflichten nachkommen. Ich lese und teste später weiter.

    Ich muss auch noch herausfinden, warum das dv**pi-Plugin nur auf dem ersten Tuner funktioniert... 😢


    Viele Grüße

    Stubi

  • -P"softhddrm -C $CONNECTOR -r 50 -g $RESOLUTION -a $AUDIO_OUT" \

    1. CONNECTOR="DP-3"
    2. RESOLUTION="1920x1080+0+0"

    ich würde mal alles am NUC11PAH auf DP-3 setzen z.B. Grub und Ausgabe -Plugin


    z.B. Grub

    GRUB_CMDLINE_LINUX_DEFAULT="splash quiet video=DP-3:1920x1080@50D drm.edid_firmware=DP-3:edid/edid.bin nohz=off nolapic-timer"


    den NUC11PAH hierzu am HDMI Port anschließen und direkt zum TV-Gerät

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Ich bin damit leider etwas überfordert ?(

    Ich benutze das Ausgabeplugin softhdvaapi:

    Code
    1. selected_frontend: softhdvaapi
    2. vdr_output_plugin: vdr-plugin-softhdvaapi

    Leider läuft jetzt auch das Playbook nicht mehr durch:

    Code
    1. TASK [yavdr-xorg : start x-verbose@.service] ******************************************************************************************
    2. fatal: [localhost]: FAILED! => {
    3. "changed": false
    4. }
    5. MSG:
    6. Unable to start service x-verbose@vt7.service: Job for x-verbose@vt7.service failed because the control process exited with error code.
    7. See "systemctl status x-verbose@vt7.service" and "journalctl -xeu x-verbose@vt7.service" for details.

    ein Aufrufen der beiden Befehle für mehr Details ergibt dann:

    Wie ich sonst das Ausgabeplugin ändern soll, weiß ich nicht und ich habe auch keine Ahnung, wie ich den Plugins die Startparameter mitgeben kann. *schäm*


    Ein direktes Anschließen an den Fernseher hat keine Änderung gebracht.


    Viele Grüße

    Stubi