[Gelöst] yavdr-ansible und wlan mit netplan

  • Hallo, ich bekomme die Verbindung zu meinem wlan mit wpa2 und meiner Netzwerkkarte Broadcom BCM4352 nicht hin.

    Wie ist denn der Standardweg unter yavdr-ansible? Die Treiber wurden bei der Erstinstallation bereits installiert, das Gerät wird angezeigt und ist up. Der Treiber ist der bcmwl-kernel-source, Firmware habe ich nachinstalliert

    Ich habe eine wpa_supplikant.conf erstellt, aber das Gerät verbindet sich nicht.

    Vielleicht kann mir jemand helfen. Danke schon mal.



    yavdr-ansible

    Mainboard: FUJITSU D3162-A1
    CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Ram: 3.96 GB
    Festplatte(n): Samsung SSD 850
    WDC WD30EFRX-68E
    Opt. Laufwerke: HL-DT-ST DVD-RAM GSA-H30N
    Netzwerkkarte: Intel Ethernet Controller + Broadcom WLAN Controller
    Grafikkarte: NVIDIA Corporation Device 128b (rev a1) (Geforce 710 passiv) über HDMI an Beamer

    Soundkarte: Intel Audio device analog an Stereo Verstärker
    TV-Karte(n): 2 x Digital Device DVB C

    DKMS Status:

    broadcom-sta

    dddvb, 0.9.36.0easyVDR0, 4.4.0-96-generic, x86_64: installed

    nvidia-370, 370.28, 4.4.0-96-generic, x86_64: installed

  • Wie genau bist du dabei vorgegangen? Für systemd-networkd müsste der in https://wiki.ubuntuusers.de/sy…-networkd/#Arbeitsstation beschriebene Weg funktionieren.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • seahawk1986 : Danke für den Link. Systemd habe ich bisher noch nicht fürs wlan konfiguriert, hole das heute aber nach.

    Melde mich dann wieder.



    yavdr-ansible

    Mainboard: FUJITSU D3162-A1
    CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Ram: 3.96 GB
    Festplatte(n): Samsung SSD 850
    WDC WD30EFRX-68E
    Opt. Laufwerke: HL-DT-ST DVD-RAM GSA-H30N
    Netzwerkkarte: Intel Ethernet Controller + Broadcom WLAN Controller
    Grafikkarte: NVIDIA Corporation Device 128b (rev a1) (Geforce 710 passiv) über HDMI an Beamer

    Soundkarte: Intel Audio device analog an Stereo Verstärker
    TV-Karte(n): 2 x Digital Device DVB C

    DKMS Status:

    broadcom-sta

    dddvb, 0.9.36.0easyVDR0, 4.4.0-96-generic, x86_64: installed

    nvidia-370, 370.28, 4.4.0-96-generic, x86_64: installed

  • warum so kompliziert?


    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • seahawk1986 :

    So, bin nach der von dir verlinkten Anleitung vorgegangen und kann nun mit "systemctl start Broadcom@wlp3s0.service" das wlan starten und mit "dhclient wlp3s0" eine IP zuweisen. Wenn ich das jetzt noch für den Rechnerstart automatisieren könnte, wäre ich sehr zufrieden.


    Kann mir da noch jemand weiter helfen?


    CKone : Ich habe mal so eine 01-netcfg.yaml erstellt und mit meinen Daten gefüllt. Leider ohne Erfolg. Trotzdem Danke.



    yavdr-ansible

    Mainboard: FUJITSU D3162-A1
    CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Ram: 3.96 GB
    Festplatte(n): Samsung SSD 850
    WDC WD30EFRX-68E
    Opt. Laufwerke: HL-DT-ST DVD-RAM GSA-H30N
    Netzwerkkarte: Intel Ethernet Controller + Broadcom WLAN Controller
    Grafikkarte: NVIDIA Corporation Device 128b (rev a1) (Geforce 710 passiv) über HDMI an Beamer

    Soundkarte: Intel Audio device analog an Stereo Verstärker
    TV-Karte(n): 2 x Digital Device DVB C

    DKMS Status:

    broadcom-sta

    dddvb, 0.9.36.0easyVDR0, 4.4.0-96-generic, x86_64: installed

    nvidia-370, 370.28, 4.4.0-96-generic, x86_64: installed

  • Das wifi Passwort muss in Gänsefüßchen, ohne Gänsefüßchen ist es der psk- musste mal schauen, weiß Gerade nicht mehr wie ich den damals ermittelt habe. Mit den Gänsefüßchen bin ich nicht weitergekommen da ich die im Kennwort hatte und nicht wusste wie ich die korrekt escape.

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Ich glaube ich habe das hier aus ssid und Kennwort generiert: https://www.wireshark.org/tools/wpa-psk.html

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • CKone : Ok, ich probiere das noch mal mit dem generierten psk aus.



    yavdr-ansible

    Mainboard: FUJITSU D3162-A1
    CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Ram: 3.96 GB
    Festplatte(n): Samsung SSD 850
    WDC WD30EFRX-68E
    Opt. Laufwerke: HL-DT-ST DVD-RAM GSA-H30N
    Netzwerkkarte: Intel Ethernet Controller + Broadcom WLAN Controller
    Grafikkarte: NVIDIA Corporation Device 128b (rev a1) (Geforce 710 passiv) über HDMI an Beamer

    Soundkarte: Intel Audio device analog an Stereo Verstärker
    TV-Karte(n): 2 x Digital Device DVB C

    DKMS Status:

    broadcom-sta

    dddvb, 0.9.36.0easyVDR0, 4.4.0-96-generic, x86_64: installed

    nvidia-370, 370.28, 4.4.0-96-generic, x86_64: installed

  • Wenn ich das jetzt noch für den Rechnerstart automatisieren könnte, wäre ich sehr zufrieden.

    Das steht weiter unten im verlinkten Wiki-Artikel, wie man das beim Start durchführen lassen kann - aber der Weg, den CKone vorgeschlagen hat, ist besser, weil der den dafür vorgesehenen Dienst einspannt.

    Ich habe mal so eine 01-netcfg.yaml erstellt und mit meinen Daten gefüllt.

    Man muss die Konfiguration auch noch anwenden - vgl. https://wiki.ubuntuusers.de/Netplan/#Ausfuehrung

    Code
    1. $ sudo netplan generate
    2. $ sudo netplan apply

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo nochmal.

    Wenn der Weg über netplan der eigentlich richtige ist, würde ich auch gerne diesen gehen. Ich bekomme esaber nicht hin:

    Code
    1. $ sudo netplan generate
    2. $ sudo netplan apply

    Als Antwort kommt immer ein " Invalid Yaml: inconsitent identation". Ich habe alle Varianten ausprobiert: den 20-stelligen Wlanschlüssel mit und ohne "...", ebenso den über https://www.wireshark.org/tools/wpa-psk.html generierten.



    yavdr-ansible

    Mainboard: FUJITSU D3162-A1
    CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Ram: 3.96 GB
    Festplatte(n): Samsung SSD 850
    WDC WD30EFRX-68E
    Opt. Laufwerke: HL-DT-ST DVD-RAM GSA-H30N
    Netzwerkkarte: Intel Ethernet Controller + Broadcom WLAN Controller
    Grafikkarte: NVIDIA Corporation Device 128b (rev a1) (Geforce 710 passiv) über HDMI an Beamer

    Soundkarte: Intel Audio device analog an Stereo Verstärker
    TV-Karte(n): 2 x Digital Device DVB C

    DKMS Status:

    broadcom-sta

    dddvb, 0.9.36.0easyVDR0, 4.4.0-96-generic, x86_64: installed

    nvidia-370, 370.28, 4.4.0-96-generic, x86_64: installed

  • Identation ist ja kein inhaltliches Problem, das bezieht sich ja auf die Einrückungen beim Aufbau der Datei

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • So sieht meine yaml jetzt aus:



    yavdr-ansible

    Mainboard: FUJITSU D3162-A1
    CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Ram: 3.96 GB
    Festplatte(n): Samsung SSD 850
    WDC WD30EFRX-68E
    Opt. Laufwerke: HL-DT-ST DVD-RAM GSA-H30N
    Netzwerkkarte: Intel Ethernet Controller + Broadcom WLAN Controller
    Grafikkarte: NVIDIA Corporation Device 128b (rev a1) (Geforce 710 passiv) über HDMI an Beamer

    Soundkarte: Intel Audio device analog an Stereo Verstärker
    TV-Karte(n): 2 x Digital Device DVB C

    DKMS Status:

    broadcom-sta

    dddvb, 0.9.36.0easyVDR0, 4.4.0-96-generic, x86_64: installed

    nvidia-370, 370.28, 4.4.0-96-generic, x86_64: installed

  • Da dürfen - so weit ich mich erinnere - keine Tabulatoren drin sein, nur Leerzeichen zum Einrücken.

    Viel Erfolg!

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Als Antwort kommt immer ein " Invalid Yaml: inconsitent identation".

    Dann hast du die Zeilen nicht sauber eingerückt - alles Spaces, gleiches Einrückungslevel und daran denken, dass man hier im Forum bei Codeblöcken immer auf den Inhalt Kopieren-Knopf drücken muss, damit man eine Form bekommt, die man in eine Datei einfügen kann, sonst landet da immer ein Zeichen <200> am Anfang der jeder Zeile.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Was sind das für X hinter SSID?

    Da gehört nur die SSID durch deine ersetzt und nach dem Doppelpunkt ist die Zeile zu Ende wie in meinem Beispiel

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • CKone : Das war der entscheidende Hinweis! Ich habs jetzt verstanden: SSID in deinem Beispiel wird durch meine SSID ersetzt und nicht hinter den Doppelpunkt geschrieben. So gemacht, Neustart: Wlan ist up und connected.


    Mein VDR hat wieder Internet ohne dass sich immer ein Netzwerkkabel quer durchs WZ schlängelt.


    Allen Beteiligden vielen Dank!



    yavdr-ansible

    Mainboard: FUJITSU D3162-A1
    CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Ram: 3.96 GB
    Festplatte(n): Samsung SSD 850
    WDC WD30EFRX-68E
    Opt. Laufwerke: HL-DT-ST DVD-RAM GSA-H30N
    Netzwerkkarte: Intel Ethernet Controller + Broadcom WLAN Controller
    Grafikkarte: NVIDIA Corporation Device 128b (rev a1) (Geforce 710 passiv) über HDMI an Beamer

    Soundkarte: Intel Audio device analog an Stereo Verstärker
    TV-Karte(n): 2 x Digital Device DVB C

    DKMS Status:

    broadcom-sta

    dddvb, 0.9.36.0easyVDR0, 4.4.0-96-generic, x86_64: installed

    nvidia-370, 370.28, 4.4.0-96-generic, x86_64: installed

  • Ein Problem gibt es jetzt noch: ich kann den vdr nicht mehr per ssh erreichen. Wo muss ich denn da noch nacharbeiten?



    yavdr-ansible

    Mainboard: FUJITSU D3162-A1
    CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Ram: 3.96 GB
    Festplatte(n): Samsung SSD 850
    WDC WD30EFRX-68E
    Opt. Laufwerke: HL-DT-ST DVD-RAM GSA-H30N
    Netzwerkkarte: Intel Ethernet Controller + Broadcom WLAN Controller
    Grafikkarte: NVIDIA Corporation Device 128b (rev a1) (Geforce 710 passiv) über HDMI an Beamer

    Soundkarte: Intel Audio device analog an Stereo Verstärker
    TV-Karte(n): 2 x Digital Device DVB C

    DKMS Status:

    broadcom-sta

    dddvb, 0.9.36.0easyVDR0, 4.4.0-96-generic, x86_64: installed

    nvidia-370, 370.28, 4.4.0-96-generic, x86_64: installed

  • Ist dein Router so konfiguriert, dass WLAN-Geräte untereinander kommunizieren dürfen?

    Hast du in der Konfiguration von sshd (/etc/ssh/sshd_config) den SSH-Daemon an eine bestimmte Adresse gebunden?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • seahawk1986 : wlan-Geräte dürfen kommunizieren, und sshd ist an keine bestimmte Adresse gebunden.



    yavdr-ansible

    Mainboard: FUJITSU D3162-A1
    CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    Ram: 3.96 GB
    Festplatte(n): Samsung SSD 850
    WDC WD30EFRX-68E
    Opt. Laufwerke: HL-DT-ST DVD-RAM GSA-H30N
    Netzwerkkarte: Intel Ethernet Controller + Broadcom WLAN Controller
    Grafikkarte: NVIDIA Corporation Device 128b (rev a1) (Geforce 710 passiv) über HDMI an Beamer

    Soundkarte: Intel Audio device analog an Stereo Verstärker
    TV-Karte(n): 2 x Digital Device DVB C

    DKMS Status:

    broadcom-sta

    dddvb, 0.9.36.0easyVDR0, 4.4.0-96-generic, x86_64: installed

    nvidia-370, 370.28, 4.4.0-96-generic, x86_64: installed

  • Das Ding wird jetzt eine andere ip haben als mit dem lan device, musste mal in der Fritz schauen wo der jetzt auftaucht.

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5