Video Treiber für Odroid-N2+ (softhdodroid)

  • Frage:

    Sind die Erweiterungen eingeflossen um die Plugins vdrboblight oder seduatmo zu füttern?

    ist ja jetzt fast schon ein Jahr alt dein Post: hast du das zwischenzeitlich zum Laufen bekommen (Ubuntu bzw. Coreelec), die Schnittstelle sollte ja für beide Plugins identisch sein?


    Ich hab Jörg gebeten das seduatmo um den Frontendnamen zu erweitern damit es weiß wo es sich attachen soll, werde danach mal hier auf VDRSternELEC testen.

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • ist ja jetzt fast schon ein Jahr alt dein Post: hast du das zwischenzeitlich zum Laufen bekommen (Ubuntu bzw. Coreelec), die Schnittstelle sollte ja für beide Plugins identisch sein?


    Ich hab Jörg gebeten das seduatmo um den Frontendnamen zu erweitern damit es weiß wo es sich attachen soll, werde danach mal hier auf VDRSternELEC testen.


    Hallo,

    ich meine das JoJo das eingebaut hat, jedoch nutze ich auf dem Odroid Hyperion.ng. Damit kann man das Bild direkt grabben und an die Sedu-Lights ausgeben. Den "Umweg" mit dem boblight-plugin nutze ich auf dem NUC8 mit softhddrm und externen hyperion.ng.

  • So ganz rund läuft das auf meinem n2+ noch nicht mit dem seduatmo, ich muss das aber noch mal in Ruhe testen. - Das Plugin selber läuft, connected sich über die udev Rule mit dem Controller und kann auch die Farben separat ausgeben, soweit so gut. Wenn ich den atmo mode starte erhält sich der vdr aber merkwürdig, die CPU Load geht hoch und er zeigt auch keine sauberen Farben an - auch wenn es so scheint als würde er dem Bildinhalt irgendwie folgen.


    Ich muss da noch mal hinterhergehen - Vielmehr stoße ich mich im Moment aber eher an den enorm hohen Umschaltzeiten, da sind je nach Sender 6-8 Sekunden drin. - ich hab wirklich den ganzen Zoo an sofhd* Plugins hier am laufen (-cuvid, -drm, -vaapi) alle mit streamdev und überall sehe ich Zeiten von 1-3s. Verhalten ist auch unter ubuntu oder dem CE Image von Zabrimus identisch.


    Ist da irgendwo Abhilfe in Sicht, oder mach ich noch irgendwas falsch?

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • ohne seduatmo und auch nur mit softhdodroid und satip/streamdev, auf ubuntu ie auch auf CE Basis, Zabrimus bestätigt das auch. Vllt ne spezielle Einstellung in den Plugin settings die vom default abweichen?


    Ansonsten läuft die Kiste flüssig und macht ein Bild wie ne eins

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • ja gern, komm ich aber erst morgen zu

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • also mit dem reinen hardkernel image selber tu ich mich schwer, ich hab das aber jetzt als chroot unter coreelec laufen und da hab ich ganz ansprechende Umschaltzeiten. ich beobachte das mal weiter

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • jojo61 : Vielleicht ist das Problem von durchflieger ähnlich meinem Problem mit SES Demo UDH. Das Bild ist unter CE UBUNTU chroot zwar da, aber kaum sichar, so als hätte jemand die Helligkeit komplett runtergedreht. Nur wenn extrem helle Schriftzüge o.ä. da sind, sieht man es. Vielleicht hat KODI hier noch ein paar Dinge anders voreingestellt (Kontrast, Helligkeit, Farbe o.ä.). Unter Ubuntu funktioniert es ja einwandfrei, daher schließe ich meinen LG-TV z.B. aus.

    Komischerweise habe ich das Problem aber nicht beim Verkaufs-TV QVC ind UHD...

    ich war hier auch drüber gestolpert an meinem 10 Jahre alten Samsung FHD im Arbeitszimmer, hatte den odroid aber heute im Esszimmer am Sony UHD TV angeschlossen und die Inhalte wurden fehlerfrei , genauso wie von vom NUC8 mit softhddrm, wiedergegeben. Wenn man auf einen HLG Kanal schaltet atmet der Fernseher leicht durch und schaltet dann in einen anderen Modus, das HDR Bild wirkt auch leicht dunkler. (bei softhddrm auch)


    Hab Im kodi die Auflösung dann auf 2160p gesetzt und das Ganze läuft wirklich beeindruckend rund! :thumbup:


    Ich hab dann im Esszimmer auch das seduatmo noch mal probiert und hier ist definitiv noch was nicht korrekt:

    Er scheint sich an die API vom sofhdodroid zu connecten und versucht auch die LEDs entsprechend des Bildinhalts zuzuweisen. Es ist auch so das ich die angezeigten Farben "irgendwo" im Display wiederfinde aber es ist komplett flau und tut halt nicht das Erwartete bei recht viel CPU Last (bei 92 Kanälen die angefragt werden, also nur eine recht grobe Grafik).


    Die Frage wäre wie ich hier am besten vorgehe um das Ganze zu debuggen. Durch die chroot Umgebung kann ich ja mittlerweile schnell Änderungen an den beteiligten Plugins einsetzen. jojo61 : würde es hier Sinn ergeben, wenn ich horchi nach seinem Urlaub bitte das seduatmo so zu modifizieren, dass es alle 2-3s ein Bild wegschreibt um dessen Sicht zu sehen. man könnte ja hier eine Aufnahme pausieren und die dagegenhalten? Denke das mit der Last macht erst Sinn anzusehen wenn die Ausgabe funktioniert.


    Danke bis hier her, ganz neue Dimensionen am VDR - jetzt fehlt nur noch ordentlich UHS Content von den Sendeanstalten.

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



    The post was edited 1 time, last by CKone ().

  • würde es hier Sinn ergeben, wenn ich horchi nach seinem Urlaub bitte das seduatmo so zu modifizieren, dass es alle 2-3s ein Bild wegschreibt um dessen Sicht zu sehen. man könnte ja hier eine Aufnahme pausieren und die dagegenhalten?

    Also erstmal wegen dem dunklen UHD Bild: Die UHD Sender bis auf die Ausnahme vom Shopping Sender senden alle in HDR. Wenn der Fernseher dann nicht auf HDR umschaltet dann ist das Bild zu dunkel. Ob der Fernseher überhaupt HDR kann sieht man am EDID und genau danach richtet sich auch softhdodroid oder genauer gesagt der Kernel Treiber. Also vergleicht mal das edid wo es geht mit dem wo es nicht geht. Bei Fernshern die kein HDR können wird es auf SDR umgerechnet. Wenn das Bild also zu dunkel ist kann es ein das der TV (EDID) sagt er kann HDR aber dann doch nicht umschaltet.


    Ich kann nicht sagen wie seduatmo die Farben errechnet, aber es könnte evtl. sein das das Bild das ich liefere auf dem Kopf steht. Deswegen macht es sicher Sinn das seduatmo das Bild mal ausgibt damit man sieht auf welcher Basis es die Farben berechnet,


    mfg

    jojo61

  • Jörg ist noch eine Woche im Südafrika und schaut sich das dann an.


    AFAIR berechnen das seduatmo/vdrboblight gar nichts an den Farben. Vielmehr fragt es über die ATMO1_GRAB_SERVICE ein Bild in der Geometrie der verbauten LEDs - hier bei mir 38x21 also 118 LEDs am Frontend, an und schickt die Information (vermutlich einen Mittelwert der äußeren Pixel, bei cinebars geht er auch weiter rein ins Bild), direkt auf den LEDs aus. Das hat er damals mit johns entwickelt kann ich mich erinnern, aber das ist schon lang her. So richtig tief drin steckt da nur er.


    Aber wie du schon sagst wir müssen erst mal schauen was da für ein Bild ankommt im sedu.

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Ich habe hier auf einem odroid n2+ Mikroruckler beim TV sehen. Mir ist unklar, an welchen Parametern/Einstellungen ich spielen kann, damit die nicht mehr auftauchen. Das System ist CoreELEC mit der letzten Version von softhdodroid.


    Mit Android / Kodi habe ich keine Probleme feststellen können. Da wird alles ohne Probleme abgespielt.


    Hat jemand eine Ahnung was hier die Ursache sein könnte oder an Besten sogar eine Lösung?

  • Kann es sein das dein TV auf 60 Hz läuft ?

    Auf die Idee kam ich auch irgendwann, aber das Problem habe ich sowohl am TV, als auch am Monitor sowohl mit 50/60 Hz.

    Ein baugleiches Modell (mit derselben emmc) liefert an beiden Endgeräten gar kein Problem.

    Ich habe es auch noch nicht geschafft, die Boot-Reihenfolge auf SD, eMMC zu ändern. Dieses eMMC ein-/ausbauen geht mir auf den Senkel.

  • ich hab genau das gleich beobachtet mit chroot auf CE, und zwar fällt mir das nur bei Fußball auf wenn ich das aktuell im Arbeitszimmer parallel mitlaufen lasse. Habe gestern zum Gegentest mal meinen Celeron NUC7 mit softhdvaapi dran gehabt und da ist das nicht, auch wenn dort das Bild in sich nicht so toll ist wie bei odroid. Beide Geräte sind sind exakt gleich konfiguriert. Beim normalen Fernsehen ist das nicht zu bemerken, es fühlt sich an wie so ein leichtes Nachziehen hinter dem Ball.

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Habe gerade mal in die aktuelle Fußballübertragung von der ARD gezappt - das sieht alles sehr flüssig aus.

    Den Effekt, dass es ruckelig aussah, hatte ich aber auch schon ein paar mal. Das erste Problem war kodi - die Oberfläche war auf 60 Hz konfiguriert. Diese Rate blieb beim Wechsel zu vdr. Seitdem habe ich in kodi 50 Hz eingestellt. Alternativ könnte man

    Code
    1. echo 1080p50hz > /sys/class/display/mode

    in das Umschaltscript bei der Rückkehr zu vdr eintragen. Ich habe es bisher nur in meiner runvdr vor dem Start von vdr stehen.


    Ein anderes mal zeigte der TV 50 Hz, und dennoch lief es erst nach einem reboot wieder flüssig.


    Probier doch mal den o.g. Befehl. Wenn er was bringt, sollte man ihn im vdr-Startscript und beim Wechsel von kodi zu vdr ergänzen, dann kann kodi auch auf 60 Hz laufen.

    Was ist in der boot.ini und config.ini definiert? Ich bin mir nicht sicher, ob die boot.ini schon komplett obsolet ist oder zumindest Teile davon noch greifen.

    In meiner boot.ini steht setenv vout "1080p60hz" und in der config.ini sind HDMI custom mode und HDMI mode auskommentiert.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Das ist alles seltsam. Alles neu installiert und keine Probleme. Dann habe ich in Kodi die Refresh Rate auf 50Hz gesetzt und schon kamen die Probleme wieder.

    Die schlaue Idee, die Refresh Rate in Kodi wieder auf 60Hz zu setzen funktioniert nicht, weil ich nicht mehr an die Settings komme. Die sind jetzt disabled :/

    echo 1080p50hz > /sys/class/display/mode

    hat an dem Problem auch nichts geändert. Dann habe ich die /flash/config.ini geändert und folgende Einträge gemacht:

    Nach einem reboot lief wieder alles problemlos. Aber an die Kodi Einstellungen komme ich immer noch nicht. Aber wenn es jetzt läuft, werde ich erstmal nix weiter daran basteln.