Video Treiber für Odroid-N2+ (softhdodroid)

  • Es gibt mal wieder ein kleines Update.

    Bei den meisten wird ja der Ton über HDMI an den Fernseher übertragen. Und das evtl. auch noch als AC3 Stream. Dann geht ja die Lautstärkeregelung nicht mehr.

    Ich habe nun die libcec eingebunden und steuere den Amplifier des TV direkt an. Damit wird dann mit den VDR Lautstärketasten die Lautstärke des TV gesteuert.

    Allerdings kann man das nicht absolut setzen sondern nur immer lauter oder leiser senden. Deswegen ist es sinnvoll die Initiallautstärke des VDR beim start auf 127 zu setzen. Dann hat man spiel nach oben und unten. Ausserdem muss die "Volume Control" auf Hardware/CEC sitzen.

    Falls der Ton nicht vom Fernseher kommt sondern von einer über HDMI/CEC angeschlossenen Soundbar o.ä., dann kann man die Device Nummer davon auch einstellen.


    Viel Spass und Feedback willkommen.

    jojo61

  • beta

    wurde hier im Forum schon berichtet. Aber nicht als Problem des Plugins, sondern wohl der Audiospur des Senders. Ist bei mir mit softhdvaapi auch...

  • ...aber wohl in der allgemeinen Verwendung des Senders mit der Tonspur innerhalb VDR / channels.conf (Halbwissen AUS) ;)

  • Bei mir gibt es da auch keinen Ton derzeit. Habe ich aber noch nicht weiter untersucht. Da ich morgen für 3 Wochen in Urlaub fahre wird das wohl noch etwas liegen bleiben.


    Quote

    [aac @ 0x7f140008d0] Multiple frames in a packet.

    [aac_latm @ 0x7f140008d0] Multiple programs is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.

    [aac_latm @ 0x7f140008d0] If you want to help, upload a sample of this file to https://streams.videolan.org/upload/ and contact the ffmpeg-devel mailing list. (ffmpeg-devel@ffmpeg.org)

    Das ist die Fehlermeldung wenn ich versuche einen AC3 Downmix einzuschalten. Ich werde wohl mal ffmpeg aktualisieren. Alles weitere dann in 3 Wochen :-)

  • Eine gemachte Aufnahme (hier mit softhdvaapi) hat mit Kodi den Ton...

  • lnj


    Hhhmm - Upload? Where?

  • lnj

    Ah OK, here is the short *.ts

  • jojo61 ,

    PIP funktioniert bei UHD nicht.


    Ich habe bei mir festgestellt, dass die PIP-Funktion bei UHD-Sendern nicht funktioniert.

    Bei den anderen Sendern ist es manchmal etwas hakelig, geht aber meistens.


    Ist diese Funktion noch nicht richtig implementiert oder liegt es evtl. an meiner Software mit dem CoreElec-VDR von Zabrimus ?