Video Treiber für Odroid-N2+ (softhdodroid)

  • jojo61 : Erst einmal Danke für die neue Version. Die Umschaltzeiten sind so super.


    Leider ist mir noch etwas aufgefallen: Wenn ich per streamdev-client einen Kanal von einem anderen VDR herhole, ruckelt das Bild (ca. im Sekundenrhythmus) und Ton kommt gar nicht. Das hatte vorher (wenn auch mit langsamen Umschaltzeiten) funktioniert. LG

  • Tja alles kann ich im Vorfeld halt nicht testen. Dafür gibt es einfach zu viele Setups mit dem VDR. Ich schaue mir das mit den Radio Sendern mal an.

    Ob ich das mit den Streamdev-client lösen kann muss ich noch sehen. Danke für euer Feedback.


    jojo61

  • Post by beta ().

    This post was deleted by the author themselves ().
  • beta

    *puuh* - das freut mich aber - ist meine bevorzugte 'Empfangsart'...

    Client - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / Intel NUC8i3BEH / RAM 16 GB / SSD 240 GB m.2 / TV 82" Samsung / AVR Denon 3300

    Server - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / HP Proliant N54l / RAM 16 GB / System 2 TB HD Raid1 / Daten 4 TB HD Raid1 / 4 x DVB-S2 - DDCine & DuoFlex

  • Gibt es denn nicht Möglichkeit, wie bei softhddevice beim Umschalten bzw. bei Playmode pmNone ein schwarzes Bild zu setzen? Ich sehe, dass du diese Einstellungsoption nicht mit drin hast - aber ist das nur "Geschmackssache" oder gibt der Treiber es nicht her, die Bildausgabe schwarz zu machen?

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Ich gebe die Bilder ja nicht direkt aus. Das macht der Kernel und ich sende dorthin nur den Videostream. D.h. selbst das dekodieren des Videos wird schon im Kernel gemacht. Ich schaue es mir aber nochmal an.


    Habe nun mal rumgespielt und eine Möglichkeit gefunden das Bild zu löschen. Aber wenn ich das bei pmNone einbaue, dann gibt es beim umschalten eine

    (subjektiv unschöne) Schwarzphase. Und dann wird beim Radio Plugin kein Bild mehr angezeigt. :-( Das liegt dann wohl daran das diese Bilder keinen Video PTS enthalten. Ich werde es deswegen nicht einbauen zumal es ja eine Lösung mit dem Radioplugin gibt um ein ordentliches Bild bei Radio zu haben das auch Schwarz sein kann.

  • jojo61 : EIn Punkt ist mir noch aufgefallen. Wenn der VDR läuft und man sich dann per (open-)ssh einloggt, stockt das Bild ganz kurz (Bruchteil einer Sekunde). Audio ist kurz weg. Danach ist das Audio etwas tiefer von der Tonhöhe, als es eigentlich sein sollte. Das Bild ruckelt dann auch leicht. Ein erneutes Schalten auf denselben Kanal behebt das Problem.


    Edit: Dasselbe geschieht auch, wenn man die Shell mit CTRL-D verlässt. Sehr merkwürdig.


    Edit2: Das Problem verschwindet, wenn man unter General Make primary device auf ja stellt.

  • Ich habe hier https://github.com/beta68/ce_chroot ein Skript abgelegt, welches automatisch ein CoreElec KODI für den Odroid n2(+) in einer chroot-Umgebung unter Ubuntu erzeugt.


    Das genaue Vorgehen habe ich hier https://forum.odroid.com/viewt…hp?f=177&t=43593&start=50 beschrieben.


    jojo61 : Hattest Du meinen Post gesehen mit der Audio-Tonhöhe, wenn Dein Plugin nicht primary-Device ist?

  • Ich vermute, Du wolltest direkt auf Beitrag 42 verlinken? Mein Safari-Browser springt immer auf den ersten Beitrag auf Seite 2 des Threads im Odroid-Forum.

    Ich habe das jetzt nur mal auf die Schnelle überflogen und muss vorausschicken, dass ich meinen neuen N2+ bisher nur kurz mit CoreElec auf einer SD-Karte ausprobiert habe, also noch gar kein Ubuntu mit vdr installiert habe. Noch bin ich also dabei und versuche zu verstehen, wie das alles mal laufen soll.

    Bezüglich Schritt 10 und 12, also das Aufrufen des Kodi-Startscriptes aus dem laufenden vdr und die Rückkehr von Kodi zu vdr mit Aufruf des Scripts zum Aushängen der chroot-Umgebung:

    Wie hast Du das genau gelöst? Mit einem Eintrag in der commands.conf von vdr? Muss da noch mehr gemacht werden, z.B. softhdodroid suspenden? Oder wird das externalplayer-Plugin benötigt, damit vdr in den External-Playmode versetzt wird? Wir wollen ja nicht, das bei Längerem Verweilen in Kodi der vdr die Minimum Inaktivitätszeit erreicht und die Kiste mitsamt laufender chroot-Umgebung runterfährt.

    Und wie rufst Du das Script beim Beenden von Kodi auf? Da muss doch bestimmt noch eine Kodi-Konfigurationsdatei bearbeitet werden, damit das umount-Script beim Betätigen des „Verlassen“-Buttons ausgeführt wird.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • So nun habe ich erstmal die AV Sync optimierungen abgeschlossen. Jetzt sollte auch das springen in Aufnahmen besser funktionieren.

    Es gibt immer noch hin und wieder Probleme nach einen Sprung, aber da habe ich im Moment keine Idee woran das liegen könnte.


    Viel Spass

    jojo61

  • Ich unternehme meine ersten Versuche mit dem N2+ und softhdodroid. Dazu habe ich mir vdr 2.6 kompiliert und das Plugin aus dem git dazu. Zum Autostart habe ich dann /usr/local/bin/vdr in der /etc/rc.local eingetragen. In /etc/vdr/conf.d/vdr.conf steht der Eintrag user=root.

    Nach dem Booten startet vdr, aber es kommt nur ein OSD ohne TV-Bild. Das Bild kommt erst nach dem ersten Umschalten und bleibt dann auch. vdr läuft definitiv als root, sonst würde ein fehlender Zugriff auf das video-Verzeichnis bemeckert werden.


    Wenn ich vdr manuell auf der Konsole mit sudo starte, tritt das Problem nicht auf, das Bild ist sofort da. Im Log sehe ich nichts auffälliges. Ich habe den Verdacht, dass es eher was mit dem iptv-Plugin zu tun hat (ich habe kein DVB-device, weil der alte Kernel 4.9 meinen WinTV dualHD-Stick nicht erkennt). Trotzdem erstmal die Frage, ob es bezüglich Autostart irgend etwas besonders zu beachten gibt. Kann man das eleganter über systemd machen, damit das Netzwerk auch sicher schon up ist, ehe vdr startet? Wie habt Ihr das gelöst?

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Du könntest meinen Kernel nehmen und dazu crazycat's Treiber. Evtl. wird der Stick mit denen erkannt? Ansonsten fällt mir nur ein, beim Starten nach einer Sekunde Wartezeit svdrpsend den Kanal umschalten zu lassen.

    Gibt es Deinen Kernel fertig kompiliert oder muss das jeder selbst machen?
    Wie ist

    Quote

    Crazycat drivers disable KODI in chroot due to 2 unresolved symbols in videobuf-res.

    zu verstehen? Es geht doch gerade um Kodi bei Deiner chroot-Lösung?

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.