[gelöst]Neue NFS Freigabe einrichten

  • Hallo Gemeinde

    Ich bin am verzweifeln,versuche schon 2 Tage,aber ich bekomme es nicht gebacken.

    Möchte meine ext Platte als NFS freigeben.

    Ext Platte ist über esata angeschlossen und auf "/media/Media_Kiste" gemountet.

    Habe diese Seite mehrfach durchgelesen,aber ich kapiere es nicht .

    Alles was ich versucht habe funktioniert nicht .

    Kann mir jemand auf die Sprünge helfen?

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Gigabyte B560M DS3H,Core i5-11400,NVIDIA T400,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates.

    VDR-2 :ASUS AT3IONT-I Mini-ITX/DD Cine-S2-V7/2GB Kingston ValueRAM,SSD-32GB/HD-1TB,STM32 USB Adapter, FB-One for All 7145,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates

    Client: Raspberry Pi 3,LibreELEC 9.2.8

    TV am VDR=Sony KD-55AF8

  • Was hast du denn bisher wo eingetragen und welcher Fehler erscheint?


    Paket: "nfs-kernel-server" ist installiert?

    "/etc/exports" ist die Festplatte hinterlegt?


    Gibt es Fehler beim Freigeben oder beim Mounten auf der Client Seite?

    -- wird überarbeitet -- VDR- Server: Gigabyte Brix 3150 - (2x Hauppauge DualHD DVB-C Sticks mit 4 Tunern) - Ubuntu 18.04 - Aufnahme und Streaming-Server
    Client Wohnzimmer: DQ77KB - i3 - Logitech z-5500 - Blaupunkt 39" TV - Openelec (Streaming)
    Client Büro: Asus AT3N7A-I , yaVDR0.6.1 (Streaming + Cutting) - 19" TFT
    Test Client1: Raspberry Pi + openelec

  • Hier meine /etc/exports


    Code
    1. root@stube:/home/frank# apt install nfs-kernel-server
    2. Paketlisten werden gelesen... Fertig
    3. Abhängigkeitsbaum wird aufgebaut.
    4. Statusinformationen werden eingelesen.... Fertig
    5. nfs-kernel-server ist schon die neueste Version (1:1.3.4-2.5ubuntu3.4).
    6. Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:
    7. libllvm11
    8. Verwenden Sie »sudo apt autoremove«, um es zu entfernen.
    9. 0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    10. root@stube:/home/frank#

    Habe mir noch folgende Datei erstellt /etc/avahi/services/media mit folgendem Inhalt

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Gigabyte B560M DS3H,Core i5-11400,NVIDIA T400,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates.

    VDR-2 :ASUS AT3IONT-I Mini-ITX/DD Cine-S2-V7/2GB Kingston ValueRAM,SSD-32GB/HD-1TB,STM32 USB Adapter, FB-One for All 7145,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates

    Client: Raspberry Pi 3,LibreELEC 9.2.8

    TV am VDR=Sony KD-55AF8

    The post was edited 1 time, last by pille2011 ().

  • Sieht eigentlich gut aus.

    Wie mountest du auf dem Client ?

    Was sagt "showmount -e <Server IP Adresse> auf dem Client ?

    VDR
  • Sehr seltsam,jetzt funktioniert es auf einmal.

    Trotzdem Danke:thumbup::thumbup::thumbup:

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Gigabyte B560M DS3H,Core i5-11400,NVIDIA T400,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates.

    VDR-2 :ASUS AT3IONT-I Mini-ITX/DD Cine-S2-V7/2GB Kingston ValueRAM,SSD-32GB/HD-1TB,STM32 USB Adapter, FB-One for All 7145,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates

    Client: Raspberry Pi 3,LibreELEC 9.2.8

    TV am VDR=Sony KD-55AF8

  • Brauchte wohl (noch) einen Neustart (des nfs-servers oder des Rechners) ...

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 14 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF1050Ti SFF (nvidia-dkms-495), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.5.6-seahawk, vdr-epg-daemon mit Frodo-plugins, Kernel 5.15.6-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv.

  • Ja,irgend etwas hatte ich falsch gemacht(in /etc/exports-falscher Eintrag),aber das Gute ist nun hat man wieder etwas dazu gelernt.Dank diesem Forum:thumbup::]:thumbup:

    VDR-1:Steacom-ST-FC9S,Steacom-ST-Nano160,Gigabyte B560M DS3H,Core i5-11400,NVIDIA T400,DDR4 8GB 3200MHz,Crucial P2 CT500P2SSD8 500GB,DD Cine-S2-V7,STM32 USB Adapter,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates.

    VDR-2 :ASUS AT3IONT-I Mini-ITX/DD Cine-S2-V7/2GB Kingston ValueRAM,SSD-32GB/HD-1TB,STM32 USB Adapter, FB-One for All 7145,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates

    Client: Raspberry Pi 3,LibreELEC 9.2.8

    TV am VDR=Sony KD-55AF8

    The post was edited 1 time, last by pille2011 ().

  • Was ich gerne dabei vergesse ist nach der Änderung der "/etc/exports" Datei ein "sudo exportfs -ra" auszuführen um die exports neu im Server einzulesen.

    Ein Neustart des PCs funktioniert dafür aber auch.

    -- wird überarbeitet -- VDR- Server: Gigabyte Brix 3150 - (2x Hauppauge DualHD DVB-C Sticks mit 4 Tunern) - Ubuntu 18.04 - Aufnahme und Streaming-Server
    Client Wohnzimmer: DQ77KB - i3 - Logitech z-5500 - Blaupunkt 39" TV - Openelec (Streaming)
    Client Büro: Asus AT3N7A-I , yaVDR0.6.1 (Streaming + Cutting) - 19" TFT
    Test Client1: Raspberry Pi + openelec