[0.7] kein Bild nach Update (softhdvaapi)

  • Verstehe ich das richtig, dass du ppa:yavdr/experimental-vdr nutzt und es genügt das vdr-plugin-softhdvaapi-opengl zu installieren, damit wieder alles funktioniert? Dann kann ich für das vdr-plugin-softhdvaapi das Makefile von LIBPLACEBO=1 auf LIBPLACEBO_GL=1 umstellen und alle bekommen das als Paket-Update.

    Nein, ich verwende

    Code
    1. ppa:seahawk1986-hotmail/softhdvaapi-oibaf

    Soll ich das mal purgen und schauen, ob es dann noch geht?


    Edit: ich habe einfach mal ppa-purge ppa:seahawk1986-hotmail/softhdvaapi-oibaf

    gemacht und neu gestartet. Bild ist immer noch da.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

    The post was edited 1 time, last by rkp ().

  • Anders formuliert: was sagt apt policy vdr vdr-plugin-softhdvaapi-opengl?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Sorry wegen der Formatierung

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

  • Die Variante mit LIBPLACEBO_GL=1 ist völlig identisch mit der Variante LIBPLACEBO=1. Nur wird dann kein Vulkan sonder Opengl genutzt. Funktional ist da kein Unterschied. Wenn also nur noch LIBPLACEBO_GL=1 funktioniert, dann sollte man das als Standard nutzen.


    PS: ich werde mal schauen ob ich die aktuelle libplacebo wieder zum laufen bekomme.

  • Schlechte Nachrichten. Jetzt hängt sich mein VDR regelmässig auf. Im Log findet sich dann sowas:


    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

  • Ich habe gerade mal ein Backup-Image eingespielt, jetzt ist der VDR wieder auf dem Stand vor den Updates. Allerdings sind mittlerweile eine Menge Updates aufgelaufen, die ich natürlich gerne einspielen möchte, ohne erneut das Bild zu verlieren. Welches Update müsste man da blocken und wie?


    Antwort: apt-mark hold libplacebo*


    und man kann wieder gefahrlos updaten.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

    The post was edited 2 times, last by rkp ().

  • Ich habe das plugin softhdcuvid/vaapi/drm nun auf die libplacebo mit API 175 aktualisiert.


    Bei mir läuft softhdvaapi mit beiden libplacebo Varianten (vulkan und opengl) einwandfrei.

    Meinst du da 175 oder 157?

    Bzw. ist die API-Version das, was beim Tag hinten steht, ist also v4.157.0 die Version 4 mit API-Version 157?

    Oder wo steht die API-Version sonst?

  • Die API Version ist in der Datei meson.build zu finden.


    Also es gitb 3 meson.build Files.

    In keinem steht direkt lesbar eine API-Version.

    Beziehst du dich auf das "apiver = version_split[1]" da unten, das in der meson.build im Hauptverzeichnis zu finden ist?

    Dann wäre ja trotzdem v4.157.0 die Version 4 mit API-Version 157 und Fixversion 0. Dann finde ich aber keine API-Version 175 im Git.

  • Also im GIT gibt es nur ein meson.build und da steht die aktuelle API Version (und alle anderen) ganz oben. Aktuell wohl 206.


  • Ja, im Hauptordner gibt es nur eine meson.build und die ist in der aktuellen Version genau das, was du da oben auch gepastet hast.

    Bis 4.157.0sah das allerdings so aus, wie ich es gepastet hatte. Da gab es diese Liste mit den API-Versionen im meson.build nicht.

    Und selbst wenn: Ich verstehe nicht, wie ich jetzt die Version mit API-Version 175 finde, die du verwendet hast.

  • Und selbst wenn: Ich verstehe nicht, wie ich jetzt die Version mit API-Version 175 finde, die du verwendet hast.

    Ja das ist leider bei der libplacebo nicht so einfach. Das API 175 ist aus dem April 2021 wenn ich mich recht erinnere. Da musst du mal in der Historie von meson.build suchen.

  • Die folgende müsste die Version von jojo61 sein.


    Stefan


    Code
    1. wget https://github.com/haasn/libplacebo/archive/72cd260ad7d5aa564ff5e68caf16ec2633f3460e.zip
  • Ja das ist leider bei der libplacebo nicht so einfach. Das API 175 ist aus dem April 2021 wenn ich mich recht erinnere. Da musst du mal in der Historie von meson.build suchen.

    Hatte ich, aber ich hab sie leider nirgendwo gefunden.

  • Die folgende müsste die Version von jojo61 sein.


    Stefan


    Code
    1. wget https://github.com/haasn/libplacebo/archive/72cd260ad7d5aa564ff5e68caf16ec2633f3460e.zip

    Ok, danke - ich probiers mal aus.

  • Ok, danke - ich probiers mal aus.

    Jepp, sieht gut aus - zumindest hat die API-Version 175 lt. meson.build.