[yavdr-ansible] Kein Ton nach aufwachen nach /bin/systemctl suspend

  • Ich habe yavdr mit vdr_shutdown_command: "/bin/systemctl suspend" konfiguriert, damit das System bei einem Inaktivitäts-Timeout nicht komplett ausgeschaltet sondern in suspend geht und schneller aufwacht. Das funktioniert auch so, allerdings hab ich keinen Ton mehr nach dem Aufwachen. Wenn ich das System dann nochmal per Fernbedienung (POWER2 Taste) suspende und wieder aufwecke tut der Ton wieder! Macht das Abschalten/Suspend per Fernbedienung irgendwas anders als der automatische Shutdown Hook im VDR?

    Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR-ansible

    Frontend 2: Intel NUC, TerraTec Cinergy S2 USB, easyVDR 3.0.0

    Backend: Intel Core i7, Digital Devices CineS2 DVB-S2, Debian 10, vdr (e-tobi)

  • Wie gibst du denn den Ton aus und was steht im Log, wenn der Ton nach dem Aufwachen nicht funktioniert?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Der Ton wird über HDMI ausgegeben, bei mir ist das das Ausgabegerät "alsa_output.hw_1_7 laute pulsecontrol. Das ist der HDMI Ausgang der Onboard NVIDIA Corporation GT218 meines Mainboards.


    An vdr Logmeldungen finde ich bis auf diese Zeilen nur "normale" Meldungen:

    Code
    1. Aug 03 16:32:52 vdr vdr[16712]: vdr: error while reading '/var/lib/vdr/plugins/pulsecontrol/startup.script'
    2. Aug 03 16:32:52 vdr vdr[16712]: [16712] pulsecontrol: error on reading script /var/lib/vdr/plugins/pulsecontrol/startup.script

    Das Verzeichnis /var/lib/vdr/plugins/pulsecontrol existiert, aber ein startup.script gibt es dort nicht, das Verzeichnis ist komplett leer.


    Diese Meldungen kommen aber auch bei einem Startup, bei dem der Ton dann tut.


    Soll ich noch logs von anderen Prozessen checken?

    Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR-ansible

    Frontend 2: Intel NUC, TerraTec Cinergy S2 USB, easyVDR 3.0.0

    Backend: Intel Core i7, Digital Devices CineS2 DVB-S2, Debian 10, vdr (e-tobi)

  • Was hängt denn am HDMI-Ausgang? Ein Receiver oder direkt der TV?

    Hast du mal im pulsecontrol-Plugin (oder pavucontrol) geschaut, ob der HDMI-Ausgang nach dem Aufwachen immer noch das aktive Ausgabegerät ist? Man kann pulseaudio zwingen ein bestimmtes Gerät zu nutzen: https://wiki.archlinux.org/tit…to_detect_the_Nvidia_HDMI

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Am HDMI Ausgang hängt direkt der Fernseher.


    Ich hatte nach dem Aufwachen schon mal im pulsecontrol die Option "setze Standardausgabegerät" verwendet um die Karte nochmal zu setzen. Checken konnte ich das da nicht. Die Settings in dem von Dir verlinkten Artikel habe ich bereits gemacht.

    Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR-ansible

    Frontend 2: Intel NUC, TerraTec Cinergy S2 USB, easyVDR 3.0.0

    Backend: Intel Core i7, Digital Devices CineS2 DVB-S2, Debian 10, vdr (e-tobi)

  • Kannst du mal vergleichen, was pulseaudio normalerweise so sieht, wenn der Ton funktioniert und wenn der nach dem Aufwachen weg ist?

    Code
    1. sudo tmux -S /tmp/tmux-666/default # in der Session anmelden
    2. pactl list

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Die foldenden Sektionen fehlen in der pactl list Ausgabe, wenn der Ton weg ist:



    Zusätzlich sind dann noch einige Zeilen im Abschnitt Karte #1 unterschiedlich.


    Die unterschiedlichen Zeilen sind:

    Code
    1. output:hdmi-stereo-extra1: Digital Stereo (HDMI 2)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 5700, verfügbar: nein)
    2. Aktives Profil: off
    3. hdmi-output-1: HDMI / DisplayPort 2 (priority: 5800, latency offset: 0 usec, not available)

    Diese Zeile fehlt komplett in der Ausgabe ohne Ton:

    Code
    1. device.product.name = "Onlap2501HDP
    2. "

    Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR-ansible

    Frontend 2: Intel NUC, TerraTec Cinergy S2 USB, easyVDR 3.0.0

    Backend: Intel Core i7, Digital Devices CineS2 DVB-S2, Debian 10, vdr (e-tobi)

  • Werden die fehlenden Geräte wieder sichtbar, wenn du das nachfolgende Skript als root ausführst?

    Code
    1. #!/usr/bin/bash
    2. devices=($(lspci | grep "Audio device" | cut -d" " -f1))
    3. for device_id in "${devices[@]}"
    4. do
    5. echo $device_id
    6. device_path=$(compgen -d /sys/bus/pci/devices/*${device_id})
    7. echo 1 > "${device_path}/remove"
    8. done
    9. echo 1 > /sys/bus/pci/rescan

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Werden die fehlenden Geräte wieder sichtbar, wenn du das nachfolgende Skript als root ausführst?

    Nein, die pactl Ausgabe sieht immer noch so aus wie vorher.

    Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR-ansible

    Frontend 2: Intel NUC, TerraTec Cinergy S2 USB, easyVDR 3.0.0

    Backend: Intel Core i7, Digital Devices CineS2 DVB-S2, Debian 10, vdr (e-tobi)

  • Gerade ist der Ton während dem "normalen" Betrieb einfach weg gewesen. Video läuft ganz normal weiter. Ich hab mich dann gleich auf dem System eingeloggt und mit journalctl die letzten 3 Minuten geholt:


    Ich denke mal, das "audio/alsa: using device 'default'" ist der Punkt, an dem das Audio Device wegfällt.

    Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR-ansible

    Frontend 2: Intel NUC, TerraTec Cinergy S2 USB, easyVDR 3.0.0

    Backend: Intel Core i7, Digital Devices CineS2 DVB-S2, Debian 10, vdr (e-tobi)

  • Aug 09 18:31:54 vdr vdr[14068]: [14084] SATIP-ERROR: Tuning timeout - retuning [device 1]

    Mich wundert, dass da danach das Video "noch ganz normal weiter" läuft.

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Das Signal kommt über die eingebaute DVB-S2 Karte. Die vom SAT>IP Plugin bereitgestellten Devices haben eine niedrigere Priorität soweit ich die Konfiguration verstanden habe.

    Ich habe das SAT>IP Plugin aber mal deinstalliert um jeglichen Einfluss auszuschließen.

    Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR-ansible

    Frontend 2: Intel NUC, TerraTec Cinergy S2 USB, easyVDR 3.0.0

    Backend: Intel Core i7, Digital Devices CineS2 DVB-S2, Debian 10, vdr (e-tobi)