[gelöst] Yavdr 07 Streamdev Client mit Osd2web Fehler

  • Seit ca. 2 Tagen habe ich ein Problem mit meinen Streamdev Clients (softhddevice mit va-api)

    An der Konfiguration hat sich nichts geändert, aber seit einem dist-upgrade funktioniert der Client nicht mehr sobald das osd2web-Plugin aktiviert ist - Siehe Log (Buffer läuft voll und VDR bleibt stehen.)

    Ich habe 2 VDRs mit streamdev-client und osd2web - beide mit gleichem symtom :-(

    Was ich schon versucht habe:

    -VDR und Plugins neu compiliert

    -setup.conf aus Backup eingespielt

    -osd2web Theme geändert

    -streamdev-plugin auf server und clients neu installiert.

    -vorherigen Kernel gebootet

    -andere Plugins deaktiviert (außer streamdev-client)

    ......


    Wenn ich osd2web nicht aktiviere gibt es keinen Fehler, aber am osd2web kann es eigentlich nicht liegen.

    Mein Haupt VDR mit eigener DVB Karte läuft auch mit osd2web einwandfrei.


    Mit der Fehlermeldung kann ich nichts anfangen und ich sehe auch keinen Zusammenhang zwischen streamdev-client und osd2web.

    Hat jemand eine Idee was da durch ein dist-upgrade passiert sein könnte ?


    Log
  • Ich benutze kein streamdev-client, habe aber prinzipiell die gleichen Probleme mit dem osd2web-Plugin.

    Siehe hier: [yavdr-ansible@focal] VDR-PC friert ca. 1x pro Woche ein und ist unbedienbar


    Seit dem ich damals das osd2web-Plugin deaktiviert habe, gab es nie mehr ein Einfrieren des VDR.

    Was der Bug im osd2web-Plugin ist, kann ich nicht sagen, außer dass eben der Speicher-RAM und dann auch der SWAP voll läuft.


    Meine Lösung ist momnetan: osd2web-Plugin bleibt deaktiviert!

  • Ok, Problem gefunden !

    Ich starte den osd2web.service schon lange mit dem Firefox als Browser

    Jetzt nach einem Upgrade wurde der Firefox geupdated - danach der Fehler wie oben beschrieben.

    Habe jetzt den Kiosk-Browser wieder im osd2web.service eingetragen und osd2web funktioniert wieder.

    Was da mit dem Firefox Update passiert ist, bleibt mir ein Rätsel.

  • merkwürdig das der Browser das streamdev stört. Aber prima das du es gefunden hast.

  • Habe jetzt den Kiosk-Browser wieder im osd2web.service eingetragen und osd2web funktioniert wieder.

    Ich hatte nur den Kiosk-Browser ( so wie er bei yavdr-focal installiert wird) verwendet und trotzdem die von mir beschriebenen Probleme mit dem Einfrieren des VDR gehabt.

    Wundert mich also etwas, dass es nun bei Dir so einfach wieder läuft! :/

  • Ich sehe den Zusammenhang mittlerweile eher mit dem Frontend als mit dem Streamdev Client.

    Ein Client mit einer Nvidia Graka (softhddevice -vdpau), zwar ohne streamdev-client, funktioniert nach wie vor mit Firefox als osd2web Browser.

    2 Clients mit Intel Graka (softhddevice -va-api) und streamdev-client mögen den "neuen" Firefox nicht mehr als Browser für osd2web.

    Was genau das Problem verursacht, kann ich leider nicht feststellen.

    Könnte eigentlich ja auch am softhddevice mit vaapi liegen.?!?

  • Könnte eigentlich ja auch am softhddevice mit vaapi liegen.?!?

    Ich habe aber eine Nvidia-Karte GT1030 im VDR stecken und benutze softhddevice-cuvid, also kein vaapi!

  • Ich habe aber eine Nvidia-Karte GT1030 im VDR stecken und benutze softhddevice-cuvid, also kein vaapi!

    Die habe ich auch in dem VDR, der mit Firefox funktioniert :/

    Allerdings auf dem 3. Bildschirm


    Echt verwirrend =O

  • Nur zur Info:

    Habe die Firefox Version 89.0 auf die 84.0.2 zurückgesetzt.

    Alle Probleme mit hängendem VDR sind verschwunden.:]

    Die neue Version hat offensichtlich ein Problem mit softhddevice -va-vapi. Mal Abwarten ob die nächste Version wieder funktioniert.