Habe bei UHD-Sendern kein intaktes Bild

  • Verwende seit ein paar Monaten mld 5.5 und bin im großen und ganze zufrieden.

    Um das interne Display meines Gehäuses zu nutzen brauche ich einen VDR-Ausgang und habe deswegen alles über VDpau und eine Nvidia GF210, am laufen. Das Signal kommt direkt von der Antenne auf eine CineS2 eingebaut. Ich denke mal V5.5 oder V6. Leider zeigt lspci bei mld nichts verwertbares an.


    Mehr zum System siehe unten.


    Nun zur Frage. Die neuen UHD-Sender werden angezeigt, es kommt auch Ton, allerdings ist das TV-Bild in der linken Hälfte grün und von springenden Geisterbildern überlagert.

    Woran kann das liegen? Ist es die Grafikkarte? Ist es der VDR?



    System:

    Name: MLD 5.5

    Systemarchitektur: amd64

    Paket Kategorie: unstable

    vdr 2.4.7.220.3-220.7


    Hardware:

    Sytem: CPU: Quad Core Intel Core i7-6700 (-MT MCP-) speed/min/max: 800/800/4000 MHz Kernel: 5.12.8.202.116 x86_64 Up: 3h 02m Mem: 571.0/15942.7 MiB (3.6%) Storage: 2.84 TiB (59.2% used) Procs: 0 Client: Unknown Client: busybox inxi: 3.0.37


    Kernel: System: Host: MLD Kernel: 5.12.8.202.116 x86_64 bits: 64 Console: N/A Distro: MiniDVBLinux 5.5


    Model: Machine: Type: Desktop Mobo: ASUSTeK model: Z170-DELUXE v: Rev 1.xx serial: UEFI: American Megatrends v: 3801 date: 03/14/2018


    CPU: Topology: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP L2 cache: 8192 KiB Speed: 2151 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 1635


    Graphics: Message: No Device data found. Display: server: X.org 1.20.4 driver: nvidia tty: N/A Message: Unable to show advanced data. Required tool glxinfo missing.

    Sound: Audio: Device-1: HDA Intel PCH driver: HDA-Intel Device-2: HDA NVidia driver: HDA-Intel Sound Server: ALSA v: k5.12.8.202.116

  • Hi,

    UHD ist doch hevc bzw h. 265? Also schaffen alte Nvidia das nicht. Nur GT10x0 und neuer.

    Mfg Stefan


    Ich antworte mal hier, um den anderen Thread nicht zu kapern.


    Also eine lüfterlose GT1030 würde gehen? Welche anderen Modelle sind empfehlenswert? Sie muss zwingend einen VGA-Ausgang haben.

  • GT1030 geht.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Diese Grafikkarten haben aber keine VGA-Ausgänge mehr ... und VGA kann vielleicht noch HD, aber UHD wird nix.

    Schon der Monitor/TV wird über den VGA-Eingang bestenfalls "HD ready" wiedergeben, da für höhere Auflösungen irgendeine Form von HDCP Pflicht wird bie Fernsehern und VGA damit als rein analoger Signalweg nicht kompatibel ist - auch wenn ein UHD-Signal über den Analogweg "geprügelt" werden könnte.

    Wobei das ganz sicher ein Matsch wird (AD-Konverter) und analoge Rährenfernseher nicht UHD können :)

    Wikipedia - VGA

  • Verwende seit ein paar Monaten mld 5.5 und bin im großen und ganze zufrieden.

    Um das interne Display meines Gehäuses zu nutzen brauche ich einen VDR-Ausgang und habe deswegen alles über VDpau und eine Nvidia GF210, am laufen. Das Signal kommt direkt von der Antenne auf eine CineS2 eingebaut. Ich denke mal V5.5 oder V6. Leider zeigt lspci bei mld nichts verwertbares an.

    Also zu UHD kann ich nix sagen, aber ich habe auch ein internes TFT im Gehäuse, dazu einen Fernseher an meinem VDR hängen.

    Der TFT wird "außen herum" an den VGA-Ausgang der internen Intel-GPU gehängt, der Fernseher läuft über einen der HDMI-Ports dieser GPU.

    Das ist ein nagelneues MoBo, hat aber dennoch VGA.

    Die NVidia-Karte habe ich mittlerweile wieder raus geworfen, die wurde zu heiß. Da das ganze System komplett passiv gekühlt ist, hat die NVidia dazu geführt, dass die Core-Temp immer knapp am oberen Limit war, weil das Gehäuse innen zu warm wurde. Ohne die NVidia sind es fast 30° C weniger.

    Vorher war das TFT ebenfalls an der internen Intel-GPU gehangen, der Fernseher aber an der NVidia. Das geht gut, allerdings muss man ganz schon basteln, um den X-Server dazu zu bewegen, dieses Setup korrekt zu bedienen.


    Weiß nicht, ob das dir irgendwie weiter hilft - ich fürchte fast, dass nicht.

    Trotzdem :)


    Ciao.

    Michael.

  • So, danke für Euer Feedback.


    Das interne Display hängt am VGA und muss kein HD können. Es bekommt die Infos von graphtft mit 800x600px.


    wmautner & jsffm: Danke für das Feedback.

    Ddie ASUS PH-GT1030-O2G GeForce GT 1030 1GB Phoenix scheint passiv zu sein und mit vga. Mal sehen, ob ich eine bekomme.



    nobanzai :

    Wir scheinen eine ähnliche Konfiguration zu haben. Bei mir ist es das Moneual-Media Reference Gehäuse. Das Display wird auch per VGA nach außen geleitet. Habe es seit vielen Jahren. Ist im Grunde nicht mehr zeitgemäß, da viel zu groß, aber das Display ist echt nützlich, da ich es vom Sofa ablesen kann. Mein Lieblings Skin ist "anthraize-easy" welches von easyvdr stammt.


    Hatte auch jahrelang die Lösung mit intel-onboard am laufen. War einer der allerersten überhaupt, der das dauerhaft nutzte. Aber aus irgendeinem Grund geht genau die gemeinsame Nutzung von interner VGA und interner HDMI bei MLD nicht. Da ich mittlerweile nicht mehr stunden ins frickeln stecken möchte, ist die Nvidialösung die schnelle Abkürzung gewesen. Aber im Grunde halt völlig überflüssig und Stromverschwendung.


    Dank Euch fürs Feedback

  • Es gibt ja auch externe HDMI-zu-VGA-Wandler. Bei so modernen GPUs wird der VGA-Ausgang eh genauso realisiert, da die GPU-Chips von sich aus kein VGA mehr generieren können.

    MLD 5.5 mit VDR 2.4.1.219.4-219.4 & Kodi 18.6 - Gigabyte GA-F2A88XM-HD3 - AMD A8-7600 - 4 Gb RAM - Ausgabe via MSI N220GT-MD1GZ mit softhddevice & vdpau - 19.2E & 28.2E Empfang via Linux4Media L4M-Twin S2 ver 6.5 - Terratec Aureon 5.1 Fun TTP8 - Crucial m4 CT064M4SSD2 - Seagate Exos 7E8 - Medion X10 RF Remote Control 20016398

  • Wir scheinen eine ähnliche Konfiguration zu haben. Bei mir ist es das Moneual-Media Reference Gehäuse. Das Display wird auch per VGA nach außen geleitet. Habe es seit vielen Jahren. Ist im Grunde nicht mehr zeitgemäß, da viel zu groß, aber das Display ist echt nützlich, da ich es vom Sofa ablesen kann. Mein Lieblings Skin ist "anthraize-easy" welches von easyvdr stammt.


    Hatte auch jahrelang die Lösung mit intel-onboard am laufen. War einer der allerersten überhaupt, der das dauerhaft nutzte. Aber aus irgendeinem Grund geht genau die gemeinsame Nutzung von interner VGA und interner HDMI bei MLD nicht. Da ich mittlerweile nicht mehr stunden ins frickeln stecken möchte, ist die Nvidialösung die schnelle Abkürzung gewesen. Aber im Grunde halt völlig überflüssig und Stromverschwendung.


    Das mit dem "vom Sofa ablesen" kenne ich :) Mein Gehäuse ist ein OrigenAE.

    Wenn du willst, kann ich dir meine xorg.conf geben - da musst du vermutlich nur noch die Ports ändern.

    Ich hab fast 2 Wochen gebraucht, bis die so war, wie ich sie gebraucht habe.

  • da würde ich mich dann bei Bedarf nochmal melden. Momentan läuft alles und ich lasse es bis zum Herbst erstmal so, dann werde ich testen, ob es onboard wieder geht. Wenn ich was ändere, dann ist das Ziel auf jeden Fall auch UHD zu empfangen.

    Dank Dir!