markad-ng 3.011 für easyvdr 3.5

  • Hallo,

    falls noch wer das aktuelle markad-ng für die v3.5 sucht, bitte die anhängende markad nach /usr/bin/markad ersetzen und das Plugin in /usr/lib/vdr/plugins/.


    Natürlich vorher entpacken.

    MfG,

    Stefan


    PS:

    Zur Doku wie man es baut:

    Code
    1. apt install easyvdr-dev apt-src
    2. apt-src install vdr
    3. cd /root/vdr-2.2.0/PLUGINS/src/
    4. git clone https://github.com/kfb77/vdr-plugin-markad.git
    5. apt install libavcodec-ffmpeg-opti-dev libavformat-ffmpeg-opti-dev libswresample-ffmpeg-opti-dev libavutil-ffmpeg-opti-dev gettext libavcodec-extra libavfilter-ffmpeg-opti-dev libswscale-ffmpeg-opti-dev libpostproc-ffmpeg-opti-dev libavresample-ffmpeg-opti-dev
    6. cd vdr-plugin-markad
    7. make && make-install

    Files

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

    The post was edited 2 times, last by SurfaceCleanerZ ().

  • Hi Stefan!


    Sorry,die Suffix von ffmpeg ist für easyVDR-3.5 -> ffmpeg3

    bei easyVDR-3.0 lautet diese -> ffmpeg-opti

    Im Anhang Paket vdr-markad-ng_3.0.3-0easyVDR0~trusty_amd64.deb.txt

    und Paket vdr-plugin-markad-ng_3.0.3-0easyVDR0~trusty_amd64.deb.txt

    Bitte .txt entfernen!


    Gruss

    Wolfgang

    Files

    TT S2-6400 - saa716x kompilieren unter 20.04(Focal)

    The post was edited 1 time, last by wolfi.m ().

  • Hi,

    Also bei mir geht das von mir gebaute in easyvdr 3.5.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Ich bringe jetzt noch eine 3. Variante. Unter Ubuntu 14.04 die von SurfaceCleanerZ beschriebenen Libs, alle neueren Ubuntus: libavcodec-dev libavformat-dev libavfilter-dev libswresample-dev.

    Alle anderen Varianten müssten aber auch gehen, sofern (Zitat aus INSTALL) minimum version of libavcodec: 56.1.0 (FFmpeg 2.4).

    Wobei 56.x.x bereits als "deprecated" erklärt ist und eh nur noch wegen easyVDR drin ist.

    VDR
  • Hallo,


    Also bei mir geht das von mir gebaute in easyvdr 3.5.

    in PPA 3-hevc-base & PPA 3-hevc-vdr sind die geänderten Pakete für easyVDR-3.5

    Bei install easyvdr-dev aus PPA 3-hevc-base wird auch ffmpeg3-all-dev installiert.

    Paket ffmpeg3-all-dev

    Code
    1. Depends:libavutil-ffmpeg3-dev (= 3.3.0-0easyVDR2~trusty),
    2. libavcodec-ffmpeg3-dev (= 3.3.0-0easyVDR2~trusty),
    3. libavdevice-ffmpeg3-dev (= 3.3.0-0easyVDR2~trusty),
    4. libavformat-ffmpeg3-dev (= 3.3.0-0easyVDR2~trusty),
    5. libavfilter-ffmpeg3-dev (= 3.3.0-0easyVDR2~trusty),
    6. libpostproc-ffmpeg3-dev (= 3.3.0-0easyVDR2~trusty),
    7. libswscale-ffmpeg3-dev (= 3.3.0-0easyVDR2~trusty),
    8. libswresample-ffmpeg3-dev (= 3.3.0-0easyVDR2~trusty),
    9. libavresample-ffmpeg3-dev (= 3.3.0-0easyVDR2~trusty)

    Install Paket easyvdr-depends aus PPA 3-hevc-base installiert Paket ffmpeg3

    Code
    1. Depends: libavcodec-ffmpeg57,
    2. libavdevice-ffmpeg57,
    3. libavfilter-ffmpeg6,
    4. libavformat-ffmpeg57,
    5. libavresample-ffmpeg3,
    6. libavutil-ffmpeg55,
    7. libpostproc-ffmpeg54,
    8. libswresample-ffmpeg2,
    9. libswscale-ffmpeg4

    Wie man sieht wurde markad-ng von dir auch gegen die richtigen Files gebaut.

    Die *-ffmpeg-opti-dev stammen aus PPA 3-base-stable(ffmpeg(2.8.6) werden also nicht benötigt.

    ...easyVDr-3.5 PPA 3-hevc-base imstalliert ffmpeg-3.3.0 mit libavcodec-ffmpeg57


    Gruss

    Wolfgang

    TT S2-6400 - saa716x kompilieren unter 20.04(Focal)

  • Hi,

    Danke für die Erklärung!

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Hi,

    ich versuche gerade ein Update auf aktuelle Version, leider mit sehr vielen Warnings...

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Ich vermute mal das ist VDR 2.2, Ubuntu 14.04 mit gcc 4.8.

    Das Ubuntu ist seit April 2019 aus dem Standard Support (auch bei mir) und wird April 2022 End of Life sein (und das gilt dann auch für markad).

    Für so alte Compiler behebe ich keine Warnings mehr, es wir nur noch die Funktion bis April 2022 sichergestellt. Die Warnings kannst du ignorieren, es müsste trotzdem gehen.

    VDR
  • Hi,

    kein Problem, wollte es nur mal melden!

    Ja, es geht um 14.04.6.

    MfG,

    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Ich habe gerade mal wieder unter easyVDR 3 getestet und mir wurden die warnings auch lästig. In der nächsten Version werden sie unterdrückt (nicht gelöst, das lohnt sich nicht mehr).

    VDR