softhdcuvid - bilinear shader

  • Hi *,


    im README von softhdcuvid steht

    'Best you begin with setting all to "bilinear"'

    Einen bilinear shader finde ich allerdings nicht - und auch keine Einstellung mit diesem Namen.

    Kucke ich an der falschen Stelle?


    Danke und ciao.

    Michael.

  • bei softhdcuvid kenn ich mich nicht aus, aber bei softhdvaapi ist es in den plugin-einstellungen unter video bei den einzelnen auflösungen

  • Also es ist hier auch die Inkarnation softhdvaapi.

    Aber ich finde da keine solchen Einstellungen bei den Auflösungen.

    Hier sieht das so aus - Beispiel 1080:

    Code
    1. Monitor Type: sRGB Monitor
    2. * 576i: show
    3. * 720p: show
    4. * fake 1080: show
    5. * 1080: verstecken
    6. Skalierung: (null)
    7. Schneide oben und unten ab (Pixel): 0
    8. Schneide links und rechts ab (Pixel): 0
    9. * 2160p: show

    Shader habe ich aus dem Plugin-Source-Verzeichnis nach /etc/vdr/plugins/shaders kopiert.

    Es gibt KrigBilateral.glsl, LumaSharpenHook.glsl, adaptive-sharpen.glsl und filmgrain.glsl.


    Ich habe das Plugin mit -S adaptive-sharpen.glsl gestartet.

    Und es meldet auch, dass es den Shader initialisiert hat:

    Code
    1. Use Shader adaptive-sharpen.glsl
    2. [softhddev]Shaders initialized
  • Na nicht jedes softhd-xxx-plugin hat einstellungen zu shadern, daher kann ich nur zu softhdvaapi was sagen (in verbindung mit libplacebo). kann schon sein, dass es diese setup-optionen bei softhdcuvid nicht gibt.

  • "Also es ist hier auch die Inkarnation softhdvaapi."

    Also wie bei dir.

  • Hi,

    Dort Cursor nach rechts drücken, wenn auf der Auflösung mit * davor.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Hi,

    Dort Cursor nach rechts drücken, wenn auf der Auflösung mit * davor.

    Mfg Stefan

    Hat er doch bei 1080 schon wie im Bild aufgeklappt. softhdcuvid hat halt diese Settings nicht.

  • "Also es ist hier auch die Inkarnation softhdvaapi."

    Also wie bei dir.

    Wieso, wie bei mir?

    Ich benutze softvaapi und du softhdcuvid. Sind doch 2 verschiedene Ausgabeplugins. *vaapi für Intel und *cuvid müsste doch Nvidia sein.

  • Sorry, wieder mal softhdvaapi und softvaapi in einen Topf geworfen 8-<

    Und ne, softhdvaapi ist eine der beiden Intel Inkarnationen von softhdcuvid - nicht für NVidia.

    Für NVidia wäre es softhdcuvid in seiner Gestalt als softhdcuvid :)


    Irgendwann träum ich schlecht von den ganzen Variationen - das ist schlimmer als bei Covid-19.

  • Sorry, wieder mal softhdvaapi und softvaapi in einen Topf geworfen 8-<

    Und ne, softhdvaapi ist eine der beiden Intel Inkarnationen von softhdcuvid - nicht für NVidia.

    Für NVidia wäre es softhdcuvid in seiner Gestalt als softhdcuvid :)


    Irgendwann träum ich schlecht von den ganzen Variationen - das ist schlimmer als bei Covid-19.

    Na hab ich doch geschrieben, softhdvvapi für Intel und softhdcuvid für Nvidia. Ein softvaapi gibt es doch gar nicht.

  • Na hab ich doch geschrieben, softhdvvapi für Intel und softhdcuvid für Nvidia. Ein softvaapi gibt es doch gar nicht.

    Irgendwie reden wir aneinander vorbei, glaube ich.

    softhdvaapi ist doch softhdcuvid - das ist dasselbe Plugin, nur mit anderem Compile-Define.

    Und du hast oben geschrieben "ich benutze softvaapi und du softhdcuvid" und jetzt schreibst du "Ein softvaapi gibt es doch gar nicht.".

  • Bei der neusten libplacebo hat sich an den scalern was geändert. Kann sein das das derzeit nicht geht. Nutze mal die Version 3.117

    Das Plugin meldet, aber dass es die Scaler initialisiert hätte.

  • Und du hast oben geschrieben "ich benutze softvaapi und du softhdcuvid" und jetzt schreibst du "Ein softvaapi gibt es doch gar nicht."

    manoman, ein tippfehler halt.


    softhdvaapi ist doch softhdcuvid - das ist dasselbe Plugin, nur mit anderem Compile-Define

    es sind doch trotzdem unterschiedliche ausgabeplugins.

    um in deinem sprech zu bleiben, sind es doch alles "inkarnationen" des ursprünglichen softhddevice von johns, halt nur weiterentwickelt und auf aktuelle hardware angepasst.

  • es sind doch trotzdem unterschiedliche ausgabeplugins.

    um in deinem sprech zu bleiben, sind es doch alles "inkarnationen" des ursprünglichen softhddevice von johns, halt nur weiterentwickelt und auf aktuelle hardware angepasst.

    Sorry, ich will nicht pingelig sein, ich will es nur verstehen:

    Mit Inkarnation meine ich, dass sie alle aus demselben Paket kommen, nicht dass es unterschiedliche Pakete mit demselben Ursprung sind.

    Wenn man im Makefile von softhdcuvid VAAPI=1 setzt, dann kommt da softhdvaapi raus, setzt man CUVID=1, dann kommt softhdcuvid raus. Das meine ich mit Inkarnation. Ist das nun das, was du verwendest oder verwendest du ein anderes Paket, um dein vaapi-Plugin zu bauen?

    Oder bin ich völlig daneben?

  • Bei der neusten libplacebo hat sich an den scalern was geändert. Kann sein das das derzeit nicht geht. Nutze mal die Version 3.117

    Habs mal versucht, aber mit allem < 3.120 bekomme ich nach dem Übesetzen und Installieren beim Laden des Plugin die freundliche Mitteilung:

    vdr: /usr/lib/vdr/libvdr-softhddrm.so.2.5.1: undefined symbol: pl_filter_presets

    Erst mit 3.120 ist die weg und die Plugins lassen sich laden.

  • Habs mal versucht, aber mit allem < 3.120 bekomme ich nach dem Übesetzen und Installieren beim Laden des Plugin die freundliche Mitteilung:

    vdr: /usr/lib/vdr/libvdr-softhddrm.so.2.5.1: undefined symbol: pl_filter_presets

    Erst mit 3.120 ist die weg und die Plugins lassen sich laden.

    Hast du nach dem Übersetzen auch ein ldconfig grmacht ? Sonst nutzt er die alte Lib.

  • Ja, macht mein Script immer.

    Ich hab mit ldd auch nachgeschaut, welche libplacebo da drin verlinkt ist.

  • hier gabs zu der 120er gestern ein hotfix release, vllt hilft das?


    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5

  • Danke für den Hinweis, aber mit der Version habe ich gestern schon getestet - diesbzgl. leider keine Änderung 8-<