Startproblem softhddrm - drm:FindDevice

  • So nun startet es wieder.

    Irgendwie hat sich der Connector verändert von HDMI-A-1 auf DP-1.

    Da ich aber Tonprobleme mit libplacebo habe, wollte ich softhddrm ohne libpacebo übersetzen, das scheitert aber an:

  • Hi,


    apt install libdrm-dev


    und dann


    libdrm

    damit sollte es laufen


    cinfo

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • noch nicht ganz

    Code
    1. Run-time dependency pciaccess found: NO (tried pkgconfig and cmake)
    2. meson.build:247:0: ERROR: Dependency "pciaccess" not found, tried pkgconfig and cmake

  • Hallo,


    ist Paket libpciaccess-dev installiert?


    Gruss

    Wolfgang

    TT S2-6400 - saa716x kompilieren unter 20.04(Focal)

  • nein war es nicht.

    ich dachte, mit apt build-dep vdr-plugin-softhddrmwird alles notwendige zum bauen des paketes lokal installiert.

    auch nachdem cinfos anleitung durchgelaufen ist, baut das paket nicht ohne lipplacebo. jetz bricht es hiermit ab

    Code
    1. dpkg-shlibdeps: Fehler: keine Abhängigkeitsinformationen für /usr/local/lib/x86_64-linux-gnu/libdrm.so.2 (verwendet von debian/vdr-plugin-softhddrm/usr/lib/vdr/plugins/libvdr-softhddrm.so.2.4.7) gefunden
    2. Tipp: Prüfen Sie, ob die Bibliothek tatsächlich aus einem Paket stammt.
    3. dh_shlibdeps: error: dpkg-shlibdeps -Tdebian/vdr-plugin-softhddrm.substvars debian/vdr-plugin-softhddrm/usr/lib/vdr/plugins/libvdr-softhddrm.so.2.4.7 returned exit code 255
    4. dh_shlibdeps: error: Aborting due to earlier error
    5. make: *** [debian/rules:17: binary] Fehler 2
    6. dpkg-buildpackage: Fehler: Unterprozess debian/rules binary lieferte Exitstatus 2

  • Quote

    baut das paket nicht ohne lipplacebo

    Makefile

    "so eingestellt"


    cinfo

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • ich würde es einfach klassisch bauen aus den Git


    git clone https://github.com/jojo61/vdr-plugin-softhdcuvid


    - Makefile anpassen

    - make

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • ich würde es einfach klassisch bauen aus den Git

    naja, würde schon gerne bei den paketen bleiben.

    versuche es aber trotzdem mal ==> hat schon mal geklappt. warum auch immer es mit dem paket nicht ging.

    softhdvaapi konnte ich damals, wo es die problleme nach einem update gab, ohne libplacebo bauen.

    softhddrm mit libplacebo hat bei mir laufend tonausetzer.

    vllt. kann ja seahawk was dazu sagen, warum das nicht klappt.

    The post was edited 1 time, last by ofenheizer ().

  • Probiere mal mit LIBPLACEBO_GL=1 zu kompilieren, statt LIBPLACEBO=1


    Eventl. hilft das ja, beim vdr-plugin-softhdvaapi hat es geholfen:
    [0.7] kein Bild nach Update (softhdvaapi)

  • libplacebo_gl=1 ist standard bei softhddrm. ich wollte ja ohne libplacebo.

    softhdvaapi läuft bei mir bestens mit libplacebo.

  • Hat denn jemand eine Ahnung warum es zu Tonproblemen kommt bei Verwendung von softhddrm und libplacebo?

    Im Log habe ich dabei dauernd

    Code
    1. Nov 30 23:21:52 vdr vdr: Delay Audio 100 ms
    2. Nov 30 23:21:56 vdr vdr: Delay Audio 100 ms
    3. Nov 30 23:21:59 vdr vdr: Delay Audio 100 ms

    Und es gibt kleine Aussetzer.


    Eigenartigerweise ist bei Verwendung von softhdvaapi genaus andersherum, da tritt dieser Fehler ohne lipbplacebo auf.


    Leider habe ich aber mit softhdvaapi aktuell sporadische Ton/Bild-Probleme beim Abspielen von Aufzeichnungen, siehe softhdvaapi Abspielen von Aufnahmen, stottert manchmal

  • Ich habe auch einen NUC8, aber mit UHD mache ich nichts, alles FHD.

    Ich meine vor "langer" Zeit, mit meinen ersten Versuchen/Test mit softhddrm, lief das ganze mit libplacebo. Bin damals nur wieder zurück zu softhdvaapi, wegen der Kodi-Geschichte und weil im Skin (skindesigner) einiges nicht mehr ganz so schon dargestellt wurde.

  • Upps bin ich Blind oder wo ist der link ? Wenn du Tonprobleme mit softhddrm hast und es wird immer 100ms Audio eingeschossen dann ist das Bild zu langsam.

    Nur warum das so ist kann ich so einfach nicht sagen. Der NUC 8 sollte schnell genug dafür sein. Welche scaler hast du denn eingestellt ? Stell mal auf bilinear und schau mal ob es dann geht.

  • Der Link ist weiter oben in #32.

    Bei den scalern hatte ich eigentlich nichts angepasst, ich schau mal.

    Bei den haklern unter softhdvaapi, aus dem verlinkten Thread, ist bilinear eingestellt, aber da betrifft es ja nur die Aufnahmen.