[skindesigner] Aktuelle Version

  • Naja, das ist halt Geschmackssache... Das skindesigner-Plugin stellt hier "nur" das komplette OSD zur Verfügung, weil es ja nicht wissen kann, was der "Anwender" dann damit macht. So kann es natürlich passieren, das dann Skin-Abhängig sowas entsteht, z.B. für zusätzliche Informationen.

    Ich fürchte, ich hab mich unglücklich ausgedrückt: bei mir kommt bei der Kanalanzeige überhaupt kein weisslicher Rahmen rund um die "schwarze" Info-Leiste unten; und ich glaube, das soll auch so sein. Möchte damit sagen, dass der Rahmen gar nicht vom Skindesigner kommt, sondern viell. vom Ausgabeplugin?!

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Möchte damit sagen, dass der Rahmen gar nicht vom Skindesigner kommt, sondern viell. vom Ausgabeplugin?!

    ja, bei estuary4vdr wird so ein Rechteck nicht explizit gezeichnet, deshalb denke ich auch, das das vom Ausgabeplugin kommt. Es gab ja auch schon solche Fälle, wo nicht alles bereinigt wurde.


    Grüße

    kamel5

    VDR 2.6.0: ASUS Prime X470-PRO, Ryzen 7 2700, 64GB, 6TB HD, GT1030, Fedora 35 Kernel 5.15 X86_64, Devicebonding 2 x 1 auf 2, TT6400, DVBSky S952 V3

    Git-Repo: gitlab.com/kamel5

  • Ich vermute mal das dies mit softhdcuvid und libplacebo auftritt. Da wird evtl. der Alphakanal nicht komplett gelöscht.

    Da gab es vor ein paar Tagen einen Fix in libplacebo. Habe ich aber noch nicht ausprobiert. Kann das mal jemand mit der aktuellen libplacebo testen ?

    Ausserdem hatte ich da auch noch eine Korrektur für den Alphakanal gemacht. Also auch das plugin aktualisieren bitte.


    mfg

    jojo61

  • Mit akt. skindesigner, softhdvaapi und libplacebo folgende Beobachtung:

    - sobald das OSD geöffnet ist, wirkt das TV-Bild blasser (passiert auch mit skinnopacity-Plugin),

    - außerdem darf ich im OSD nur max. 97 % Breite und Höhe einstellen, sonst erfolgt der Absturz beim Neustart, sobald das OSD angezeigt werden soll. Läuft der VDR dann kann ich auf 100 % einstellen - bis zum nächsten Neustart. Komischerweise passiert das nur auf meinen NUC 8 mit Iris-VGA. Mit UHD 620 (10er CPU) oder UHD 630 (8er CPU) ist alles iO.


    Mit libplacbo API 117 und softhdvaapi-b2247ebb9b-git ist nichts blasser dargestellt beim Öffnen des OSDs und der Scaler-Test geht. Der Absturz bei OSD ab 98 % erfolgt aber immernoch...


    Stefan

  • ...ich habe bei mir im Plugin-Setup von softhdvaapi die Studio-Levels eingeschaltet. Dann ist bei mir die "Blässe" weg und das OSD sauber...

    Client - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / Intel NUC8i3BEH / RAM 16 GB / SSD 240 GB m.2 / TV 82" Samsung / AVR Denon 3300

    Server - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / HP Proliant N54l / RAM 16 GB / System 2 TB HD Raid1 / Daten 4 TB HD Raid1 / 4 x DVB-S2 - DDCine & DuoFlex

  • Die "Blässe" kommt aber doch von einem drübergelegten (?) Rahmen - zumindest schaut das in dem Screenshot so aus.

    Mit den Studio-Levels siehst du ihn viell. nicht mehr, aber er ist doch immer noch (fälschlicherweise) da, oder?

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Probiers doch aus, is doch nur ein Häkchen! ;) Hier läufts problemlos...

    Client - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / Intel NUC8i3BEH / RAM 16 GB / SSD 240 GB m.2 / TV 82" Samsung / AVR Denon 3300

    Server - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / HP Proliant N54l / RAM 16 GB / System 2 TB HD Raid1 / Daten 4 TB HD Raid1 / 4 x DVB-S2 - DDCine & DuoFlex

  • ...ich habe bei mir im Plugin-Setup von softhdvaapi die Studio-Levels eingeschaltet. Dann ist bei mir die "Blässe" weg und das OSD sauber...

    Mensch, Taipan. Der Tipp ist ein Kasten Bier wert. Danke!!

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

  • :thumbup: bleibt noch zu klären warum das so ist...

    Client - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / Intel NUC8i3BEH / RAM 16 GB / SSD 240 GB m.2 / TV 82" Samsung / AVR Denon 3300

    Server - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / HP Proliant N54l / RAM 16 GB / System 2 TB HD Raid1 / Daten 4 TB HD Raid1 / 4 x DVB-S2 - DDCine & DuoFlex

  • ...und in vdpau musste ich sie tunlichst auslassen für ein vernünftiges Bild

    Client - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / Intel NUC8i3BEH / RAM 16 GB / SSD 240 GB m.2 / TV 82" Samsung / AVR Denon 3300

    Server - yaVDR / seahawk1986-2.6.0 & Kernel 5.15.14 / Streamdev / HP Proliant N54l / RAM 16 GB / System 2 TB HD Raid1 / Daten 4 TB HD Raid1 / 4 x DVB-S2 - DDCine & DuoFlex

  • ...ich habe bei mir im Plugin-Setup von softhdvaapi die Studio-Levels eingeschaltet. Dann ist bei mir die "Blässe" weg und das OSD sauber...

    Bei mir (softhdcuvid) wird dann der helle Hintergrundrahmen nicht mehr gezeichnet. Leider bleibt immer noch eine feine, dunkle Linie vom unteren Rand der Channel-Box stehen.

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

    Im Aufbau: VDR-UHD mit nVidia GT1030 unter Ubuntu 20.04

  • Ob Studio-Levels oder nicht hängt von euren Einstellung am TV ab. Damit wird beschrieben ob der Dynamicbereich von 0 bis 255 oder von 16 bis 238 geht. Das muss zusammen passen sonst ist das Bild zu dunkel oder zu hell.


    Mit dem OSD Problem hat das nix zu tun auch wenn man es evtl. dann nicht mehr sieht.


    Ich hatte mal einen Patch zum skindesigner veröffentlich weil ich gesehen hatte das er beim löschen des OSD zuerst den Flush und dann das löschen gemacht hatte. Damit ist dann der letzte OSD Update stehen geblieben. Das ist dann der beschriebene Effekt das das OSD noch schwach zu sehen ist weil es das letzte ist was angezeigt wurde.

  • Hallo,


    es gibt eine neue Version 1.2.16:


    - add additional recording flag {isInUse} - can be used in skins for e.g. records in cutting/copy(queue)

    - add additional <vdrstatus> exposing {vdrIsRecordingsHandlersActive} and {vdrIsRecording} - can be used in skins for e.g. IDLE/BUSY REC/FREE

    - Fix Incorrect detection of a recording that is currently running

    - Fix segfault with mpv plugin (thx to lnj at vdr-portal.de)

    - Update skin estuary4vdr

    - add {vdrHasTimers} to <vdrstatus> - can be used in skins for e.g. REC/SCHED/FREE (in combination with {vdrIsRecording})

    - add <vdrstatus> also to displaymenu to be able to display in header

    - Fix display of recording sign in display channel

    - Fix a device is currently recording

    - Fix update timer in the main menu


    Grüße

    kamel5

    VDR 2.6.0: ASUS Prime X470-PRO, Ryzen 7 2700, 64GB, 6TB HD, GT1030, Fedora 35 Kernel 5.15 X86_64, Devicebonding 2 x 1 auf 2, TT6400, DVBSky S952 V3

    Git-Repo: gitlab.com/kamel5

  • Danke kamel5 für die Korrekturen und die laufende Weiterentwicklungen!

    Ich hab mal eine (viell.) blöde Frage, aber in welchem PPA ist denn diese aktuellste Version vom skindesigner enthalten?

    Im "yavdr/experimental-vdr" ist jedenfalls nur Version 1.2.8.4 drinnen.


    thx4info u lg

    davie2000

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Ich hab mal eine (viell.) blöde Frage, aber in welchem PPA ist denn diese aktuellste Version vom skindesigner enthalten?

    Im "yavdr/experimental-vdr" ist jedenfalls nur Version 1.2.8.4 drinnen.

    Eigentlich in allen relevanten für focal: https://launchpad.net/~yavdr/+…field.series_filter=focal https://launchpad.net/~seahawk…field.series_filter=focal https://launchpad.net/~seahawk…field.series_filter=focal - für bionic bin ich länger nicht mehr dazu gekommen Pakete zu bauen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke für die Info.

    Verdammt :wand .... jetzt muss ich wohl wirklich endlich mal auf focal umsteigen *Angst hab*

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD