mcli ERROR: video data stream broken

  • Hallo, um nicht den mcli Fork Thread weiter zu "missbrauchen" sammle ich hier die Infos:


    16:37:01 BM2LTSNuc64native-MCLI vdr: [3068] ERROR: video data stream broken


    Fakt ist, dass er immer nur ca. 30-120s nach Aufnahmestart auftritt. (markad habe ich disabled).


    Im .ts1 stoppt der VLC jedes Mal nach 20s.


    Die Ursache ist, dass in 00001.ts ab dann die TS-Pakete verschlüsselt sind (es sind insgesamt 206762 TS-Pakete, ab Paket #83140 nur mehr verschlüsselt).

    Das ERROR: video data stream broken kommt aus recorder.c wenn 30 Sekunden kein I-Frame erkannt wurde. Also muß ab ca. 17:38:20 irgend ein Ereignis die Entschlüsselung verhindern. Im Post 452 ist allerdings kein brauchbarer Hinweis zu finden.

    Lg helmut

    Die von Helmut analysierte Aufnahme liegt hier.


    Auch in unten angeführtem Fall stockt der 00001.ts nach ca 20s.


    Ich hätte in /etc/security/limits.conf do eingestellt:

    Code
    1. * hard core 100000
    2. * soft core 100000

    und ulimit -c bestätigt das auch. Leider wird kein File gespeichert ... :-(

    "initiating emergency exit" -> VDR ist noch "heile" genug, daß er sich selbst sauber beendet...da wird's keinen coredump geben - läuft vdr auf loglevel "3" (debug)....wenn immer noch nichts zu finden und es halbwegs schnell nach Start passiert -> als user "vdr" "bash -x runvdr" - sich die finale VDR-Kommandozeile rauspicken und das dann unter strace -o /tmp/vdr-strace.txt -f -s 1024 "vdr ....all..die...optionen" starten und Problem nachstellen. Das ganze kann man mit ltrace wiederholen....und dann mal strace.txt und ltrace.txt Dateien durchschauen, ob man irgendeinen Hinweis findet.


    btw. möglicherweise wäre des der Ordnung halber besser, für dieses Problem einen neuen Thread anzufangen pro problematischer Plugin-Kombination...

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

  • Post by gggggg ().

    This post was deleted by the author themselves ().
  • ich habe ohne Erfolg versucht in /opt/vdr/conf.d/vdr.conf den loglevel zu setzten


    1 wie prüfe ich ob der loglevel auf 3 ist ?


    2 kann man auch bei mcli den loglevel erhöhen ?

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

  • Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

  • ich vermute level 3 bringt uns nicht weiter oder ?

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

  • pbrb kfb77 könnt ihr mir bitte behilflich sein, wie der Aufruf aussehen muss !

    Quote

    als user "vdr" "bash -x runvdr" - sich die finale VDR-Kommandozeile rauspicken und das dann unter strace -o /tmp/vdr-strace.txt -f -s 1024 "vdr ....all..die...optionen" starten und Problem nachstellen. Das ganze kann man mit ltrace wiederholen....und dann mal strace.txt und ltrace.txt Dateien durchschauen, ob man irgendeinen Hinweis findet.

    Code
    1. root@BM2LTSNuc64native-MCLI:~# su vdr
    2. vdr@BM2LTSNuc64native-MCLI:/root$ bash -x runvdr
    3. bash: runvdr: Keine Berechtigung
    4. vdr@BM2LTSNuc64native-MCLI:/root$ sudo bash -x runvdr
    5. [sudo] Passwort für vdr:
    6. Das hat nicht funktioniert, bitte nochmal probieren.
    7. [sudo] Passwort für vdr:

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

  • liegt das Problem nicht beim mounten von /media/hd/recordings (1671)

    Hm, 1 Platte vergößert oder 2 Platten in fstab, denn diesen Fehler gibt hier mit dem MCLI nicht.

    Code
    1. # NVme /dev/sda3
    2. UUID=3458e42a-e819-4fd5-b6aa-1bc9631963d7 /media/hd auto defaults,nofail 0 2
    3. # Recordings WD1TB /dev/sda4
    4. UUID=cccf41fe-06bb-4bc6-b368-f684335ad3dd /media/hd/recordings auto defaults,nofail 0 2

    cinfo

    (VDR) NUC10i3FNK * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Player) LG UP970 * (Stream) Apple TV 4K * (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Soeben mit der nvme partition getestet:

    Code
    1. # Recordings /dev/sda3
    2. #NVme
    3. UUID=3458e42a-e819-4fd5-b6aa-1bc9631963d7 /media/hd auto defaults,nofail 0 2

    cinfo ich teste es immer auf einem verschlüsselten Kanal (ORF2HD). Auch den

    Jan 31 12:36:00 BM2LTSNuc64native-MCLI vdr[3364]: sh: 1: /media/hd/recordings: Permission denied

    bekomme ich nicht weg

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

  • es laufen auch nur mehr folgende Plugins:

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

  • Für einen reinen Aufnahmetest sollten doch mcli und softhddrm genügen, oder?

    Dabei sollte vorläufig auch nur dein NUC auf den Netceiver zugreifen, keine weiteren Clients.

    Helmut

    Hallo Helmut, danke dass du "vorbei schaust". (bei de bisherigen Tests lief immer nur der NUC, alerdings hat er nur 3 dr 6 Tuner bekommen).

    Wenn du sagst ich kann alle deaktivieren ... mach ich das ... oder meinst du beim Aufruf des vdr aus der bash ? den ich nicht alleine gebacken bekomme (s.o.)

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

  • Gestern Abend hatte ich 2 Aufnahmen parallel programmiert.

    die 1. auf ORFHD brachte es auf 82 .ts1 und die 2. auf ZDF auf eine mit 0 Bytes. Erst als ZDF geendet hatte lief der ORFHD durch. Sonst hatte er minütlich den Stream broken exit ...


  • Post by gggggg ().

    This post was deleted by the author themselves ().
  • Leider keine Änderung


    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

    The post was edited 1 time, last by gggggg ().

  • Das Log ist zumindest übersichtlicher, der Fehler aber immer gleich:

    Code
    1. Jan 31 16:15:19 BM2LTSNuc64native-MCLI vdr[1449]: Mcli::recv_ts_func: Discontinuity on receiver 0x555a4a277c20 for pid 767: 13->12 at pos 0/7
    2. ... ### 29 bis 30 Sekunden später:
    3. Jan 31 16:15:49 BM2LTSNuc64native-MCLI vdr: [1641] ERROR: video data stream broken

    Ich nehme an die Pid 767 kommt von deinem Live-Programm auf Device 1.


    Hast du noch außer der Alphacrypt noch ein anderes Modul für die ORF-Karte mit dem du einen Test durchführen kannst?

    Helmut

  • Eine easymouse hat er noch, soweit ich das verfolgt habe

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Das Log ist zumindest übersichtlicher, der Fehler aber immer gleich:

    Code
    1. Jan 31 16:15:19 BM2LTSNuc64native-MCLI vdr[1449]: Mcli::recv_ts_func: Discontinuity on receiver 0x555a4a277c20 for pid 767: 13->12 at pos 0/7
    2. ... ### 29 bis 30 Sekunden später:
    3. Jan 31 16:15:49 BM2LTSNuc64native-MCLI vdr: [1641] ERROR: video data stream broken

    Ich nehme an die Pid 767 kommt von deinem Live-Programm auf Device 1.


    Hast du noch außer der Alphacrypt noch ein anderes Modul für die ORF-Karte mit dem du einen Test durchführen kannst?

    Helmut

    Ja, 767 ist das Live Prog (SIX weil es ja das WAF gerät ist ;-) ) . Wie utility gesagt hat, hab ich eine neue USB Easymouse, von deren Nutzung ich nicht viel weis.

    Komisch ist schon, dass das Live-TV keine Probs macht oer ...

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

    The post was edited 1 time, last by gggggg ().