[easyVDR5] easyPortal: HDD-Temperatur wird nicht angezeigt

  • Hallo zusammen,


    mir ist aufgefallen, dass im easyPortal die HDD-Temperatur nicht angezeigt wird.

    Habe es selbst debugged und es scheint mit der Zeichenkodierung zusammen zu hängen.

    In der Datei /var/www/container/c_festplattenauslastung.php habe ich an der Stelle wo die Temp ausgelesen wird

    Code
    1. $Temp = shell_exec("sudo $SH_EASYPORTAL hddtemp ".substr($Daten[0],0,8));

    noch diese Zeile hinten dran gehängt:

    Code
    1. $Temp = utf8_decode($Temp);

    Dann passt die Anzeige wieder.


    Dann ist mir noch aufgefallen, dass bei den Platten auch ein tmpfs (/dev/shm) angezeigt wird.

    Das scheint mir an der Stelle eher unsinnig zu sein.

    Oben in der gleichen Datei habe ich mittels "-x tmpfs" das tmpfs ausgeschlossen.

    Code
    1. exec("df -h -x tmpfs | sort | grep /dev/[h,s,m] | awk '{ print $1 \";\" $6 \";\" $5 \";\" $3 \";\" $4 \";\" $2 }'", $HD_CHECK);


    Wenn ihr die zwei Punkte als sinnvoll betrachtet könnt ihr es ja für alle übernehmen.


    Bei den Tooltips bin ich mir auch unsicher ob die so aussehen sollen. Soll da nur die Bezeichnung der Platte angezeigt werden?

    Irgendwie bin ich der Meinung, dass bei der v3.5 mehr Infos im Tooltip standen. Habe aber grad keine v3.5 zum vergleichen greifbar...


    Gruß

    chicco

    Mein VDR:
    M3N78-EM, Athlon II X2 240e, 4x1GB RAM, GT 710, Technisat CableStar HD 2 + Mystique CaBiX-C2, Atric-Einschalter

    easyVDR 5.0

    TV: Samsung RU7099 43"

  • Hi

    Hast du auch auf der Konsole ein sudo sensors-detect mal abgearbeitet

    Gruß Helmut

    Test_VDR: Lintec Senior Gehäuse - MSI G41M P25 MS7592 Board - Intel P4 E8500 / 775 CPU - MSI GT710 PCI-e HDMI LP passiv - DVBSky S2 952 Dual SAT - 120GB W.D. Green SSD + Big HDD - 2x2GB DDR3 RAM - LG GH24NSD1 S-ATA DVD - SMK RC6 MCE 50GB FB. an STM32 USB-Stick - EasyVDR 5 pre Alpha - Softhddevice Frontend mit Pulseaudio - Kodi 19.4 m. Confluence Skin
    Clients: Hauppauge Media MVP Scart - VIP 1903Box - VIP 1910Box - EasyStream 0.6-18 fuer Windows - Raspberry PI B+ mit OpenElec 5.08 Kodi Helix 14.2 und Tsop31238 Lirc mit Conrad Promo8 FB on Code VCR 0104 - Raspi3 m.OpenElec 6.03 und Kodi 15.2 Isengard

  • Nein hatte ich nicht.


    Aber ich habe in der php Datei den debug Modus eingeschaltet.

    Damit konnte ich sehen, dass durchaus eine Temp ausgelesen wird (also wirds wohl nicht an den sensors liegen).

    Weiter unten ist dann eine Abfrage ob der Temp-String größer als 6 Zeichen ist, wenn ja wird die Variable auf einen leeren String gesetzt.

    Der String war 7 Zeichen lang. Nach utf8_decode() war er nur noch 6 Zeichen lang.

    Hatte mir den String auch in Einzelzeichen ausgeben lassen und das Problem war das Grad-Zeichen, das wurde als zwei unleserliche Einzelzeichen ausgegeben.


    Jetzt eben habe ich das Tool mal abgearbeitet, es hat mir ein "it87" in die /etc/modules eingetragen.

    Habe meine Änderung in der php Datei wieder rückgägnig gemacht, reboot, keine Temp-Anzeige.

    Wenn ich meine Änderung wieder rein nehme, sind die Temps wieder da.


    Werden denn bei euch die Temps angezeigt?

    Mein VDR:
    M3N78-EM, Athlon II X2 240e, 4x1GB RAM, GT 710, Technisat CableStar HD 2 + Mystique CaBiX-C2, Atric-Einschalter

    easyVDR 5.0

    TV: Samsung RU7099 43"

  • Im OSD werden und wurden mir in den Systeminfos übrigens auch die HDD-Temps angezeigt. Ich denke mit den Sensoren ist alles Ok.

    Das ist im easyPortal nur ein Ausgabe-Problem mit der Zeichenkodierung.

    Mein VDR:
    M3N78-EM, Athlon II X2 240e, 4x1GB RAM, GT 710, Technisat CableStar HD 2 + Mystique CaBiX-C2, Atric-Einschalter

    easyVDR 5.0

    TV: Samsung RU7099 43"

  • Hi,

    Dann passt die Anzeige wieder.

    erstelle Bitte einen patch/diff,dann patch ich das ins easyPortal


    Gruss

    Wolfgang

    TT S2-6400 - saa716x kompilieren unter 20.04(Focal)

  • Hallo Chicco,


    ich habe bei mir (frisch die 5.0 installiert) gerade mal geschaut => keine Angaben im easyPortal.


    War auch kein sensors installiert. Installiert und sensors-detect durchgeführt => sieht schon besser aus, aber nichts von der Platte. Ich kann morgen mal schauen, aber ich meine beim VDR mit 3.5 steht die Festplatte auch dabei.


    Ich denke auch /dev/shm habe ich da vorher auch noch nie gesichtet.


    Sensors ist ja dafür unrelevant :-)


    Temperatur ist theoretisch auch schon vorher verfügbar gewesen:

    Code
    1. easyvdr@easyVDRDachboden:~$ hddtemp /dev/sdb
    2. /dev/sdb: WDC WD10EURX-73FH1Y0: 36°C


    Mit deiner zusätzlichen Zeile ist es wieder im Lot => Screenshots. Danke :-)


    Gruß Ralf

  • Ich denke mal. für die Festplattentemperaturen muß auch hddtemp installiert sein?

  • Hi,


    Ich denke mal. für die Festplattentemperaturen muß auch hddtemp installiert sein?

    wird ja über Paket easyvdr-depends installiert!


    Gruss

    Wolfgang

    TT S2-6400 - saa716x kompilieren unter 20.04(Focal)

  • Hi,

    Zum einen :

    Danke für die Fehlerfindung inkl. Lösungen.

    Da sind noch mehr Fehler im easyportal. Das wurde ja nur übernommen von 3.5.

    Tmpfs: keine Ahnung, wahrscheinlich Relikt aus 1.0 oder so.

    Easyportal hatten Stevee und Sinai ja gepflegt. Leider machen beide nichts mehr aktiv.

    Sollte lmsensors inkl. Sensors-detect nicht in die easyvdr-depends bzw. In dessen Installskript?

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • erstelle Bitte einen patch/diff,dann patch ich das ins easyPortal

    Hi Wolfgang,


    das will ich gerne machen, aber das ist Neuland für mich.

    Reicht dir ein

    Code
    1. diff originalDatei geänderteDatei > datei.diff

    oder brauchst du ein bestimmtes Format, z.B.

    Code
    1. diff -uNr ...


    Gruß

    chicco

    Mein VDR:
    M3N78-EM, Athlon II X2 240e, 4x1GB RAM, GT 710, Technisat CableStar HD 2 + Mystique CaBiX-C2, Atric-Einschalter

    easyVDR 5.0

    TV: Samsung RU7099 43"

  • Hi,


    diff -uNr ...

    ist Ok ..oder diff -Naur


    Gruss

    Wolfgang

    TT S2-6400 - saa716x kompilieren unter 20.04(Focal)

  • Hi,


    patch ist im Anhang.

    Merci!

    Build im PPA läuft.Hab auch noch die Links unter easyPortal > ? > Links angepasst.


    Pic:


    [Edit On]

    Paket Published!

    [Edit Off]


    Gruss

    Wolfgang

    TT S2-6400 - saa716x kompilieren unter 20.04(Focal)

    The post was edited 1 time, last by wolfi.m ().

  • Hallo,


    update gemacht => passt.

    Danke.


    Gruß Ralf

    Wohnzimmer (easyVDR 5.0):

    Intel NUC 7PJYH / 8 GB RAM / 60 GB SSD / SMK RC6 MCE 50GB

    Dachboden (easyVDR 5.0):
    Asrock J4105 / 8 GB RAM / CINE S2 (V6.5) + DuoFlex S2 / CINE S2 (V6.5) / 60 GB (SAMSUNG SSD 830) / 8 TB (HGST HUS728T8TAL) / Futaba MDM166A / SMK RC6 MCE 50GB / Cooltek G3 / attric IR (Rev.5)

    weitere Kodi-clients (LibreELEC, CoreELEC):

    Raspi 3 (Openelec) und Odroid C4 (Coreelec)

  • Hallo chicco3 wolfi.m

    Danke für den fix

    Nach Update und Upgrade läuft es

    Sehr gut ;Thanks

    MfG Helmut

    Test_VDR: Lintec Senior Gehäuse - MSI G41M P25 MS7592 Board - Intel P4 E8500 / 775 CPU - MSI GT710 PCI-e HDMI LP passiv - DVBSky S2 952 Dual SAT - 120GB W.D. Green SSD + Big HDD - 2x2GB DDR3 RAM - LG GH24NSD1 S-ATA DVD - SMK RC6 MCE 50GB FB. an STM32 USB-Stick - EasyVDR 5 pre Alpha - Softhddevice Frontend mit Pulseaudio - Kodi 19.4 m. Confluence Skin
    Clients: Hauppauge Media MVP Scart - VIP 1903Box - VIP 1910Box - EasyStream 0.6-18 fuer Windows - Raspberry PI B+ mit OpenElec 5.08 Kodi Helix 14.2 und Tsop31238 Lirc mit Conrad Promo8 FB on Code VCR 0104 - Raspi3 m.OpenElec 6.03 und Kodi 15.2 Isengard