[yavdr-ansible-focal] Crash vom VDR mit softhddevice-cuvid

  • Habe jetzt seit längeren wiedermal den VDR im yavdr-ansible-focal aktualisiert auf den vdr-2.4.6.

    Jetzt habe ich aber das Problem bekommen, dass der VDR immer wieder neu startet, siehe Auszug aus dem syslog:

    Diese Meldung kommt dann immer wieder, nach dem der VDR neu starten will.


    Bei meiner Suche im Inet habe ich dann gefunden, dass dies irgendwie am softhddevice-cuvid-plugin liegen muss. siehe hier!

    Oder am verwendeten CUVID von NVIDIA.


    Denn wenn ich einfach in der softhddevice.conf den Aufruf -v cuvid auskommentiere, dann läuft der VDR wieder ohne Probleme.


    Zumindest bin ich also nicht der einzige, der das Problem hat.

    Vielleicht kann sich lnj der Sache mal annehmen.


    Hier noch der verwendete NVIDIA-Treiber und die CUDA-Version:


    Das vdrboblight-Plugin habe ich noch nie genutzt, war also noch nie aktiviert. Hier mal noch die aktivierten Plugins:

    Ansonsten habe ich das ganz normale yavdr-ansible-focal am laufen, nicht die gepatchte Version von seahawk1986

    The post was edited 2 times, last by Paulaner ().

  • Attached you find the syslog with used softhddevice-cuvid.

    Files

  • Hast du das Verhalten auch mit zB lcars, also einem Nicht-Skindesigner-Skin?

    Weil da auch ein Skindesigner-Fehler drin ist: "skindesigner: invalid factor {timerwidth} in expression "{timerwidth}*{areawidth}*0,9/1000""


    Und osd2web würd ich auch mal abschalten und ohne probieren.

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Weil da auch ein Skindesigner-Fehler drin ist: "skindesigner: invalid factor {timerwidth} in expression "{timerwidth}*{areawidth}*0,9/1000"

    Habe ich korrigiert und der Fehler tritt jetzt nicht mehr auf.

    Hat aber keinerlei Auswirkung auf die Crashes vom VDR. Erst wenn ich einen anderen Skin nehme sind die Crashes weg, siehe unten!



    Then which ffmpeg are you using.


    I don't know which version of ffmpeg I use, because I get nothing.

    I use the normal installation of yavdr-ansible-focal.

    Code
    1. /yavdr# ffmpeg -version
    2. Der Befehl 'ffmpeg' wurde nicht gefunden, kann aber installiert werden mit:
    3. apt install ffmpeg


    Try start softhddevice with -w disable-ogl-osd.

    With this option I get the same crashes like without.


    But if I use LCARS instead of skindesigner-plugin then the problem is gone and the VDR starts without crashes.

    At the other side: LCARS is not my preferred skin! :(

    What can we do?

  • Skindesigner have some skins, can you try change it?

    I try some skins and with all skins I tested it get the same result: vdr crash


    I have compiled the debug-version of softhddevice-cuvid from this ppa:

    https://launchpad.net/~yavdr/+…e/ubuntu/experimental-vdr


    In the Makfile I've uncomment these 2 lines (I hope this is right?):

    Code
    1. CONFIG += -DDEBUG
    2. CONFIG += -DOSD_DEBUG # enable debug output+functions
    3. #CONFIG += -DSTILL_DEBUG=2 # still picture debug verbose level


    The syslog with the vdr crashes you'll find in the attachment.

    My next tests I can do earliest tomorrow. Sorry. ;)

    Files