Live zeigt nur Startseite an und friert bei Bedienung ein

  • Ich habe jetzt Live unter Gentoo installiert. Die Startseite wird am Schleppi angezeigt mit den korrekten Daten. Aber das Statusfensteren oben ist leer und im Kopf steht "Hole Status ..."

    Im Log steht:

    Code
    1. Nov 23 16:39:12 rockpro vdr[12695]: [12695] starting plugin: live
    2. Nov 23 16:39:12 rockpro vdr[12695]: [12695] live: initial file cache has 82 entries and needs 376715 bytes of data!
    3. Nov 23 16:39:12 rockpro vdr[12695]: [12709] live: INFO: attempt to listen on ip = ''

    Jetzt klick ich irgend etwas auf der Webseite an. Im Log erscheint nix. Auf der Konsole auf der runvdr läuft:

    Code
    1. rockpro ~ # runvdr
    2. 2020-11-23 16:43:47.23011 [12695.281471839342960] FATAL tntnet.poller - internal error: job for fd 69 not found in jobs-list
    3. 2020-11-23 16:43:47.23034 [12695.281471839342960] WARN tntnet.poller - need to rebuild poll structure

    Firefox wartet endlos auf Daten. Erst nach beenden von vdr kommt "Seite nicht gefunden".

    Schließe ich jetzt vdr, starte neu und vordere im Firefox die aktuelle Seite neu laden wird die vorher angeforderte Seite korrekt angezeigt nur Status ist wieder leer. Klick ich irgenwas an => kommt die Fatal Message wieder mit anderer fd Nummer.


    Ich weiß nicht weiter und bin für jede Hilfe dankbar.

  • Das sieht schon mal besser aus. Jetzt wird eine ganze Menge angezeigt. Danke!


    Die komische Fehlermeldung kommt immer noch und Streamen geht leider noch nicht.

    Code
    1. rockpro ~ # runvdr
    2. INFO: validating live server ip '0.0.0.0'
    3. 2020-11-23 22:18:46.41166 [18581.281472158134640] FATAL tntnet.poller - internal error: job for fd 53 not found in jobs-list
    4. 2020-11-23 22:18:46.41174 [18581.281472158134640] WARN tntnet.poller - need to rebuild poll structure
    5. Unrecognized option 'preset'.
    6. Error splitting the argument list: Option not found

    Im Log find ich da was von ffmpeg:

    Mmmh!? Soll da was gewandelt werden? Kann man das 1:1 rausschicken?

  • Jetzt zeigt sich noch ein grosses Problem. Auf der Webseite laß ich mir "Jetzt" danach "Nächstes" anzeigen. Auf den Seiten wird alles richtig angezeigt. Eine halbe Stunde später kackt VDR ab und startet über runvdr neu. Im Log ist nix zu sehen. Auf der Konsole sehe ich:

    Code
    1. 2020-11-28 12:43:49.07703 [3126.281472292352368] FATAL tntnet.worker - requesttime 600 seconds in thread 281472535609712 exceeded - exit process
    2. restarting VDR
    3. Sa 28. Nov 12:43:50 CET 2020
    4. INFO: validating live server ip '0.0.0.0'

    Das ist immer so nachvollziehbar. Was da requested wird weiß ich nicht. Kann das an meinem ARM Setup liegen?