vdr-plugin-softhddevice hängt

  • .. kurzes Feedback - seit ca. einem Tag mit dem unter Focal gelieferten nvidia-Treiber kam der Fehler (vdpau aktiviert) mit den massiven alsa-Einträgen (audio/alsa: start delay 336ms) im Log nicht mehr. Nur beim Kanalwechsel, wo die Einträge dann eh vorgesehen sind. Bin mir aber nicht sicher, ob schon 'Vorfreude' aufkommen darf :schiel


    Die anderen Fehler im Log bleiben (SATIP timeout, etc) und sollte ich besser in dem von mir eröffneten Fred ansprechen.


    Grusz!

  • Hi,


    mein nvidia Treiber: 340.108

    Und nein, ich kann den nicht updaten: Die neueren unterstützen meine Graka (GeForce 9500 GT) nicht mehr :(.


    ~Markus

    Client1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 20.04, VDR 2.4x

    Client2: RPI3

    Server: RPI4, Sundtek SkyTV Dual 2x

  • Hi,


    I use 1920x1080. I don't think, that this is the issue.

    The error occurs if I detach and attach softhddevice:

    Code
    1. svdrpsend PLUG softhddevice DETA
    2. svdrpsend PLUG softhddevice ATTA -d :0.0 -a pulse

    ~Markus

    Client1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 20.04, VDR 2.4x

    Client2: RPI3

    Server: RPI4, Sundtek SkyTV Dual 2x

  • Leider, der Fehler trat heute nacht trotz original mitgelieferter nvidia-Treiber unter Focal wieder auf. vdr fiel damit wieder in einen "inkonsistenten" Zustand.


    Grusz!

  • Wollte gerade auf "vdr-plugin-softhddevice-cuvid" wechseln, plugin installiert - hatte genau die gleiche Versionsnummer wie "vdr-plugin-softhddevice":


    Code
    1. ii vdr-plugin-softhddevice-cuvid 1.0.7+git20201108-3-003e956-0yavdr1~focal amd64 Plugin for VDR. A software and GPU emulated HD device


    Auch wenn ich mit den Paramtern

    Code
    1. [softhddevice]
    2. -D
    3. -w alsa-driver-broken
    4. -w also-no-close-open
    5. -v cuvid


    starte, kommt im Log, daß vdpau aktiviert sei ... ?


    Keine Spur von "cuvid" im Log? Hmm.


    Grusz!

  • Keine Spur von "cuvid" im Log? Hmm.

    Ich habe gerade mal auf meinem Testsystem mit GT 1030 nachgesehen - zuletzt hatte ich damit am 10. Oktober entsprechende Einträge im Log - dann muss ich mal auf die Suche gehen, woran das liegen könnte - laut Buildlog wird das vdr-plugin-softhddevice-cuvid auf jeden Fall mit CUVID-Unterstützung gebaut: https://launchpadlibrarian.net…dr1~focal_BUILDING.txt.gz (-DUSE_CUVID).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Eventuell ist es der neure nvidia-450 Treiber (der kam IIRC im Oktober) - da gab es IIRC schon mal Posts dazu, dass softhdcuvid nur mit nvidia-440 richtig funktioniert.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • My experience: Softhddevice with cuvid is ok, but it doesn't work with vdpau. My last test was about 2 weaks ago with the newest Version from git. When I change to windowed mode the error or segfault is caused.

  • I only have a GT720, so no cuvid. Checking every minute with a "svdrpsend stat disk" for hangs, and a few times a day it's really hanging (and no action with remote possible as well). So I check for a running recording after svdrpsend hang ("timeout") is detected, and restart the vdr when no recording is active.

    Unfortunately, there are no relevant log entries at the time vdr "hangs".

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-460.32), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.6-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.10.7-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Just yavdr with openbox, fullscreen mode :(

    Will check if disabling ogl-osd helps, but it is just standard softhddevice.

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-460.32), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.6-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.10.7-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Uhm, disabling ogl-osd (though not even a parameter described in the config) makes some mess of my skindesigner-estuary4vdr-skin. Clearly not good for the WAF :)

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-460.32), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.6-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.10.7-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.