Aufnahmen perfekt, aber im live-TV immer mal verpixelt / mit Kästchen / Bildstörungen

  • Hi Leute,


    Ich hatte ja vor einigen Tagen meine betagte Hardware mit ubuntu 20 und yavdr ansible installiert und jetzt funktioniert alles so, wie es soll. Aber was mir auffällt, besonders nach dem Umschalten, aber manchmal auch zwischendurch, habe ich Bildstörungen - und zwar nie, wenn ich Aufnahmen ansehe, aber immer mal wieder beim live-TV-Bild


    Beim standardmäßig installierten softhddevice - welche Einstellungen könnte ich ändern, um weniger "Last" auf dem System zu erzeugen (testweise, falls es daran liegt) - und was kann ich sonst testen?

  • Treten diese Störungen auf Sendern auf, von denen Du auch einwandfreie Aufnahmen machen kannst? Oder sind es vielleicht Sender, von denen Du sonst gar nichts aufnimmst?

    Welche DVB devices hast Du? Tip: Leg mal eine Signatur an, in der Du Dein System beschreibst.

    Wie sehen die Bildstörungen aus?

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Treten diese Störungen auf Sendern auf, von denen Du auch einwandfreie Aufnahmen machen kannst?

    Ja, die Störungen treten auf allen Sendern aber eben nur im live-TV auf. Manchmal habe ich das Gefühl, nach einigen Minuten auf einem Sender gibt es sich. Ich habe 2 baugleiche externe Empfänger, Technisat Cablestar Combo HD CI (angeschlossen per USB).


    Leg mal eine Signatur an, in der Du Dein System beschreibst.

    hmm, ich hab alle Unterlagen entsorgt, aber ich versuche es mal nachher. :-) Hardware ist auch ASrock mit NVidia (mini-PC), interne SSD(Sata) mit 80 GB, externe HDD (USB) 2TB für Aufnahmen, FLIRC als Infrarotempfänger = Tastatur, Ubuntu 20.., ethernet per kabel und TV per hdmi angeschlossen inkl. ton.


    Wie sehen die Bildstörungen aus?

    Meist wandern so in der Mitte des Bildes bunte Kästchen durchs Bild und der Ton setzt kurz (einige millisekunden) aus. Manchmal senkt man auch, man sieht kurz ein Negativ vom Bild oder nur Umrisse.


    Ich meine im log steht auch was von verlorenen Paketen/Frames oder so (muss ich später mal genauer rauskopieren)

  • gibt es in der Anzeige des femon-Plugins Unterschiede in der Signalqualität zwischen beiden Tunern? Vdr greift für Aufnahmen i.d.R. auf ein anderes device zurück als für Live-TV.
    Welches Ausgabeplugin in welcher Version verwendest Du denn?

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Ich muss erst mal nachlesen, was Deine Fragen bedeuten. :-)


    Das femon-plugin muss ich wohl erst installieren / habe ich noch nie benutzt.


    Ausgabe ist softhddevice, Version muss ich später nachsehen, aber ich hoffe es ist aktuell, denn ich habe ja vor ca. 2 Wochen neu installiert.. Melde mich wieder.

  • vdr-plugin-femon zu installieren, kann nicht schaden :) - das legt sich ins "System"-Menü und zeigt bei Aufruf in Balken die Signalstärke und andere Parameter an. Mit den Pfeiltasten der FB links-rechts kann man zwischen den Tunern umschalten und den Unterschied gleich sehen.

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.5 mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-455, --no-unified-memory), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.5-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.9.9-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Ich kann diese leichten Pixel im Live-TV bestätigen.

    Dies tritt bei mir aber nur sehr selten auf.

    wonach muss ich denn im syslog suchen,habe mal folgendes ausgeführt.


    VDR :ASUS AT3IONT-I Mini-ITX/2GB Kingston ValueRAM,SSD-32GB/HD-1TB,FB-One for All 7145,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates

    Client: Raspberry Pi 3,LibreELEC 9.2.1

    The post was edited 4 times, last by pille2011 ().

  • Eine blöde Frage: wird am ASUS direkt der TV angesteckt oder läuft das über WLAN am Raspberry-Client?

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.5 mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-455, --no-unified-memory), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.5-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.9.9-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • TV steckt am Asus.

    Auf dem Clienten läuft LibreElec und kein VDR,steht so in meiner Signatur!!!

    VDR :ASUS AT3IONT-I Mini-ITX/2GB Kingston ValueRAM,SSD-32GB/HD-1TB,FB-One for All 7145,CSL 300Mbit WLan-Stick,yaVDR-ansible(focal) alle Updates

    Client: Raspberry Pi 3,LibreELEC 9.2.1

    The post was edited 1 time, last by pille2011 ().

  • welche CPU ist in dem System? Welche GPU ist verbaut? Was sagt der vdr-Prozess,d.h. welche Auslastung hat der in dem Moment , wo die Störungen auftreten?

    ------------------------------------------------------------------------------------------------------------------------------------------------

    BM2LTS im VDR-Portal   http://www.bm2lts.de   http://www.sc-schulze.de

    ------------------------------------------------------------------------------------------------------------------------------------------------

    Empfang: Octopus Net S2 max (8 Tuner) +Netceiver mit 2x DVB-s2 dual

    Kopfstation/ Wohnzimmer: Intel NUC8i3BEH2; BM2LTS v3.2.XX

    VDR: Intel NUC D54250WYKH2; BM2LTS Route 66

    weitere Client's: FireTV 4k mit Kodi u. VNSI-Plugin

    ------------------------------------------------------------------------------------------------------------------------------------------------


  • Es ist ein ASRock Board mit Nvidia 304.. Hab die Unterlagen nicht mehr.


    femon habe ich jetzt installiert und getestet: Beide Empfänger (baugleich) liefern ein gleich gutes / gleich verpixeltes Signal. CPU /Ram ist dabei unauffällig ("top"-Anzeige):


    Code
    1. PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    2. 13268 vdr 20 0 3271848 169268 75720 S 23.7 11.1 1:46.40 vdr
    3. 978 vdr 20 0 803812 13652 9832 S 4.3 0.9 29:24.76 pulseaudio
    4. 13423 root 20 0 8176 3976 3176 R 1.3 0.3 0:00.67 top


    bei "Streaminformationen" ist mir aufgefallen, dass da steht:


    Bitrate 8 MBit/s (3.1 MBit/s)


    heißt das, dass das Signal aus meiner Kabeldose einfach zu schlecht ist? Wenn der Wert in Klammern unter 3 geht, kommen die Pixel. Ist die 8 der Sollwert und das in Klammern der Ist-Wert? Bei HD-Sendern (öffentlich -rechtlichen) sind es 25MBit/s und in Klammern dann so gut die Hälfte (13-14 MBit/s) - da zuckt nichts..


    Evtl. kann mein Fernseher einfach besser damit umgehen?

  • Die entscheidenden Informationen, die Aufschluss über die Qualität des empfangenen Signals geben, sind der Störabstand CNR (in dB) und die Bitfehlerrate BER. Der Signalpegel (STR, in dBµV) ist weniger aussagekräftig, da manche Karten mit niedrigerem Signalpegel besser zurecht kommen als andere. Eine gute Orientierung bieten auch die beiden Farbbalken. Der untere ist für CNR, der obere für STR.


    In den Streaminformationen siehst Du u.a. die nominale Bitrate - das ist in der Regel ein fixer Wert, der im Header steht und nichts zu tun hat mit der tatsächlichen Bitrate (die dahinter in Klammern steht). Kleine Bitraten sorgen für verpixelte Bilder, insbesondere bei schnellen Bewegungen. Das sind aber keine Bildstörungen an sich und es sollte dabei auch weder etwas "Zucken", noch sollte es Negativbilder geben oder Tonaussetzer. Und die Pixel sollten dann auch in Aufnahmen genauso zu sehen sein. Es ist einfach eine zu geringe Qualität, die vom Sender und/oder Kabelprovider geliefert wird.


    Die von Dir beschriebenen Störungen deuten eher auf kaputte Pakete hin. Manchmal kommt das so vom Sender, aber meist ist es ein Empfangsproblem.


    Leider liefern nicht alle Karten richtige Werte für femon, und selbst wenn, ist das immer nur innerhalb der gleichen Karte vergleichbar. Deshalb ja meine Idee zu schauen, ob es zwischen den beiden Tunern beim Umschalten mit den links-rechts-Tasten auffällige Unterschiede bei den Werten gibt. Die Bitrate kannst Du aber vergessen, denn der Empfang hat darauf keinen Einfluss.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Deshalb ja meine Idee zu schauen, ob es zwischen den beiden Tunern beim Umschalten mit den links-rechts-Tasten auffällige Unterschiede bei den Werten gibt. Die Bitrate kannst Du aber vergessen, denn der Empfang hat darauf keinen Einfluss.

    Nein, keine auffälligen Unterschiede beim Umschalten, beide gleich "gut". Aber danke für die Erläuterungen.

  • Wie sieht es denn mit BER und UNC aus?

    Die Werte findest du auch im Plugin Femon.

    Argus hat diese beiden Werte hier mal gut erklärt:

    Hab immer schlechte SNR Raten. Egal bei welchem Sender. Bei allen Sat-Richtungen.

    BER sollte möglichst niedrig und UNC immer 0 sein.

    Evtl. kann mein Fernseher einfach besser damit umgehen?

    Vermutlich ja.

    Software: yaVDR0.6.1 mit VDR 2.2.0-13yavdr0~trusty, Kernel 4.4.0-193-generic, nvidia 384.130, dddvb 0.9.37.1easyVDR0
    Hardware: ASRock B75 Pro3-M, Intel G2030, RAM 4GB, SSD 64GB, HDD 4TB, Zotac GT630 ZONE Edition 1024MB GK208 (SKU:ZT-60408-20L), DD Cine C2/T2 V7
    Fernseher: SONY KDL-32D3000