[yavdr-ansible@focal vdr-patched] Problem mit Darstellung im skindesigner-Plugin

  • Ich habe jetzt ja vor ein paar Tagen mal auf meiner Testpartition erst das "normale" yavdr-focal installiert und anschließend dann das ppa von seahawk1986 mit den gepatchten VDR und Plugins eingebunden, da ich das dynamite-Plugin testen wollte. Das dynamite-Plugin hat ja auch für meine Anforderungen (Aus- und Einhängen von DVB-Devices während des laufenden VDR) gut funktioniert. siehe meinen Beitrag hier!


    Beim rumprobieren ist mir dann gestern aufgefallen, dass die Darstellung im skindesigner-Plugin irgendwie nicht optimal ist wenn ich z.B. die Systeminfo aufrufe.

    Die grafische Darstellung der CPU-Auslastung bzw. der Festplattenbelegung ist irgendwie nicht schön.


    Mit den gepatchten VDR und Plugins aus dem ppa von @seahwk sieht es dann so aus:




    Und so sieht es beim "normalen" yaVDR-focal, ohne die gepatchten Sachen:




    Fehlt da noch irgendwas bzw. muss ich jetzt irgendwo noch etwas einstellen oder ist das bei dem gepatchten VDR so?

    The post was edited 1 time, last by Paulaner ().

  • Hallo Paulaner,

    die Darstellung der Systeminfo ist eigentlich abhängig von dem gewählten Skin im Skindesigner und von der zugehörigen displaymenudefault.xml im jeweiligen skin-ordner.

    Anbei meine displaymenudefault.xml von Skin Shady_KISS. darin gibt es Einstellungen wie die Anzeige u.a. von den Systeminfos dargestellt werden.



    Übrigen gefällt mir welche Infos bei Dir angezeigt werden. Könnte ich Deine systeminfo.sh bekommen ?


    Gruß

    Charly

  • Die einzelnen Striche statt durchgehender Balken könnte auch an fehlender bzw. anderer Schriftart liegen, oder?

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Die einzelnen Striche statt durchgehender Balken könnte auch an fehlender bzw. anderer Schriftart liegen, oder?

    Ja das habe ich auch schon vermutet, aber es läuft ja einwandfrei mit dem "normalen" yavdr-focal.

    So hatte ich das ja auch zuerst installiert und dann später nur das ppa mit dem gepatchten VDR+Plugins zugefügt und ein

    apt-get update

    apt-get dist-upgrade

    gemacht. Dabei wurden dann nur die gepatchten Versionen vom VDR+Plugins installiert und mehr nicht.

    Die richtigen Schriftarten dürften ja dabei nicht entfernt worden sein. War jedenfalls nicht zu sehen.


    Einen anderen Skin werde ich noch probieren, mal sehen ob es da auch so ist.

  • Okay, ich habe einen anderen Skin "estuary4vdr" und dann auch "metrix" getestet.

    Bei beiden gibt es die gleiche Anzeige bei den Balken für die grafische Darstellung. :(

  • Das liegt mit ziemlicher Sicherheit an der Schrift, war kürzlich erst ein Thema mit focal

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Die zusätzlich benötigten Fonts für die skindesigner-skins stehen in der jeweiligen globals.xml beim Skin.


    z.B. bei estuary4vdr:

    Viele Grüße

    kamel5

    VDR 2.4.4: ASUS Prime X470-PRO, Ryzen 7 2700, 32GB, 6TB HD, GT630, Fedora 32 Kernel 5.9 X86_64, Devicebonding 2 x 1 auf 2, TT6400, DVBSky S952 V3

  • Teste doch mal den shady oder shady_kiss

    Hmmm, bietet er mir komischerweise gar nicht mehr an.

    Ich weiß genau, dass man immer über das Setup-Menü des skindesigner-Plugins alle möglichen Skins installieren konnte.

    Aaber bei meinen beiden Installationen die ich hier habe (yavdr-focal(normal) und auch yavdr-focal-gepatcht) bietet er mir das gar nicht an, denn der 2. Menüpunkt "Weiter verfügbare Skins" ist leer und nicht anwählbar.

    Konnte ich also jetzt nicht testen, glaube aber auch nicht. dass es etwas bringen würde, siehe weiter unten!


    Quote

    Das liegt mit ziemlicher Sicherheit an der Schrift, war kürzlich erst ein Thema mit focal

    Habe ich ja auch zuerst gedacht, aber es kann nicht sein, da es ja vor dem Einbinden des PPA mit dem gepatchten VDR+Plugins einwandfrei gelaufen ist.


    Nochmal zur Erinnerung, was ich gemacht habe:

    Auf der Partition /sda1 habe ich das "normale" yavdr-focal installiert. Darauf läuft auch alles einwandfrei.

    Jetzt habe ich alle Dateien (weil ich zu faul für eine 2. Installation war) auf die Testpartition /sda2 kopiert und dann noch GRUB und die /etc/fstab usw. angepasst, damit ich je nach Bedarf von beiden Partitionen booten kann.

    Jetzt habe ich also 2 identische Installationen, die auch einwandfrei funktionieren, je nach dem in welche Partition ich boote.

    Von diesem Zeitpunkt stammt das 2. Bild vom Systeminfo aus dem skindesigner-OSD, wo alles einwandfrei aussieht.


    Nun habe ich auf der Testpartition das PPA von @seahawk mit dem gepatchten VDR+Plugins zugefügt und dann ein

    apt-get update

    apt-get dist-upgrade

    ausgeführt, worauf der gepatchte VDR und auch die entsprechenden Plugins installiert wurden.


    Wenn ich nun jetzt das Systeminfo aufrufe erhalte ich das 1. Bild, mit dem "gestrichelten" Grafikbalken!

    Aaaaber zusätzlich sieht man da auch noch die Zeilenlinien auf dem 1. Bild, welche eigentlich ausgeblendet sein sollten (siehe Vergleich Bild 2).



    In der zugehörigen "displaymenudefault.xml" vom Skin gibt es dazu folgenden Code:

    Code
    1. <!-- Trennlinie zwischen den einzelnen Zeilen -->
    2. <area condition="not{current} ++not{systeminfo} ++not{setup}" x="0" y="0" width="100%" layer="2">
    3. <drawrectangle x="0" y="{areaheight}-1" width="100%" height="1" color="{clrGreyLight}" />
    4. </area>

    Um zu sehen, ob das auch noch funktioniert habe ich hier noch zusätzlich die Condition ++not{setup} eingefügt (das ist sonst nicht enthalten).

    Und das funktioniert da einwandfrei!

    Beim Aufruf des Setup-Menüs werden nun die Zeilenlinien nicht mehr angezeigt, aber beim Systeminfo-Menü funktioniert es eben nicht.


    Irgendwie erkennt der Skindesigner hier nicht, dass das systeminfo-Plugin aufgerufen wird.

    Somit ist dann vermutlich der gesamte Code für die optimale Anzeige des Systeminfo-Plugins nicht wirksam und deshalb erfolgt die merkwürdige Anzeige beim Aufruf.

    Wie ich gerade beim probieren bemerkt habe gilt das auch für z.B. das filebrowser-Plugin.



    Für mein Verständnis ist es hier irgendein Patch der da nicht ganz optimal ist und dadurch Probleme macht. X/

    Oder mal anders gefragt:

    Wer hat denn das PPA von @seahawk mit den gepatchten VDR+Plugins am laufen?

    Der könnte doch mal testen, ob er auch Probleme bei der Anzeige der grafischen Balken des systeminfo-Plgins hat!

    The post was edited 1 time, last by Paulaner ().

  • Ich hab seit ewigen Zeiten die Skins auf einer Extra Partition wie auch andere teilbare Daten und passe bei den Systemen nur die Pfade der Plugins zu den Skins an.

    Die Skins sind der letzte Stand der jeweiligen GIT Versionen und funktionieren hier als Balken wo du Striche hast.

    Das funktioniert mit @bionic, @focal und @vdr4arch hier.


    Wenn natürlich irgendwo verschiedene Skins liegen mit gleichem Namen jedoch unterschiedlichen Stand dann kann es schon knirschten bei der Ansicht.

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Das funktioniert mit @bionic, @focal und @vdr4arch hier.

    Bei mir funktioniert es ja auch mit @bionic und auch @focal! Darum geht es hier NICHT.


    Aber hier geht es ausschließlich um yavdr@focal + gepatchtenVDR+Plugins aus dem ppa:seahawk1986-hotmail/vdr-2.4.5-patches von seahawk1986  

    Vielleicht gibt es hier jemanden, der das PPA mit den gepatchten VDR+Plugins auch einsetzt und kann testen, ob es bei Ihm ähnlich ist oder auch nicht!

    The post was edited 1 time, last by Paulaner ().

  • Leider kann ich da nicht helfen, da ich das experimental PPA nutze.

    Da aber skindesigner bei dir auch keine Skins zum installieren anbietet, scheint doch das Problem am VDR aus dem PPA "VDR-245-gepached" zu liegen. Da kann bestimmt seahawk1986 was zu den Unterschieden sagen.


    P.S.

    Kannst du mir bitte mal den Inhalt deiner systeminfo.sh geben/zeigen ?

  • Beruhig dich nur, die Plugins wurden sicher nicht gepatched und sind der selbe Stand wie bei den anderen genannten....

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Da aber skindesigner bei dir auch keine Skins zum installieren anbietet, scheint doch das Problem am VDR aus dem PPA "VDR-245-gepached" zu liegen.

    Das ist so nicht ganz richtig, denn auch bei dem ungepatchten yavdr@focal habe ich keine Skins zum installieren!

    Warum weiß ich jetzt auch nicht, denn früher hatte ich da immer jede Menge Skins zum installieren in der Liste.

  • Schau doch mal in var/lib/vdr/plugins/skindesigner/installerskins/skinrepositories ob da der Inhalt fehl

    Stimmt, das Verzeichnis ist leer!

    Ich habe jetzt den Inhalt aus einem anderen VDR (yavdr@bionic) reinkopiert, aber funktioniert nicht.

    Ich sehe jetzt die Liste mit den Skins und auch die Vorschau. Aber wenn ich auf "Installiere Skin" klicke, dann kommt die Meldung "Installiere Skin ..." und die zeit läuft ab und nach 120 sekunden kommt dann ein "Timeout".

    :(


    UPDATE:

    Ich habe jetzt dasgleiche nochmal auf der Partition mit dem "normalen" yavdr@focal ausprobiert und da ließ sich der Skin Shady problemlos installieren.

    Warum das bei der anderen Testpartition mit dem gepatchten VDR+Plugins nicht klappt weiß ich einfach nicht! :(

    Jetzt kann ich erstmal nicht weiter probieren, die familie braucht den VDR! ;)

    The post was edited 1 time, last by Paulaner ().

  • Hallo,


    Ich habe jetzt den Inhalt aus einem anderen VDR (yavdr@bionic) reinkopiert, aber funktioniert nicht.

    müsste ein Symlink sein!

    ln -s /usr/share/vdr/plugins/skindesigner/dtd /var/lib/vdr/plugins/skindesigner/dtd


    Gruss

    Wolfgang

  • wolfi.m

    das ist aber jetzt wieder eine völlig ander Sache und JA diesen Link gibt es.

    Hier war der Inhalt des Verzeichnisses /var/lib/vdr/plugins/skindesigner/installerskins/skinrepositories gemeint, welcher alle zur Installatiopn verfügbaren Skins beinhaltet.

  • So, nach dem ich jetzt 2mal gebootet hatte konnte ich auf einmal auch auf meiner Testpartition mit dem gepatchten VDR+Plugins einen anderen Skin installieren. Ich habe nun testweise den Skin "Shady" installiert.


    Das Ergebnis ist gleich dem von mir verwendeten Skin: Die grafischen Elemente werden auch nur durch senkrechte Striche dargestellt.

    Liegt also m.M. nach nicht am verwendeten Skin, sondern irgendwo anders.


    Deshalb nochmals meine Bitte und Frage:

    Gibt es hier jemanden, der das PPA mit den gepatchten VDR+Plugins auch einsetzt und kann bitte testen, ob es bei Ihm ähnlich ist oder auch nicht!

    The post was edited 1 time, last by Paulaner ().

  • Sorry, sieht bei mir (estuary4vdr, vorher skinflatplus) genauso aus. Stört mich nur zuwenig :)

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.5 mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-455, --no-unified-memory), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.5-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.9.11-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.