yavdr-ansible focal fossa + USB Massenspeicher mounten + OSD Message nur 1x

  • Hi,


    Wenn ich am VDR nen USB Stick anstöpsel wird der schön gemountet und man bekommt auch ne Meldung diesbzgl. am VDR OSD zu sehen, doch wenn ich diesen Stick später umounte und egal auch wenn ich das System runterfahre und erst am nächsten Tag wieder hochfahre und den USB Stick erneut mounte klappt zwar das Mounten weiterhin aber die OSD Meldung das der USB Stick gemountet wurde kommt hier nicht wieder.


    Ich habe beobachtet das beim Mounten immer ein Link erstellt wird in diesem Fall mit Namen USB DISK, dieser Link

    liegt dann unter /srv/vdr/video und verweist auf /media/vdr/USB DISK, das ist auch alles super gelöst, aber wenn man

    den USB Stick umountet bleibt der tote Link zurück, und irgendwie sieht es danach aus das deshalb beim späteren

    erneuten Mounten des selben USB Sticks keine OSD Meldung mehr aufscheint die besagt das der USB Stick gemountet wurde.


    Ich habe den toten Link schon einige Male manuell gelöscht, und wenn ich den selben USB Stick danach mounte kommt die OSD Meldung wieder.


    Ich bin jetzt nicht sicher ob das bei allen USB Medien so ist

    (hab auch schon einige Male andere USB Medien gemountet, da ist mir das aber nicht so aufgefallen)

    , aber nichts desto trotz warum wird der tote Link beim Umounten nicht gelöscht ?


    Vielleicht ist das auch nur bei mir hier so denn der VDR Video Dir ist hier ein Link also /srv/vdr/video verweist auf /media/linuxdata/media/video.00

    was ne Partition auf ner anderen Festplatte ist.



    Gruss

    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • , aber nichts desto trotz warum wird der tote Link beim Umounten nicht gelöscht ?

    Was steht denn im Log, wenn du den Stick auswerfen lässt?


    Vielleicht ist das auch nur bei mir hier so denn der VDR Video Dir ist hier ein Link also /srv/vdr/video verweist auf /media/linuxdata/media/video.00

    was ne Partition auf ner anderen Festplatte ist.

    Das würde ich lieber per bind-mount lösen (vgl. z.B. https://wiki.ubuntuusers.de/fs…inzelne-Ordner-einhaengen) lösen, da es einige Skripte gibt, die davon ausgehen, dass entweder /srv/vdr/video oder /srv/vdr/video.00 existieren und der eine ein Symlink auf den anderen ist.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,


    Ich häng ein gekürztes Log unten an (zuviele Zeichen für den Post selbst).


    Was steht denn im Log, wenn du den Stick auswerfen lässt?


    Das würde ich lieber per bind-mount lösen (vgl. z.B. https://wiki.ubuntuusers.de/fs…inzelne-Ordner-einhaengen) lösen, da es einige Skripte gibt, die davon ausgehen, dass entweder /srv/vdr/video oder /srv/vdr/video.00 existieren und der eine ein Symlink auf den anderen ist.

    Danke. das werd ich dann so machen.



    Gruss

    Bert

    Files

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Hmm, nix auffälliges zu sehen Im Log oder ?

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Man sieht nur, dass der find-Befehl nichts findet, was er löschen kann...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Hi,


    Ja leider, da muss ich mir wohl irgendnen Workaround überlegen (Script und cron vielleicht), mal gucken vielleicht fällt mir was ein,

    denn die toten Links sind ja da (ist mit anderen USB Datenträgern hier auch so).



    Gruss

    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Nicht zu glauben, jetzt wollte ich mir das mal genauer ansehen, und konnte es zuletzt nicht reproduzieren, na ja wird schon wieder mal auftauchen.

    Dachte ich probier mal statt find in /var/lib/vdr/bin/udiskie_vdr_mount_helper das Programm symlinks.



    Gruss

    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau