[Gelöst] yaVDR-Ansible Microruckler

  • Hallo,


    ich habe heute meine Grafikkarte (ASUS NVidia GT610) gegen eine Inno3D NVidia GT1030 getauscht.

    Leider gibt es seitdem Microruckler:

    Da ich lange keine Updates mehr gemacht habe, habe ich erstmal mit apt-get install nvidia-driver-390 den bisdato installierten Treiber aktualisiert.

    Leider ohne Erfolg. Also habe ich weiter aktualisiert: apt-get install nvidia-driver-440 (hat anscheinden auch gleich den 450er installiert).

    Auch das brachte keine Verbesserung.

    Ton läuft bei mir ohne PulseAudio mit Alsa ohne Aussetzer.


    Hier Infos zum aktuellen Stand

    Jemand noch eine Idee?


    Frank

  • Welchen Ausgabemodus hat der X-Server gewählt? xrandr -d :0 --query

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Da kommt das gleiche wie oben bei DISPLAY=:0 xrandr raus:

    Code
    1. root@YAVDR:~# xrandr -d :0 --query
    2. Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
    3. DVI-D-0 disconnected (normal left inverted right x axis y axis)
    4. HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1600mm x 900mm
    5. 1920x1080 60.00 + 59.94 59.93 50.00* 29.97 25.00 23.98 60.05 60.00 50.04

    1920x1080@50Hz

  • Welches Ausgabeplugin nutzt du denn?
    Ist dieses für die nvidia 1030 geeignet, also nützt die HW-Möglichkeiten deiner Karte?

    MyVDR: yaVDR-Ansible (Ubuntu 18) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Das Ausgabedevice hatte ich auch oben geschrieben:

    Code
    1. root@YAVDR:~# apt-cache policy vdr-plugin-softhddevice
    2. vdr-plugin-softhddevice:
    3. Installiert: (keine)
    4. Installationskandidat: 1:1.0.3+git20200828-2-c8a126b-0yavdr0~bionic
    5. Versionstabelle:
    6. 1:1.0.3+git20200828-2-c8a126b-0yavdr0~bionic 500
    7. 500 http://ppa.launchpad.net/yavdr/experimental-vdr/ubuntu bionic/main amd64 Packages
    8. 0.6.0+git20160108-2build1 500
    9. 500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

  • vdr-plugin-softhddevice:
    Installiert: (keine)

    Hmm, welches Ausgabeplugin dann?

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, ubuntu-focal, softhddevice-cuvid
    ddbridge-6.5 mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-450.80, --no-unified-memory), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.3-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.9.1-lowlatency

    vdradmin-am, live+webstreaming, vdrmanager (Smartphone als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Eventuell eine der anderen Varianten davon, da gab es ja ziemlichen Wildwuchs unter 18.04 (https://www.yavdr.org/document…n.html#vdr-output-plugins)

    dpkg -l | grep "^ii" | grep softhd


    Kannst du mal deine softhddevice Settings zeigen?

    grep ^softhd /var/lib/vdr/setup.conf

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Uuups, glatt vergessen, dass ich eine Variante benutze und das "(keine)" übersehen. :wand

    Hier das richtige:

    Code
    1. root@YAVDR:~# apt-cache policy vdr-plugin-softhddevice-openglosd
    2. vdr-plugin-softhddevice-openglosd:
    3. Installiert: 1:0.6.1rc1-26-569fde5-3yavdr10~bionic
    4. Installationskandidat: 1:0.6.1rc1-26-569fde5-3yavdr10~bionic
    5. Versionstabelle:
    6. *** 1:0.6.1rc1-26-569fde5-3yavdr10~bionic 500
    7. 500 http://ppa.launchpad.net/yavdr/experimental-vdr/ubuntu bionic/main amd64 Packages
    8. 100 /var/lib/dpkg/status

    Hatte gerade letztens deine Doku zu den Plugins durchgeschaut, weil mein Plan ist, auf Focal aufzurüsten. Ich wollte aber erstmal das bestehende System lauffähig haben.

    Welches Pulgin macht denn am meisten Sinn?
    Mir scheint bei Bionic passt vdr-plugin-softhddevice aus ppa:seahawk1986-hotmail/vdr-2.4.1 (passt aber nicht zu meinem aktuell installierten VDR) und vdr-plugin-softhdcuvid.
    Ab Focal dann vdr-plugin-softhddevice-cuvid oder vdr-plugin-softhdcuvid.

    Was meint ihr?

    FFMPEG ist zur Zeit 4.2.1-2~18.04.york2ubuntu2 installiert.



    Hier die aktuellen Settings:

  • vdr-plugin-softhddevice-openglosd

    Das ist der alte softhddevice-Fork von louis mit ein paar Patches für neuere ffmpeg-Versionen - da würde ich mal schauen, ob es mit der aktuellen Version des vdr-plugin-softhddevice (also der Fork von lnj, der mittlerweile auch ein hardwarebeschleunigtes OSD bietet) nicht besser klappt.

    Welches Pulgin macht denn am meisten Sinn?

    Ich würde es als erstes mit dem Fork von lnj probieren - bei einer GT1030 mit dem vdr-plugin-softhddevice-cuvid und dem Startargument -v cuvid, damit man CUVID statt VDPAU nutzen kann. Ansonsten ist softhdcuvid einen Versuch wert, aber gerade im Zusammenspiel mit dem skindesigner erschien mir das etwas wackeliger.

    FFMPEG ist zur Zeit 4.2.1-2~18.04.york2ubuntu2 installiert.

    Das ffmpeg-Binary ist egal, wichtig sind die libav-Bibliotheken und die Abhängigkeiten müsste die Paketverwaltung für das jeweilige Paket automatisch auflösen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ok scheint gelöst.

    Vor allem der Schubser, dass gar kein Standard vdr-plugin-softhddevice installiert ist, hat mich wieder in die Spur gebracht.

    Nach einem apt-get install vdr-plugin-softhddevice war Ruhe im Log. Dafür gab es audio/alsa: broken driver Meldungen.

    Die waren dann mit dem Parameter -w alsa-driver-broken auch weg.


    Vielen Dank an die fleißigen Helfer und Tippgeber :vdr1

    Frank