Camcorder mit dvgrab auslesen - 2020 - Das Jahr in dem ich mit Firewire anfange.....

  • moin!


    Vielleicht hat hier ja jemand eine Idee, wie ich dieses archäologische Problem angehe.


    Ich habe neulich von der von der Verwandtschaft einen alten Sony Digital 8 Camcorder bekommen. Auf den beliegenden Bändern befindet sich Material das ich gern gesichert hätte. (Kompromat das wir gegen $KIND verwenden könnten - :))


    Beteiligte Komponenten:

    • Lenovo Thinkpad T410 mit Debian 10.5 (aber jede Software seit 2010 wäre ok)
    • Sony Digital Handycam DCR-TRV310E PAL (Handbuch von 1999)
    • passendes Firewire-Kabel mit kleinen Steckern von Amazon
    • 27 Jahre Erfahrung mit Linux
    • 1 Tag Erfahrung mit Firewire

    Auf der Linux-Seite habe ich die entsprechenden Treiber aktiviert bekommen und auch der Camcorder für sich funktioniert einwandfrei.


    Offenbar erkennt das Linux die Kamera am Bus nicht. dvgrab meldet entsprechend das es keine Kamera findet.


    Googeln ergibt ähnliche, unkonkrete, sehr alte Postings die leider keinen großen Erkenntnisgewinn brachten. Es scheint eine generelle Degeneration des alten Subsystems und auch versionsabhängige Inkompatiblitäten zu geben. Ich habe definitiv zu wenig Informationen.



    Weiss jemand wie es um dieses Software-Biotop steht?


    Erinnert sich jemand eine funktionierende Konfiguration aus den letzten 10 Jahren?


    Wie fange ich am besten an?


    cu, Stefan

  • Unter Windows gehts mit dvapp.exe, heraus bekommst du dann .avi, welches sich mit de n üblichen Verdächtigen anschauen lässt.

  • Auf der Linux-Seite habe ich die entsprechenden Treiber aktiviert bekommen

    Welche Module hast du da genau geladen? Wie sehen die Rechte für die Firewire-Devices (/dev/fw0 usw.) aus?

    Erinnert sich jemand eine funktionierende Konfiguration aus den letzten 10 Jahren?

    Ich würde mal einen Versuch mit kino (https://forums.linuxmint.com/viewtopic.php?t=312226) oder VLC (https://bugs.launchpad.net/ubu…ino/+bug/6290/comments/89) starten.


    Ansonsten ein Windows mit WinDV

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Laut https://help.ubuntu.com/community/FireWire/DigitalVideo kann man einem Symlink anlegen, damit die weitgehend kompatiblen neuen Kernel-Schnittstellen von dvgrab und kino gefunden werden: https://help.ubuntu.com/community/FireWire/DigitalVideo

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Offenbar erkennt das Linux die Kamera am Bus nicht. dvgrab meldet entsprechend das es keine Kamera findet.

    Ich habe das schon länger nicht mehr probiert, aber mit dvgrab sollte es funktionieren. (Falls Berechtigungen fehlen, als root probieren).

    Aber mit meiner Sony TRV900 hatte ich immer enorme Probleme, oft funktionierte es erst nach mehrmaligem Einstecken des Firewire-Kabels, im Zweifelsfall mal ein anderes Kabel probieren, oder, wenn zur Hand, eine andere Kamera. Ich hatte eine Canon (Modell vergessen), mit welcher es immer auf Anhieb ging.

    Leider nur bis zu dem Tag, an welchem ich ein VHS Video mit Hilfe der Kamera digitalisieren wollte. Beim Einstecken des Firewire Kabels gab es einen winzigen Funken (Kamera war zu dem Zeitpunkt mit dem VHS verbunden) - danach war der Firewire-Anschluss der Kamera kaputt.

    Also immer vorsichtig sein beim Anschliessen!

    Viel Erfolg!

  • Vielen Dank für eure Reaktionen!


    Ich habe es noch einmal versucht und hier sind die Details :


    Die Schnittstelle ist im Bios aktiviert und wird vom System erkannt:

    Von den vorhandenen Kernel-Modulen

    sind die relevanten offenbar geladen:

    Code
    1. root@mine:~# lsmod | egrep -i 'firewire|1394'
    2. firewire_ohci 45056 0
    3. firewire_core 81920 1 firewire_ohci
    4. crc_itu_t 16384 1 firewire_core

    Es gibt keinerlei Meldungen, das die Kamera beim Anstecken oder Einschalten auf dem Bus auftaucht.


    Und der Meinung ist auch dvgrab :

    Code
    1. root@mine:~# dvgrab -debug=all
    2. Error: no camera exists


    Normalerweise würde ich jetzt anfangen die einzelnen Komponenten durch zu tauschen, aber ich habe in diesem Fall leider nichts zum Tauschen. Ich werde es aber noch mal mit historischer Software auf dem Laptop versuchen


    Windows habe ich nicht. Aktuelles WIndows mit Firewire gibt es bestimmt auch nicht mehr.


    Ich sehe heute noch ein paar Leute - vielleicht fällt denen etwas ein.



    Plan B


    Alternativ habe ich hier noch eine Hauppauge PVR250, mit der ich die Videos analog auslesen könnte. Das hat in der Vergangenheit schon mal gut funktioniert.


    Aber auch dafür muss ich dann erst mal einen Rechner mit einem PCI-Board zusammenbasteln. Ein Versuch mit Ubuntu vor wenigen Jahren mit einer PVR350 scheiterte an fehlender Software zum Umschalten der Eingänge.


    Fortsetzung folgt....

  • Erstell doch mal den Symlink, damit dvgrab unter dem erwarteten Pfad etwas finden kann:

    sudo ln /dev/fw0 /dev/raw1394

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Die Karten haben nach meiner Erinnerung mehrere inputs, die man mit v4l2-ctl auflisten und schalten kann.


    Bei einer PVR250 müsste v4l2-ctl --set-input=2 auf den Composite-Eingang umschalten.


    Dann einfach mit cat /dev/video0 > test.mpg eine Probeaufnahme machen und prüfen.


    v4l2-ctl ist bei Ubuntu in dem Paket v4l-utils enthalten.


    Hier hat sich auch schon einer die Zähne an dem gleichen Firewire-Controller ausgebissen:

    https://forums.linuxmint.com/viewtopic.php?t=92117


    Ob noch notwendige Module geblacklisted sind sowie die Zugehörigkeit des Users zur Disk-Group (evtl. auch weiteren?) kannst Du ja noch mal checken.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EACS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Celeron G540, passive GT1030, Cine CT V6, KNC-One DVB-C, Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Mein zuverlässiges Arbeitspferd.

  • Hi,

    Nimm doch einfach Windows in der Probierversion... (30 d unregistriert)

    Nur als Anregung zum Zeit sparen...

    Oder kauf eine XP Lizenz für fast geschenkt...

    Offline ist das ein wunderbares System!

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • passendes Firewire-Kabel mit kleinen Steckern von Amazon

    Darf ich mal fragen was genau du verwendest?

    SAT Hardware: Gibertini SE75 | DuraSat Dur-Line UK-24 | DD OctopusNET V2 Rack (Firmware 1.0.81) mit MaxS8
    Server: Asus M5A78L-M/USB3 | Sempron 145@2Cores | 8GB ECC RAM | PicoPSU | Debian Stretch 64Bit | VDR 2.4.0 mit SAT>IP, epgsearch, epg2vdr, vdr-epg-daemon
    Clients: RaspberryPI 2/3 | Yocto Poky Linux (Openembedded) 2.5+git | Linux Kernel 4.14+git | VDR 2.4.0 mit SAT>IP, RpiHDDevice, SkinDesigner, Remote, Graphlcd-ax206dpf, Extrecmenu, Femon, Mlist


    R.I.P: Gigaset M740 mit VDR von open7x0.org