sporadisch kurz Artefakte beim Umschalten

  • Dieses Problem verfolgt mich schon seit Jahren. Ich bin mir nicht ganz sicher, ob es auch früher beim xine-Plugin schon da war, mit softhddevice ist dies zumindest ein Problem der ersten Stunde. Wobei ich auch gar nicht mal sicher bin, ob es am Ausgabeplugin liegt oder an ffmpeg oder an... (nvidia-Treiber? VDPAU?)


    Beim Kanalwechsel gibt es nicht immer, aber immer mal wieder kurz Artefakte. Manchmal kann ich hundert mal umschalten und es ist sauber, dann tritt es plötzlich wieder bei 3 von 5 Kanalwechseln auf.

    'Früher' sahen diese Störungen verpixelt aus, seit einiger Zeit (neuere ffmpeg-Versionen?) sieht es eher aus wie senkrechte Linien. Ich baue darauf dass diejenigen, die das Problem auch haben, wissen wovon ich spreche. Ich glaube, es tritt auch nur bei HD-Sendern (h264) auf. Hardware ist eine Nvida GT1030. Bei Intel (VAAPI) ist es mir nicht aufgefallen, aber weil das bei mir so instabil läuft, habe ich da keine großen Langzeiterfahrungen.


    Was mir nun auffiel: Auf den iptv-Sendern der Telekom (iptv-Plugin) tritt das Problem nicht auf, allerdings ist das Umschalten dort ohnehin etwas langsamer.


    Hat jemand eine Idee, wo hier genau das Problem zu suchen ist?


    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Hi,

    Tja Softhddevice ist nicht Softhddevice... Nimmst du die Version von lnj? Mit Schwarzbild beim Wechsel? Gibts in Optionen.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • ja, Version von lnj. Werde jetzt mal black picture deaktivieren und schauen, ob es dann auch auftritt.

    Hier ein Video - die ersten Kanalwechsel sind noch sauber - bei etwas 12s tritt eine Störung auf:

    [Blocked Image: https://s12.directupload.net/images/201002/d8y8i64a.jpg]

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • it also happens on unencrypted channels. BlackPicture and ClearOnSwitch have no influence.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Sieht mir mehr nach einem Tuning Problem aus, dass der Tuner etwas Zeit für den lock braucht.


    vdr-User-# 755 to_h264 chk_r vdr-transcode

  • aber sollte vdr nicht in dafür sorgen, dass nur ganze Pakete beginnend mit einem key frame an das Ausgabedevice übergeben werden? Also ohne Reste von Störungen, die beim Tunen wohl zwangsläufig auftreten?

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • I replaced the Cine CT V6 with an Hauppauge WinTV dualHD stick and there are no longer artefacts when switching channels. Channel switching is still fast.

    I don't believe in a hardware issue - maybe it is a problem of the ddbrige driver? But the driver is no longer maintained...

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!