yavdr-ansible focal auf NUC10i3 etc.

  • Es dauert dann bei mir fast 2 Minuten

    Hi rkp,

    ist bei mit neuerdings auch so. War vor dem letzten update aber meiner Meinung nach besser.

    Manchmal muß ich hier auch per "sudo shutdown now" das runterfahren manuell setzen, weil die FB nicht mehr ging (CEC)...

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.5 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible auf Intel NUC 10i3FNH

  • Komische Sache. Hab gestern mal neu installiert, und da fluppte es immer sofort. Tja, und heute hängt es wieder. Im Log ist ja nun überhaupt nichts zu sehen. Allerdings kommen ganz kurz vor dem Abschalten nur für 1-2 Sekunden noch einige Fehlermeldungen, die ich so schnell nicht lesen kann. Ich versuche mal, ein Foto davon zu machen.




    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA



  • Das vdr-plugin-cecremote und der libcec-daemon dürften sich gegenseitig behindern, wenn die gleichzeitig laufen, weil sich der erste laufende Prozess das Gerät schnappt.


    Laut README.md kann man dem libcec-daemon das Gerät explizit als Startargument mitgeben, falls die automatische Erkennung nicht klappt: https://github.com/bramp/libcec-daemon#usage - wenn du die libcec-daemon.service (die kannst du dir mittels systemctl cat libcec-daemon.service anzeigen lassen) anpasst (bzw. einen Override erstellst systemctl edit --full libcec-daemon.service), kannst du die Startargumente beeinflussen.

    Möchte den pulse-eight cec Adapter nur mit libcec-daemon verwenden.


    Der Hinweis oben wurde übergangen und nur vom vdr-plugin-cecremote geschrieben.


    Als erstes habe ich persystemctl edit --full libcec-daemon.service die Startargumente gesetzt:

    Code
    1. [Unit]
    2. Description=translate cec events to uinput key presses
    3. [Service]
    4. Environment=DISPLAY=:0
    5. ExecStart=/usr/bin/libcec-daemon -p tv.1
    6. [Install]
    7. WantedBy=multi-user.target

    Default ist -a (donotactivate) - dann Neustart.

    Kein Erfolg.


    Scan per cec-client (cec-utils):

    im syslog:

    Code
    1. Dec 28 18:47:40 vdr1 kernel: [ 4.261167] usbhid: USB HID core driver
    2. Dec 28 18:47:40 vdr1 kernel: [ 4.262350] input: Pulse-Eight CEC Adapter as /devices/pci0000:00/0000:00:14.0/usb1/1-6/1-6:1.2/0003:2548:1002.0001/input/inp
    3. ut4
    4. Dec 28 18:47:40 vdr1 kernel: [ 4.262405] hid-generic 0003:2548:1002.0001: input,hidraw0: USB HID v1.10 Mouse [Pulse-Eight CEC Adapter] on usb-0000:00:14.0
    5. -6/input2

    trotz systemctl stop libcec-daemon.servicekommt:

    Code
    1. root@vdr1:/home/rossi# libcec-daemon --list
    2. INFO - Opened /dev/uinput
    3. INFO - Created uinput device
    4. [0] port:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-6 path:/sys/devices/pci0000 :00/0000:00:14.0/usb1/1-6
    5. Failed to open

    manuell gestartet:

    Code
    1. root@vdr1:/home/rossi/yavdr-ansible# libcec-daemon -p tv.1 --usb /sys/devices/pci0000:00/0000:00:14.0/usb1/1-6
    2. INFO - Opened /dev/uinput
    3. INFO - Created uinput device
    4. INFO - Physical Address is set to 0.0.0.0
    5. INFO - Base device is set to 0
    6. INFO - HDMI port is set to 1
    7. INFO - Looking for /sys/devices/pci0000:00/0000:00:14.0/usb1/1-6
    8. INFO - Opening /sys/devices/pci0000:00/0000:00:14.0/usb1/1-6
    9. Failed to open adapter

    Vdr mit der Philips Fernbedienung bedienen funktioniert nicht. Nur Einschalten vom NUC funktioniert.

    CEC im NUC Bios ist komplett aus.


    Kann ich Tastendrücke von der TV Fernbedienung diagnostizieren?


    Was muss noch definiert werden?

    The post was edited 1 time, last by vdr_rossi ().

  • Möchte den pulse-eight cec Adapter nur mit libcec-daemon verwenden.

    Hast du das vdr-plugin-cec und ggf. andere Programme, die auf die CEC-Schnittstelle zugreifen deaktiviert?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • 'PluginLoader' object has no attribute 'get_with_context'


    Hallo zusammen,

    ich wollt mal wieder ein update machen (=Playbook laufen lassen) und bin auf diesen Fehler gestoßen:

    Code
    1. ERROR! Unexpected Exception, this is probably a bug: 'PluginLoader' object has no attribute 'get_with_context'

    Habe ich eine Umstellung verpaßt, oder wo kann ich bei der Fehlersuche ansetzen?


    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.5 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible auf Intel NUC 10i3FNH

  • Es gibt ein Problem mit dem aktuellen Stand von Mitogen - ich habe das daher im Git erst mal deaktiviert: https://github.com/yavdr/yavdr…7890030e542ab5116a7db6174

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • danke für die Info.

    Heißt das erst mal Füße still halten, bis Du grünes Licht gibst? (Ist kein Problem, da mein YaVDR ja läuft...)


    Gruß K.

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.5 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible auf Intel NUC 10i3FNH

  • Es sollte genügen sich den aktuellen Git-Stand mit einem git pull zu holen (oder die Zeilen für Mitogen von Hand auszukommentieren) - danach sollte das Playbook wieder durchlaufen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Stimmt, damit läuft das Playbook jetzt durch :thumbup:

    Gruß K.

    Und bist Du nicht willig, so brauch ich Geduld!
    System: MLD 5.5 on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible auf Intel NUC 10i3FNH

  • Hast du das vdr-plugin-cec und ggf. andere Programme, die auf die CEC-Schnittstelle zugreifen deaktiviert?

    Nein, habe im Playbook geschaut - da ist nix mit cec. Meine Startargs:

    Wie finde ich das raus, wer oder was eventl. auf die cec Schnittstelle zugreift?

  • CEC auf dem NUC geht mW immer nur eingeschränkt, wenn man nicht einen CEC-Adapter nachrüstet. In meinem NUC7 läuft der interne Adapter von Pulse-Eight absolut streßfrei und tut alles, was man erwartet (nachdem ich rausgefunden habe, daß er wohl hart mit dem Port HDMI2 verdrahtet ist ;-) )

    Der NUC7 hat 2x HDMI? Funktioniert also nur an dem einen HDMI...


    Laut cec-info ist das falsche source active:

    obwohl ich 0.0.0.0 als Startport übergebe...


    Wie setze ich device #0 aktiv?

  • So bin ich ans Ziel gekommen:

    Code
    1. sudo apt-get remove libcec-daemon
    2. sudo apt-get install vdr-plugin-cecremote

    jetzt funktioniert die TV Fernbedienung für den VDR.


    Feinschliff mit Tasten anpassen läuft...

  • Ich möchte auf dem NUC8i3 (am NUC10 läuft BM2LTS) yavdr testen. Könnt ihr mir als Linux DAU bitte sagen welchem Kochrezept ich folgen soll ?


    z.B.: https://www.yavdr.org/document…aVDR07_documentation.html


    Bitte habt im Auge, dass ich das mcli Plugin zu meinem Reel Netceiver dabei ans Laufen bekommen muss (weil in dem mein ORF-Karte steckt) und von diesem auch meine Reel AVG1 versogt wird.

    (Das Ding muss aus dem Ruhezustand/OFF per FBD und Timer starten und sich nach der Aufnahme wieder schlafen legen und da es für meine bessere Hälfte ist, soll es keine Baustelle werden ;-) )


    Und nun meine finale Bitte:

    Würde mich einer von euch dabei unterstützen. Ich habe für den Test dieses WE reserviert.


    Danke und LG Richard


    PS: Alternativ habe ich einen

    HP EliteDesk 800G2 SFF i3-6100 mit einer Nvidia GT720,

    Auf diesem habe ich EasyVDR getestet, aber meine RC6 Empfänger (die unter Kodi15 auf der AVG laufen) wurden nicht erkannt und mit mcli lief es auch nicht rund.

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

    The post was edited 1 time, last by gggggg ().

  • Hi,

    Dir ist schon klar, dass das Cardsharing bei ORF dein Hauptproblem ist? Das ist nicht vorgesehen und wohl eher Zufall dass es mal lief (wenn es so war). Man soll generell 1 Karte je Client-Tuner nutzen. Das machen andere auch und das funktioniert.

    Und bei ORF ist das so weit ich weiß sogar möglich ohne extreme Mehrkosten...

    Und btw: Kläre doch erst mal eine Baustelle und mach nicht hundert auf, wenn du schon keine Standardhardware nutz(en willst). Fb ist doch totale Nebensache, wenn kein Empfang bzw. Bild da ist. Nimm halt erst mal Keyboard.

    Wir machen das alle als Hobby, da helfen drängelnde Posts in 3 Forenteilen gleichzeitig auch nicht weiter mit denselben Fragen.

    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

    The post was edited 1 time, last by SurfaceCleanerZ ().

  • OT-on

    Ja ich mach das auch in meiner Freizeit, weil es spannend ist und ich 2015 schon mal mit viel Unterstützung der BM2LTS Community den VDR auf der AVG zum Laufen gebracht hatte . 1 Monat (seit 13.12.) try & error ist f. mich nicht Drängeln sondern Enthusiasmus u. Vertrauen in die Community.


    Wir betreiben weder Cardsharing mit Fokus auf Gebühren noch ist dies rechtlich relevant.... (Ja als Ö-Haushalt könnten wir auch 10 Karten haben).

    Wir nutzen seit 2009 den Netceiver mit Alphacrypt und EINER ORF-Karte - eine tolle Lösung und damals jedenfalls der Zeit voraus !

    Mit dem mcli läuft es bisher (auch bei BM2LTS) problemlos. Ich habe mittlerweile auch eine Easymouse2 bei mir liegen ... nur das wäre meine Notlösung weil wieder Gefrickel...


    Wir benötigen (da der Netclient2 im Sterben liegt) jetzt eine Lösung die grundlegend funkt und kein (bei meinem Halbwissen) wochenlanges Gebastel ... das ist dann für die Feinheiten OK.

    Daher auch der NUC - obwohl das Bild deutlich schlechter als die GT720 ist. Und dieser Grafik-Test, das hatte ich dir auch gesagt, war der Grund für das kurze EasyVDR Intermezzo auf dem HP-PC (insgeheim hatte ich nat. die Hoffnung keine 200€ für ein schlechteres BIld beim NUC ausgeben zu müssen ;-) ).

    OT-off

    Liebe Grüße g ;-)

    BM2LTS V2.94.4, ext.NCV+AlphacryptCAM+ORFkarte, AVG1 T7400 RAM4GB SSD+HDD2TB NvidiaGT720, NCL2 mit HDD

    The post was edited 6 times, last by gggggg ().

  • Hier mal die grundsätzliche Vorgehensweise, einen NUC mit yavdr-focal zum Laufen zu bekommen. Steht im Prinzip bereits alles in der Anleitung von seahawk:


    1. Das Installations-ISO für den Ubuntu SERVER 20.04 kann von der offiziellen Ubuntu-Webseite heruntergeladen werden: https://releases.ubuntu.com/20.04/


    2. Win32DiskImager unter Windows herunterladen und damit das Ubuntu-Image auf einen USB-Stick kopieren. Oder einen anderen Weg verwenden.


    3.Die Ansible-Playbook-Sammlung für yaVDR kann so heruntergeladen werden:

    (Am besten sich per Putty auf dem Ubuntuserver anmelden)


    $ sudo apt install git

    $ git clone https://github.com/yavdr/yavdr-ansible

    $ cd yavdr-ansible


    4. Nicht benötigte Rollen können im Playbook (yavdr07.yml bzw. yavdr07-headless.yml) auskommentiert werden und Rollen,

    die keine automatische Hardwareerkennung nutzen (wie z.B. serial-ir und epgd) können bei Bedarf aktiviert werden.


    Um in group_vars/all definierte Variablen anzupassen, sollte man (muss man aber nicht) eine Datei host_vars/localhost anlegen

    und darin die gewünschten Anpassungen vornehmen. Die in dieser Datei definierten Variablen übersteuern

    die Vorgabewerte aus dem Playbook und der group_vars/all.


    In der group-vars/all softhdvaapi einstellen, alles andere läuft bei mir (NUC10) nicht:


    # choose the vdr output plugin (defaults to vdr-plugin-softhddevice resp. vdr-plugin-rpihddevice)

    vdr_output_plugin: vdr-plugin-softhdvaapi


    5.Wenn alles eingestellt ist, mit


    sudo -H ./install-yavdr.sh


    die Installation starten.


    Wenn durchgelaufen, die Inteltreiber installieren:

    sudo apt install intel-media-va-driver-non-free

    (bin nicht sicher, ob das nicht schon automatisch erfolgt)


    In der

    /etc/X11/xorg.conf.d/20-intel.conf

    noch

    "DRI" "3"

    eintragen.


    Bei mir ist das nur notwendig bei UHD-Ausgabe.


    Eventuell muss du auch noch die

    /etc/vdr/diseqc.conf anpassen.


    6. Kanalliste


    systemctl stop vdr


    Dann eine vorhandene channels.conf nach /var/lib/vdr kopieren

    oder diese erst erstellen mit

    sudo w_scan -c de -f c > channels.conf

    und dann nach /var/lib/vdr kopieren.


    7. Booten

    sudo reboot


    Dann sollte der VDR erstmal laufen und zumindest mit der Tastatur bedienbar sein. Erst dann weitere Anpassungen vornehmen.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

  • Daher auch der NUC - obwohl das Bild deutlich schlechter als die GT720 ist

    Dann machst Du was falsch. Mit softhdvaapi und den richtigen scalern habe ich keinen Unterschied zu meinem alten VDR mit GT630.

  • DANKE für den Input, bin am Laden und installieren.

    1 Bei der Server Install habe ich mich bei folgenden Punkte gefragt:
    - das VLAN eno1.2 das ich für mcli dann brauche konnte ich hier noch nicht anlegen (da hat es nur die Auswahl VLAN Tag auf eno1 oder neuer bond gegeben )

    - ganze Festplatte verwenden: JA (da liegt dann auch die media/recordings ... nehme ich an)

    - Nutzernamen hab ich halt einen neuen angegeben ... hätte ich root nehmen sollen ?

    - SSH läuft mit diesem User (aber verm. ohne root Rechten)

    - snapshots ? Habe ich nichts angehakt


    2 Nun steht nach dem Kernelinstall Folendes in der Konsole (siehe screenshot) .. passt das ?

    und dann weiter mit Punkt 3 Ansible ?


    3 Wo soll ich den install von mcli (ubin mir nicht sicher ob das nicht auch minisatip benötigt) einbauen und wie lautet die Zeile dafür ?


    4 Wo lege ich das VLAN device an und muss ich das außer in mcli noch wo eintragen ?