yavdr-ansible focal auf NUC10i3 etc.

  • seahawk1986 : FireFly hatte hier mal einen Transport-Stream-Patch. Ist der im aktuellen yavdr drin?

    Nein, bislang nicht - aber wenn der für dich funktioniert, kann ich den gerne ins Paket aufnehmen - auf die Schnelle ohne expliziten Paketbau ginge das so:

    Code
    sudo add-apt-repository -s ppa:yavdr/experimental-vdr  # oder welches PPA du für den VDR sonst nutzt
    sudo apt install build-essential pkg-config vdr-dev
    sudo apt build-dep vdr-plugin-satip
    apt source vdr-plugin-satip
    wget 'https://www.vdr-portal.de/index.php?attachment/46362-satip-transfer-mode-fixd-diff/' -O satip-transfer-mode-fixd.diff
    cd vdr-plugin-satip-2.4.1/
    patch -p0 -i ../satip-transfer-mode-fixd.diff
    make
    sudo make install
    sudo systemctl restart vdr

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    Edited once, last by seahawk1986: Restart-Befehl für VDR korrigiert ().

  • Hallo seahawk1986 ,

    Danke für die Anleitung.


    ich habe hier

    und in meiner datei localhost steht:

    muß ich da ausmisten, oder kann ich Deine Anleitung abarbeiten?

    Und bist Du nicht willig, so brauch ich Geduld!
    System: TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible - Jammy auf Intel NUC 10i3FNH

  • muß ich da ausmisten, oder kann ich Deine Anleitung abarbeiten?

    Wenn man mehr als ein PPA für VDR-Pakete gleichzeitig nutzt, kann es zu Problemen kommen - ich würde die nicht genutzten mit Hilfe von ppa-purge entfernen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo seahawk1986 und rkp - der Patch ist drin. Ich werde berichten.


    Der Letzte Befehl lief nicht durch - ich habe neu gebootet.

    Code
    kk@yavdr:~$ sudo restart vdr
    [sudo] Passwort für kk: 
    sudo: restart: Befehl nicht gefunden
    kk@yavdr:~$

    Und bist Du nicht willig, so brauch ich Geduld!
    System: TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible - Jammy auf Intel NUC 10i3FNH

  • Das sollte sudo systemctl restart vdr heißen, ich habe es oben in der Anleitung ebenfalls korrigiert.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo zusammen,

    der patch für vdr-plugin-satip ist nun seit einigen Tagen drin.

    Seither ist das Umschaltproblem (OSD meldet "cannot start transport stream" oder so) nicht wieder aufgetreten.


    Das Log wird aber nach wie vor zeitweise ca. 9x pro Sekunde mit dem "failed to send section data" geflutet - werde also suchen bei welchem Kanal das passiert.


    Ansonsten gibt es SATIP-Errors bzgl Tuning:


    Vielleicht sollte ich auch mal die Search-Timer raus werfen...

    Und bist Du nicht willig, so brauch ich Geduld!
    System: TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible - Jammy auf Intel NUC 10i3FNH

  • Ich habe den Patch mal ins satip-Paket eingebaut (baut gerade), vielleicht kann RPK das auch mal testen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Transfer-Mode Problem sind bisher nicht mehr aufgetaucht.

    Das Problem mit dem "failed to send section data" ist leider nach wie vor vorhanden.


    Auf die Idee, dass das nur durch einen bestimmten Sender ausgelöst wird, bin ich noch nicht gekommen. Das würde erklären, warum es unterschiedlich lang dauert, bis es auftritt.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

  • Wie kann ich eigentlich den epg scan auf die Kanalnummern 1-50 reduzieren?

    Ich habe auf die Schnelle keinen setup.conf eintrag gefunden...

    Und bist Du nicht willig, so brauch ich Geduld!
    System: TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible - Jammy auf Intel NUC 10i3FNH

  • Da gibt's doch das epgborder-Plugin?

  • Da gibt's doch das epgborder-Plugin?

    Danke für den Tipp! - und in seahawks Rep ist es auch schon drin :thumbup:


    Habe es Installiert und den EPG- Range auf Kanal 1-50 begrenzt. Der VDR bleibt bisher nicht mehr hängen :)

    (die section data errors sind aber noch im log)


    rkp , willst Du das auch mal teseten?

    Und bist Du nicht willig, so brauch ich Geduld!
    System: TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible - Jammy auf Intel NUC 10i3FNH

  • Im Begrenzen der EPG-Range sehe ich keinen Sinn. Habe nur die Sender in der channels.conf, von denen ich EPG möchte.


    Aber es ist offenbar so, dass das Problem mit dem "failed to send section data" immer dann auftritt, wenn ich durch die Sender zappe.

    Solange ich nur HD-Sender aufrufe, passiert nichts. Gehe ich hingegen auf einen SD-Sender, dauert es nur wenige Sekunden, bis der Fehler auftritt. Zurück auf einen HD-Sender bewirkt das sofortige Ende der Meldungen.


    Ich denke, dass man von einem Softwareproblem ausgehen muss und meine Hardware in Ordnung ist. Dafür spricht auch, dass ich noch eine ca. 4 Monate alte Version von yavdr habe, die problemlos funktioniert, ich darf nur keine Update machen.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

  • Hi rkp ,

    die Daten hier sind auch meist auf SD-Kanälen korrupt:

    Code
    Mar  4 19:37:08 yavdr vdr: tsdemux: transport error
    Mar  4 19:37:08 yavdr vdr: tsdemux: transport error
    Mar  4 19:37:08 yavdr vdr: [softhddev] invalid PES video packet
    Mar  4 19:37:08 yavdr vdr: [softhddev] 2 invalid PES video packet(s)

    Manchmal finde ich audio drift delay von über 4000 ms im Log.


    Nach dem es zwar besser geworden ist, aber die vdr-Bedienung doch noch manchmal einfriert, mache ich gerade Radikaltour:

    1) Octopus zerlegt und wieder zusammengebaut, Alle (auch interne) Kabel abgesteckt und neu angesteckt.

    2) Alle Plugins entfernt (auch CEC-Remote)


    Ist es normal, daß die /dev/loopx zu 100% belegt sind?

    so long, K.

    Und bist Du nicht willig, so brauch ich Geduld!
    System: TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible - Jammy auf Intel NUC 10i3FNH

  • Ist es normal, daß die /dev/loopx zu 100% belegt sind? Spoiler df -h

    Ja, Snap nutzt Squashfs-Images, die genauso groß wie benötigt sind - die Nutzdaten landen dann auf einem beschreibbaren Dateisystem.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • ... update...


    Das Entfernen fast aller Plugins hat das Aufhängen des vdr-prozesses nicht verhindert (100% nach htop, Bild läuft weiter, vdr ist nicht mehr bedienbar)


    Code
    Mar  6 14:26:13 yavdr vdr: [958] SATIP: Detected 2 RTP packet errors [device 1]
    Mar  6 14:26:13 yavdr vdr: [958] SATIP: Detected 2 RTP packet errors [device 2]
    Mar  6 14:26:13 yavdr vdr: [958] SATIP: Detected 2 RTP packet errors [device 3]

    Ich vermute, es gibt defekte Daten, und das wird nicht verkraftet...


    im Log habe ich ich auch incomplete sections Meldungen:


    so long,

    K.

    Und bist Du nicht willig, so brauch ich Geduld!
    System: TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible - Jammy auf Intel NUC 10i3FNH

  • Die RTP Packet Errors habe ich auch regelmäßig im Log, das verkraftet der VDR.

    Auch die

    Code
    Mar  5 15:30:06 vdr vdr: [1058] SATIP-ERROR: failed to send section data (101 bytes) [device=0]
    Mar  5 15:30:10 vdr vdr: message repeated 38 times: [ [1058] SATIP-ERROR: failed to send section data (101 bytes) [device=0]]

    habe ich sehr häufig im Log.


    Hat bei mir keinerlei Auswirkungen auf die Bedienbarkeit.


    Auch die Meldungen mit read incomplete sectionkenne ich schon lange und hatte hier auch mal im Forum nachgefragt, was die bedeuten. Leider ohne Antwort.

    Auswirkungen scheinen die aber auch keine zu haben, zumindest nicht bei mir.


    Mein System ist ein NUC8i3BEH.

  • Danke für die Information. Damit ist wohl klar, dass es nichts mit meiner spezifischen Hardware zu tun hat.


    Da liegt offensichtlich ein Softwareproblem vor, welches bei Betrieb mit Sat-IP auftritt. Da ist man als normales User natürlich hilflos.

    Wenn ich softhddrm einsetzte, passiert übrigens nicht. Aber softhddrm produziert heftige Tonprobleme, ausserdem geht Kodi nicht ohne X.


    Ich überlege schon, ob ich den VDR aufgeben soll, so macht das kein Spass mehr. Dummerweise fällt mir keine vernünftige Alternative ein.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

  • ... auch bei mir ist der WAF etwas gefallen :(


    Kann mir jemand bei einem Script helfen für folgenden Würg-Around:

    1) Prozessorauslastung des vdr auslesen. Wenn t>5min bei 100%, dann

    2) kill -9 PID-des-VDR

    3) sudo systemctl restart vdr


    Das script würde dich dann in die crontab packen...


    Oder gibt es noch eine weniger harte Methode?

    Und bist Du nicht willig, so brauch ich Geduld!
    System: TV Philips 4k, + CEC-Remote, Octopus Net

    YaVDR Ansible - Jammy auf Intel NUC 10i3FNH

  • Da liegt offensichtlich ein Softwareproblem vor, welches bei Betrieb mit Sat-IP auftritt. Da ist man als normales User natürlich hilflos.

    Wenn ich softhddrm einsetzte, passiert übrigens nicht. Aber softhddrm produziert heftige Tonprobleme, ausserdem geht Kodi nicht ohne X.

    Naja, ich benutze ja auch SatIP (Onet). Und kenne Deine beschriebenen Probleme nicht.

    Benutzt du softhdvaapi mit oder ohne libplacebo? Wenn mit, dann vllt. mal die Scaler runterschrauben oder eben mal die nocebo-Variante versuchen.

    Auch würde ich mal zum Testen alles mögliche an Plugins deaktivieren, vllt. spielt ja bei Euch was anderes mit rein.

    Evtl. ist es auch eine Treibergeschichte, ihr benutzt ja beide einen NUC10.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!