[ANNOUNCE] skinElchi HD 0.5.0 / 0.5.1

  • Hier gibt's Version 0.5.1: http://firefly.vdr-developer.o…skinelchihd-0.5.1.tar.bz2


    Die wichtigsten Änderungen:

    • Unterstützung für GraphicsMagick++ (nur PNG Kanal-Logos)
    • Unterstützung für ImageMagick++ 7.x (SVG und PNG Kanal-Logos)
    • keine Unterstützung mehr für ImageMagick++ 6.x - die Probleme mit der Transparenz werden nicht mehr gelöst
    • Kanal-Logos können jetzt auch 50% größer dargestellt werden
    • HD/UHD im Aufnahmemenü kann in den Einstellungen deaktiviert werden

    Die Umschaltung zwischen ImageMagick++ und GraphicsMagick++ erfolgt im Makefile mit IMAGELIB= oder als Parameter bei make ...IMAGELIB=imagemagick|graphicsmagick wobei ImageMagick Default ist, also ohne Parameter genommen wird.


    Danke an Uwe für's Testen diverser Betaversionen und auch an alle anderen, die mit Fragen und Tests zu dieser Version beigetragen haben :)


    Happy compiling

    FireFly

  • Mit der neuen Version, habe ich auf dem Raspi keine Probleme mehr.

    Danke schön

    speed

  • Gerade installiert. hat auch einmal funktioniert. Sieht super aus. Genau mein Fall.

    Dann habe ich in die 50-skinelchihd.conf eingegeben:


    --logopath=/usr/share/vdr/plugins/skinelchihd/logos


    (darin sind png-Logos)


    , und jetzt passiert das:


    Code
    1. Oct 23 21:29:18 ubuntu-nuc1 kernel: [ 2912.966736] vdr[4343]: segfault at 0 ip 00007f6d311ea2ee sp 00007ffd6b2a0bb0 error 4 in libvdr-skinelchihd.so.2.4.5[7f6d311e2000+21000]
    2. Oct 23 21:29:18 ubuntu-nuc1 kernel: [ 2912.966759] Code: 38 48 8b 35 94 fc 05 00 64 48 8b 04 25 28 00 00 00 48 89 44 24 28 31 c0 49 89 e5 4c 89 ef e8 29 95 ff ff 48 8b bb 40 01 00 00 <48> 8b 07 ff 50 40 4c 8b b3
    3. Oct 23 21:29:19 ubuntu-nuc1 systemd[1]: vdr.service: Main process exited, code=dumped, status=11/SEGV
    4. Oct 23 21:29:19 ubuntu-nuc1 systemd[1]: vdr.service: Failed with result 'core-dump'.
    5. Oct 23 21:29:19 ubuntu-nuc1 systemd[1]: vdr.service: Scheduled restart job, restart counter is at 5.
    6. Oct 23 21:29:19 ubuntu-nuc1 systemd[1]: Stopped Video Disk Recorder.
    7. Oct 23 21:29:19 ubuntu-nuc1 systemd[1]: vdr.service: Start request repeated too quickly.
    8. Oct 23 21:29:19 ubuntu-nuc1 systemd[1]: vdr.service: Failed with result 'core-dump'.
    9. Oct 23 21:29:19 ubuntu-nuc1 systemd[1]: Failed to start Video Disk Recorder.


    Auch nach dem Löschen des Eintrages in der 50-skinelchihd.conf geht es nicht mehr.


    Was habe ich vermurkst?

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe

  • Hm, scheint nichts mit meinen Einstellungen zu tun haben. Gelöscht, neu installiert, conf-Datei editiert, gestartet, geht, auch Logos sind da. Nach einem Neustart geht es nicht mehr, es kommt immer obige Fehlermeldung.

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe

    The post was edited 1 time, last by rkp ().


  • vdr-User-# 755 to_h264 chk_r vdr-transcode

  • Vielen Dank für das Plugin. :-)


    Ich hab es auf einem Raspi3 mit rpihddevice installiert und es sieht bis auf eine Kleinigkeit sehr gut.

    Wenn ich auf die Aufnahmen gehe, dann werden die noch ungesehenen Aufnahmen mit dem Hinweis "neu" markiert. Bei mir überlagert dieser Hinweis mit der Zeitangabe für die Länge der Aufnahme so das diese nicht richtig zu erkennen ist und unschön aussieht. Ist das nur bei mir bzw. mit dem rpihddevice ein Problem?


    Gruß dile

  • Das Problem ist, dass nicht der Skin die Breite der Spalten definiert, sondern die übergeordneten Menüs (der Skin zeigt sie nur an). Es liegt also nicht am Ausgabedevice, eher am Font - wenn der klein genug gewählt wird überlagert es sich nicht (aber man kann die Schrift nicht mehr lesen :-().

    Das steht noch auf meiner todo Liste, eine akzeptable Lösung habe ich aber bisher nicht dafür.


    EDIT: Workaround: in den Einstellungen das HD/UHD-Symbol abschalten

  • EDIT: Workaround: in den Einstellungen das HD/UHD-Symbol abschalten


    Das macht keinen Unterschied. Auch wenn das abgeschaltet ist, wird es genauso überlagert. Außerdem sehe ich bei mir auch gar kein extra Symbol womit ich HD Aufnahmen erkennen könnte, auch wenn es aktiviert ist.



    Ich hab bei mir noch ein anderes Problem festgestellt. Es werden keine epg Bilder angezeigt bzw. der VDR hängt sich komplett auf und reagiert nicht mehr. Wenn ich die epg Bilder abschalte, dann hängt sich der VDR nicht auf. Folgende Meldung sehe ich im Log als letztes vor dem Absturz:

    Code
    1. skinelchiHD-cEpgImage thread started (pid=528, tid=557, prio=high)

    Hab jetzt schon GraphicsMagick++ und ImageMagick++ probiert.


    Ideen was hier falsch läuft oder womit ich das eingrenzen könnte.


    Vielen Dank Gruß dile

  • Das macht keinen Unterschied. Auch wenn das abgeschaltet ist, wird es genauso überlagert.

    Hmm, kannst Du mal nen Screenshot machen? Den kannst Du mir auch per PM schicken. Normalerweise ist immer etwas Platz zwischen den Spalten....


    Es werden keine epg Bilder angezeigt bzw. der VDR hängt sich komplett auf und reagiert nicht mehr.

    Ja, da verfangen sich die Threads manchmal .... In meiner aktuellen Version tritt das nicht mehr auf, aber an anderen Stellen hapert es noch ab und zu weshalb ich noch keine neuere Version veröffentlicht habe. Bei Interesse könnte ich Dir die Beta-Version zukommen lassen.