[softhddevice-drm]

  • Ach so, ja klar, nur 4:3 nicht

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • Ok, vorletzte Frage: Ohne gles heißt mein branch, nicht zillerbaers?

    sg75 hatte auch so ein Problem...

    Letzte Frage: zillerbaers Original geht in beiden Fällen?

    Schau ich mir nächste Woche mal an.

  • Ok, vorletzte Frage: Ohne gles heißt mein branch, nicht zillerbaers?

    Ja, alle tests von heute und gestern habe ich mit dem branch drm-atomic-v7-gles_gbmfix gemacht nur einmal mit gles und ohne gebaut


    rell wrote:

    Letzte Frage: zillerbaers Original geht in beiden Fällen?


    habe ich nicht getestet, kann ich aber gerne machen wenn du möchtest

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • habe ich nicht getestet, kann ich aber gerne machen wenn du möchtest

    Wäre hilfreich um es einzuschränken...

    Aber keinen Stress, vor morgen abend oder Montag kann ichs aber eh nicht anschauen.

  • Hallo rookie1 ,

    ich habe die Änderungen mal in https://github.com/rellla/vdr-…m/tree/drm-atomic-v7-gles übernommen.


    Die Fehler aus deinen letzten beiden Logs haben aber imho nicht mit drm oder gles zu tun, sondern riechen nach einem Codec Problem. Die drm und gles Logs sehen gut aus, nur der Codec nicht:

    Es wäre also gut, wenn du das mit zillerbaers Branch auch nochmal versuchst.

    Hast du unterwegs irgendwas an ffmpeg geändert?


    Gruß

    Andreas

  • So jetzt bin ich zum testen gekommen


    neuester branch drm-atomic-v7-gles:
    Läuft und ich bilde mir ein daß das OSD deutlich performanter ist.

    4:3 Sendungen stürzen nicht mehr ab werden aber weiterhin in 16.9 Format dargestellt

    zillerbaers:

    wird im richtigen Format dargestellt

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • Danke, hört sich gut an. Ich werde mal eine 4:3 Aufnahme bei mir suchen... Wenn du jetzt noch ein Log mit der 4:3 Aufnahme und aktiviertem DEBUG, DRM_DEBUG und CODEC_DEBUG hättest, wär's super ;)

  • Kommt gleich, was mir noch aufgefallen ist das bei Umschalten auf Servus TV kein Bild mehr kommt und zum Teil auch wenn ich wieder zurück schalte

    Files

    • servus.txt

      (132.53 kB, downloaded 69 times, last: )

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • So jetzt noch das Log von 4:3

    Files

    • 4z3.txt

      (11.03 kB, downloaded 47 times, last: )

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • 4:3 Sendungen stürzen nicht mehr ab werden aber weiterhin in 16.9 Format dargestellt

    Kann ich reproduzieren und schaue ich mir an.

  • Das unterdrückt die Meldung "CodecVideoReceiveFrame: receive_frame ret: Die Ressource ist zur Zeit nicht verfügbar" wenn EAGAIN als geplanter Rückgabewert kommt. Es werden nur Fehler wie ENOMEM etc. angezeigt. Damit wird das Log etwas kleiner, da bei einem Kanalwechsel immer ein paar dieser Meldungen im Log auftauchen, was m.M. nach nicht unbedingt sein muss.


    EDIT: Die Commitbeschreibung ist falsch sehe ich gerade :(

  • ich habe meine VDR Installation etwas geändert wenn ich jetzt von einem HD auf einen anderen umschalte startet der VDR neu. Wenn ich aber den Debug Modus im softhddevice aktiviere hab ich keine Probleme mehr

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • seither habe ich den vdr mit apt-get --yes install vdr vdr-dev installiert.

    da mir die Version zu alt war baue ich ihn jetzt selber

    Es gibt ein Segfault. Kannst Du vdr unter gdb starten?

    muss ich nochmal schauen wie das geht

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • muss ich nochmal schauen wie das geht

    ich starte so:

    Code
    1. gdb -ex=run --args /usr/bin/vdr -c /etc/vdr --no-kbd -E /etc/vdr/epg.data -s /usr/local/bin/vdrshutdown -v /home/Video -l 3 --lirc=/dev/lircd -P "softhddevice-drm -a hw:0,2" -P streamdev-client

    Ein Core File würde auch helfen. Das kommt wenn Du das vor vdr start eingegeben hast:

    Code
    1. ulimit -c unlimited
  • kannst du damit erst mal was anfangen


    Code
    1. Thread 18 "vdr" received signal SIGSEGV, Segmentation fault
    2. [Switching to Thread 0x992fc400 (LWP 19074)]
    3. 0xb6448a00 in Frame2Display (render=0x5d8820) at video_drm.c:1192
    4. 1192 PicWidth = render->mode.vdisplay * av_q2d(frame->sample_aspect_ratio) *
    5. (gdb) quit

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO