[FYI] yavdr-ansible auf dem Raspberry Pi (Version 2 und 3)

  • Jetzt fällt mir auf das Tab (für Menu) nicht geht. In der remote.conf steht es richtig:

    Es geht da um die KBD.* Einträge, ohne X-Server und Ausgabeplugin, das dessen Tastendrücke weiterleitet sieht der VDR keine XKeySym-Tastendrücke.


    Jetzt fällt mir auf das Tab (für Menu) nicht geht.

    Aktuell gibt es in der remote.conf nur einen Eintrag für die Pos1/Home-Taste: https://github.com/yavdr/yavdr…dr/files/remote.conf#L132


    Die Datei /lib/udev/rc_keymaps/rc-tt-1500 sieht so aus:

    Ist das die originale aus https://github.com/yavdr/yavdr…ter/rc_keymaps/rc-tt-1500? Da hat seit 2012 ein Komma in der ersten Zeile gefehlt: https://github.com/yavdr/yavdr…e15f103bfcc1bf848c5f3f750

    Ich baue später noch ein neues Paket.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ah, habe nicht ganz durchgescrollt - es geht um die KBD.* Einträge (wegen tty) - Unterschied zum Nuc ist X Server und andere remote.conf Einträge...

    Ich prüfe das heute Abend.


    Ja, die /lib/udev/rc_keymaps/rc-tt-1500 ist original. Ah, auch da.


    Ich berichte.

    The post was edited 1 time, last by vdr_rossi ().

  • Versuche jetzt den GPIO IR Empfänger zum laufen zu bekommen.


    Die /etc/rc_maps.cfgsieht so aus:

    Code
    1. ..
    2. #driver table file
    3. #ite-cir rc-rc6-mce /lib/udev/rc_keymaps/rc-rc6-mce
    4. #nuvoton-cir rc-rc6-mce /lib/udev/rc_keymaps/rc-rc6-mce
    5. #serial_ir rc-rc6-mce /lib/udev/rc_keymaps/rc-rc6-mce
    6. #mceusb rc-rc6-mce /lib/udev/rc_keymaps/HOPLOrc6
    7. gpio_ir_recv rc-tt-1500 /lib/udev/rc_keymaps/rc-tt-1500

    Einträge über gpio_ir_recvsind sicherheitshalber auskommentiert.


    geladen wird trotzdem rc-rc6-mce?

    Führe ich das manuell aus:

    Code
    1. root@ubuntu:/home/ubuntu# ir-keytable -c -p rc5 -w /lib/udev/rc_keymaps/rc-tt-1500
    2. Lesen von Tabelle rc-tt-1500
    3. alte Schlüsseltabelle geleert
    4. 36 Schlüsselcode(s) wurden in den Treiber geschrieben.
    5. Protokolle geändert in rc-5

    läuft alles :thumbup: aber nach einem reboot geht es nicht mehr.


    Im Log finde ich kein keytable Eintrag.


    Was läuft da schief?

  • Ich habs, es fehlt rc-tt-1500.toml !?


    edit: Nee - habe rc-hauppauge.toml als Muster genommen und rc-tt-1500.toml aufgebaut - keine Besserung.

    The post was edited 1 time, last by vdr_rossi ().

  • Die /etc/rc_maps.cfgsieht so aus:

    gpio_ir_recv rc-tt-1500 /lib/udev/rc_keymaps/rc-tt-1500

    Das sollte so aussehen, weil ir-keytable auf die Kombination aus Treiber und Standard-Keymap schaut, wenn es die rc_maps.cfg verarbeitet und die Keymaps lädt:

    Code
    1. gpio_ir_recv rc-rc6-mce /lib/udev/rc_keymaps/rc-tt-1500

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ja, damit läufts!


    Was mir auch noch aufgefallen ist. In der ersten Zeile von /lib/udev/rc_keymaps/rc-hauppaugesteht ... RC5 am Ende

    und in /lib/udev/rc_keymaps/rc-tt-1500 steht ... rc-5


    Hab es auf RC5 geändert.

  • Lässt sich das suspend.soft Script von hier noch mit einbauen?