Problem mit Grafikkartentreiber bei/nach Installation

  • Hallo zusammen ! Ich war in der Vergangenheit unter Joe L bekannt, hab aber leider alle Zugangsdaten und auch Mailaccount irgendwie verlegt (war lange Zeit gesundheitlich außer Gefecht) und möchte mich nun (nachdem ich schon yavdr0.5 und yavdr0.6 im Einsatz hatte) dem "neuen" ansible yavdr widmen...


    Ich habe den Linux-Server http://cdimage.ubuntu.com/releases/18.04.4/release/ubuntu-18.04.4-server-amd64.iso auf mein System installiert. Nach mehreren Fehlversuchen das Playbook "as-is" durchlaufen zu lassen (immer wieder irgendwelche "fatal-Errors") habe ich mich an der headless-Variante versucht wobei ich


    Code
    1. autoinstall-satip
    2. autoinstall-pvr350
    3. autoinstall-hauppauge-pvr
    4. autoinstall-dvbsky-firmware

    auskommentiert habe und

    Code
    1. epgd
    2. channelpedia

    einkommentiert habe. Das Playbook ist fehlerfrei durchgelaufen. Testen konnte ich mangels vdr-Client in meinem Environment nicht.

    Guten Mutes machte ich mich daran das "normale" Playbook für mich zu adaptieren. Mit dem Wissen, dass ich bei der MLD-Installation nur mit nvidia-legacy driver ein Bild mit meiner nvidia-Karte bekomme habe ich folgende yavdr07.yml:

    und erhalte - nachdem bereits viele Rollen positiv durchgelaufen sind folgende Fehler:

    Jetzt bin ich leider ratlos. Was tun ?


    Übrigens: ich habe nun zum gefühlt 100sten Mal den Ubuntu-Server neu aufgesetzt um eine saubere Umgebung zu haben. Ist das notwendig oder kann ich das Playbook (teilweise) rückgängig machen ?


    DANKE !!!

  • Wenn Sie eine nvidia-GraKa verwenden, wäre es möglich, im Bios die Onboard-Grafik zu deaktivieren?

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-460.32), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.6-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.10.8-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Das sieht so aus, als wäre da die Intel IGP parallel zur nvidia-Karte aktiv - nach Möglichkeit würde ich die Intel IGP im Bios abschalten.

    Ansonsten kannst du die Zeilen https://github.com/yavdr/yavdr…tasks/detect-xorg.yml#L56 bis https://github.com/yavdr/yavdr…tasks/detect-xorg.yml#L96 für den Block auskommentieren, der versucht den noveau-Treiber und die daran hängenden Module zu entladen - das ist dazu gedacht, dass man ohne Reboot nach der Installation des nvidia-Treibers eine Bildschirmerkennung machen kann aber das klappt nur, wenn es keine anderen Grafiktreiber gibt, die auf KMS setzen.,

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Zwischenstand: abschalten der onboard ist nicht möglich. Mein ASROCK Z77 Extreme3 erlaubt nur eine Primary-GraKa auszuwählen, mit abschalten ist auf diesem Board nicht. Werde System neu aufsetzen und nach Alexander's Tip vorgehen. More to come (most likely 2morrow)


    Danke

  • Danke soweit mal, Habe Alexander's Tip befolgt und die Zeilen auskommentiert - läuft wunderbar drüber und "erhängt" sich nun später.

    "journalctl -xe" liefert folgendes

    Und bevor die Frage kommt welche GraKa ich habe hier ein lspci


    Danke für die Unterstützung !!!


    LG Joe

  • GT-430 läuft nur mit dem Legacy-nvidia-Treiber, ich glaub, da ist nix mit Cuda oder Cuvid.

    Aber was sagt lsmod|grep drm und "modinfo nvidia"?

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-460.32), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.6-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.10.8-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Natürlich geht mit einer GT430 (GF108), Fermi, VDPAU. Mit ihren 96 Cuda Cores kann die auch problemlos "temporal spatial" ...


    Richtig ist aber, die Karte ist schon vor langer Zeit aus dem regulären Treiber Support raus und wird nur noch mit dem binären Nvidia Legacy Treiber Paket rennen. Aktuellste Version hier ist "390.138" vom 24.6.2020.

    HowTo: APT pinning

  • Natürlich geht mit einer GT430 (GF108), Fermi, VDPAU. Mit ihren 96 Cuda Cores kann die auch problemlos "temporal spatial" ...


    Richtig ist aber, die Karte ist schon vor langer Zeit aus dem regulären Treiber Support raus und wird nur noch mit dem binären Nvidia Legacy Treiber Paket rennen. Aktuellste Version hier ist "390.138" vom 24.6.2020.

    OK, danke. Was heißt das aber nun für mein Problem ? Wie kann ich das lösen ? Neue GraKa ? Und wenn "ja", welcher Typ ?

    The post was edited 1 time, last by rallye ().

  • OK, danke. Was heißt das aber nun für mein Problem ? Wie kann ich das lösen ? Neue GraKa ? Und wenn "ja", welcher Typ ?

    Naja, entweder Legacy Treiber verwenden, der Code für die Karte hat ja seine Fähigkeiten behalten, eingefroren, kann also VDPAU.


    Oder eine neuere Karte, für den VDR Zweck käme eine GT 1030 (Pascal) in Frage, das wird wieder eine Weile dauern bis die aus dem "regulären" Treiber fliegt.


    Turing GPU gibt es leider nicht in der kleinen Klasse. Kleinste wäre GTX 1650, gibt es als passive Karte von Palit ... aber €130,- + von allen Herstellern.

    HowTo: APT pinning

    The post was edited 1 time, last by fnu ().

  • Mit meiner GT720 (passiv) läuft softhddevice-cuvid aus http://ppa.launchpad.net/seaha…/vdr-2.4.1-patches/ubuntu, das hat mit dem Scaler "anamorph" eine deutlich bessere Bildqualität bei SD als "temporal-spatial".

    Läuft/liefe das auch mit der GT630 oder meiner GT610 im Desktop-Rechner?

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-460.32), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.6-patches, vdr-epg-daemon mit Frodo-plugins, Kernel 5.10.8-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv. Folding@home läuft auf CPU.

  • Hi,

    610 wahrscheinlich nicht, zumindest 730 und 630 waren ja hardwaretechnisch identisch. Ob das auch der Treiber künstlich so sieht steht auf nem anderen Blatt. Kann die passiven 1030 aber empfehlen. Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Danke für eure Tips ! Ich hab nun bei einer lüfterlosen Pascal 1030 zugeschlagen und diese eingebaut. Über den zuletzt gemeldeten Fehler bin ich erwartungsgemäß problemlos drüber gekommen, doch nun stehe ich beim nächsten Problem:


    Das journalctl -xe liefert folgendes:

    Bitte um Hilfe - was ist diesmal schief gelaufen und wie kann ich es verbessern ?


    Danke

  • Hi,

    Welchen Nvidia Treiber hast du drauf? Einen zur Karte passenden?

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Welchen Nvidia Treiber hast du drauf? Einen zur Karte passenden?

    Danke, gute Frage. Ehrlich: ich weiß es nicht. Wo/wie finde ich das heraus bzw. könnte den Driver ändern ? Im Playbook/Doku habe ich dafür keine Hinweise gesehen.


    Danke !

  • Wo/wie finde ich das heraus

    Zum Beispiel mit nvidia-smi oder dem Inhalt von /etc/yavdr/autoinstalled

    Im Playbook/Doku habe ich dafür keine Hinweise gesehen.

    Das Playbook verlässt sich auf die automatische Erkennung des Treibers durch ubuntu-drivers: https://github.com/yavdr/yavdr…tu-drivers/tasks/main.yml

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke ! Das war der entscheidende Hinweis. Die richtigen Driver waren durch das Playbook bereits installiert, jedoch nicht aktiv. Ein "reboot" hatte gefehlt. Nach Einspielen einer channels.conf hab ich auch mal ein Bild.