Plugins werden nicht mit aktueller Mysql gebaut

  • Hallo da mein Headless Server noch Ubuntu 16.04 hat wollte ich jetzt auf 20.04 umstellen.


    Da die jungs von mysql Speicher sparen musten;( haben sie den Datentyp my_bool ersatzlos gestrichen. Jetzt baut ja das eine odere andere Plugin nicht mehr ( scraper2vdr, epg2vdr)


    Code
    1. db.h:419:7: error: 'my_bool' does not name a type; did you mean 'bool'?
    2. 419 | my_bool* getNullRef() { return &nullValue; }

    Wie habt ihr das den gelöst. habt ihr die Plugins abgeändert, oder gibt es da noch eine bessere Möglichkeit


    rookie

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • Ich hab mal den mysql-server gelöscht und den mariadb-server installiert, da kam der gleiche Mist.

    Hab aber nicht neugestartet

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO