Softhddevice: audio/alsa: avail underrun error? 'Broken pipe'

  • Hello,


    I have hardware setup:


    Intel Core i3-7100U Processor (2.40 GHz) + Intel GT2-520 GPU, 8GB DDR4

    PCI-e card DVB-S/2 Dual tuners ST-STV0910 by Digital Devices.


    Software setup:

    DEBIAN ("buster") v10.10.0

    vdr (2.4.0/2.4.0) - The Video Disk Recorder --> installed from Debian package distribution (apt-get)

    softhddevice (0.7.0-GIT1fb6cb8) --> built from source git://projects.vdr-developer.org/vdr-plugin-softhddevice.git

    Intel graphics driver i965-va-driver Version: 2.3.0+dfsg1-1 (intel-vaapi-driver)

    xserver-xorg-core Version: 2:1.20.4-1


    Problem:

    Whan DVB-S2 playpack of 4K channel is playing I see errors in syslog and hear fragmented sound. The channel I see the problem is:

    SES UHD Demo Channel;SES:10993:HC56M5O35P0S1:S19.2E:22000:511=36:0;512=deu@122:0:0:1:1:1035:0


    syslog:

  • From channel: Nasa TV UHD;(null):10728:hC34M5O35S1:S13.0E:30000:357+377=36:358=@4,359=@4:0:0:4602:318:11100:0

    I occasionally see stuttering audio and video and these syslog errors:


  • On my original post I had error - I was building the plugin from the https://github.com/ua0lnj/vdr-plugin-softhddevice.git

    and the git revision seems to be correct: softhddevice (0.7.0-GIT1fb6cb8)


    I tried vdr plugin with disabled audio:

    -a ""

    And there is no audio eerror but other errors remain.

  • I also notice GPU hang errors only when I play Nasa TV UHD;(null):10728:hC34M5O35S1:S13.0E:30000:357+377=36:358=@4,359=@4:0:0:4602:318:11100:0


  • I upladed two recordings of the channel to my google drive, 00001.ts is recorded with softhddevice running and 00002.ts with libxineliboutput-sxfe running. Both vidoes play much better with VLC mediaplayer on the same PC. Video 00001.ts seems to have more clitches.


    00001.ts


    00002.ts

  • Just in case I list package versions that I installed with apt-get before I built the plugin:


    Package: vdr-dev

    Version: 2.4.0-1+b1


    Package: libasound2-dev

    Version: 1.1.8-1


    Package: libdrumstick-dev

    Version: 0.5.0-4+b2


    Package: libva-dev

    Version: 2.4.0-1


    Package: libavcodec-dev

    Version: 7:4.1.4-1~deb10u1


    Package: libswscale-dev

    Version: 7:4.1.4-1~deb10u1


    Package: libxcb-dpms0-dev

    Version: 1.13.1-2


    Package: libx11-dev

    Version: 2:1.6.7-1


    Package: libx11-xcb-dev

    Version: 2:1.6.7-1


    Package: libxcb-icccm4-dev

    Version: 0.4.1-1.1


    Package: libxcb-screensaver0-dev

    Version: 1.13.1-2


    Package: libxcb-ewmh-dev

    Version: 0.4.1-1.1