Hilfe benötigt, SSD mit Reel Image erstellen

  • Hallo Ihr Lieben!

    Ich bräuchte jetzt doch dringend mal Hilfe...

    Ich hoffe, ich bin in der richtigen Kategorie, sonst bitte verschieben...


    Nach sehr langer Laufzeit ist nun leider meine 3TB Platte, die ich in meiner Reel AVGII laufen hatte, kaputt gegangen... Ich konnte noch ein Recovery des letzten Reel Img aufspielen, kam aber nicht mehr an meine Aufnahmen...

    Nun wollte ich ganz gerne eine SSD (zunächst eine 120GB probiert, aber sonst gerne eine alte 60GB) als Betriebssystemplatte einsetzen und eine 2. normale Platte als Media Laufwerk... Nun weiß ich, ich bin Linux Anfänger, dass das Factory Img von Reel immer eine Festplatte ab 320GB braucht...

    Folgende Schritte habe ich gemacht...

    Da mein DVD Laufwerk in der AVGII kaputt ist, musste meine AVGI her halten.

    SSD angeklemmt und Box mit GPARTED Live CD gestartet, dann alle Partitionen auf der SSD angelegt mit entsprechenden Größen und Dateisystemen...

    sda1 mit 13,und GiB und ext4 mit boot Markierung

    sda2 mit 750MiB und ext3 auch als primär

    sda3 mit 1,39 GiB und Swap als primär und

    sda4 mit dem Rest Speicher und jfs ...

    Alles verlief reibungslos.

    System runter gefahren, SSD ab und 320 GB Platte mit orig. Reel Img 12.12 angeklemmt, Box mit Clonezilla Live CD gestartet und die SSD über USB vorher eingebunden.

    Nun habe ich mit der Funktion Partition zu Partition klonen erst sda1 von der 320er Platte auf die jetzt sdb1 der SSD geklont...

    Anschließend den Vorgang mit sda2 wiederholt, sda3 wurde nicht angezeigt, sda4 geht ja nicht, da Zielpartition kleiner als Ausgangspartition...

    Auch das Klonen verlief ohne Fehlermeldungen...

    Alles wieder runter gefahren, CD raus, SSD angeklemmt... System bootet nicht... Ich sehe nur einen blinkenden Cursor auf dem Monitor ohne Fehlermeldung.

    Das Recovery von Reel jetzt noch mal direkt von DVD auf die SSD gespielt, auch das ohne nennenswerte Fehlermeldung, aber SSD bootet nicht...

    SSD mit GPARTED noch mal kontrolliert und Partitionen angepasst, noch mal das Img aufgespielt, selber Fehler...

    SSD bootet einfach nicht... Weder in der AVGI noch in der II...


    Was mache ich falsch?!


    Ach ja... Ich habe bereits kurzzeitig mal BM2LTS probiert, aber da war ich nicht so lange Freund von... Mir fehlte das idiotensichere RCC für den Zugriff auf die Box...

    Ich würde gerne bei dem Reel Img bleiben, hat jemand eine Lösung für mein Problem?!

    Da wäre ich SEEEEHR DANKBAR!


    Vielen Dank!


    Gruß

    Timo

  • Thema mal hierher verschoben, hier gucken die die sich eher damit auskennen könnten ...

    HowTo: APT pinning

  • Ich kenne die Reelbox nicht, aber wenn die mit MBR bootet, muß der wohl noch (grub-install) aus der /-Partition der gecloneten SSD erstellt werden.

    Dazu am besten mit einem Live-Medium muß wohl ein CD-Laufwerk rein) mit z.B. Ubuntu Server oder grml-liveCD starten.

    Die Version des Linux am Bootsystem sollte der (32/64bit) der Reelbox entsprechen.

    Dann müßte man versuchen, die / - Partition zu mounten und vom Live-Boot "mount --bind" für /dev, /sys, /proc übermounten, dann sollte - sofern die Shell gefunden wird, ggf. noch anpassen - ein chroot klappen und anschließend grub-install sowie update-grub.

    Ggf. müssen auch noch die Partitions-UUIDs in der /etc/fstab angepaßt werden.


    Vielleicht doch eine größere SSD kaufen ...

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 12 GB Ram, ubuntu-focal, softhddevice-cuvid
    ddbridge-6.5 mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF720 SFF passiv (nvidia-440-100), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.4.1-patches (=2.4.2) mit Frodo-vdr-epg-daemon, Kernel 5.7.1

    vdradmin-am, vdrmanager (Smartphone als FB), gerbera-mysql. Folding@home läuft auf CPU.

  • lade dir clonezilla runter ...dann aus usb-stick schrieben zum booten .... und dann die eine auf die andere platte kopieren ...fertig .....


    oder das letzte bm2lts-image für reel nehmen ....die reel-software war so buggy .... würde ich nicht nehmen ...aber ist ja geschmackssache

    ------------------------------------------------------------------------------------------------------------------------------------------------

    BM2LTS im VDR-Portal   http://www.bm2lts.de   http://www.sc-schulze.de

    ------------------------------------------------------------------------------------------------------------------------------------------------

    Empfang: Octopus Net S2 max (8 Tuner) +Netceiver mit 2x DVB-s2 dual

    Kopfstation/ Wohnzimmer: Intel NUC8i3BEH2; BM2LTS v3.2.XX

    VDR: Intel NUC D54250WYKH2; BM2LTS Route 66

    weitere Client's: FireTV 4k mit Kodi u. VNSI-Plugin

    ------------------------------------------------------------------------------------------------------------------------------------------------


  • Hallo Leute!

    Vielen lieben Dank für Eure Antworten und ganz großes Sorry, dass ich mich gar nicht mehr gemeldet habe!

    Ich hatte ganz schön zu kämpfen! Seit Thread Erstellung hatte ich Probleme auf anderen älteren Festplatten mit Reel Images meine HD+ Sender zum Laufen zu bringen!

    Ein totaler Spießroutenlauf! Heute habe ich es nach Wochen endlich geschafft!!!

    Es waren zwei Zeilen in der override.conf, die ich nicht berücksichtigt hatte!

    Außerdem war die Box in Reparatur, denn es stellte sich heraus, dass ganz schön viel kaputt war!

    Soooo, genug geschwafelt...

    Hier nun die Lösung zu meinem Problem aus diesem Thread...

    Es ist tatsächlich so, dass die Reelbox IMMER schon mind. eine 320 GB HDD braucht!

    Es ist NICHT möglich, das Image auf eine kleinere Platte zu bekommen, außer über einen Umweg, den ich aber jetzt erst testen kann, da das System erst mal einwandfrei laufen musste...

    Also mann kann natürlich eine 320GB SSD verwenden oder höher, ist aber ja Speicherplatz Verschwendung, da das System, ja nur max. 15 GB groß ist!

    Nun ja... Das normale Klonen auf eine kleinere Partition funktioniert nicht, da diese hinterher nicht bootet, wahrscheinlich die MBR Geschichte, ich habe nicht so viel Ahnung davon...

    Also... Image auf eine 320er Platte spielen, komplett einrichten, so dass man wirklich alles hat wie Senderliste, "Hier nicht erlaubt" und die ganzen Optionen...

    Dann ein Acronis Image erstellen (DAS hätte ich mal lieber damals eh schon machen sollen, denn dann wäre mir diese Farce komplett erspart geblieben!!!) und das Acronis Image (Wichtig!) Block für Block auf die kleinere SSD klonen, damit diese dann bootet!


    Ich bin sehr gespannt, ob es funktioniert!

    Ich werde berichten!


    Vielen Dank nochmal!

    Gruß

    Timo

  • @ Schulze...


    Vielen Dank für den Hinweis!

    Ich habe 8€ gespendet und hatte per Email mit Dir Kontakt! ;)

    Ich habe es dann auch geschafft, die richtige Version runter zu laden...

    Hat aber auf der 120er SSD auch nicht funktioniert...

    Bzw. ich hatte einfach zu viele Probleme auf einmal...

    Ich habe mich aber schlussendlich entschlossen bei der Reel SW zu bleiben...

    Hatte nie Probleme damit außer bis jetzt, aber das Sterben der Platte kam von einem defekten NT. Das wäre also auch mit bm2lts passiert...

    Außerdem habe ich echt das RCC vermisst!!! Das ist einfach ein einfach idiotensicheres Tool für totale Linux Nerds wie mich!:D

    Aber vielleicht habe ich ja doch noch mal Lust zu Wechseln, dann muss ich aber viel Zeit haben! *LACH*


    Danke!

    Gruß

    Timo