[yaVDR] Bildschirmerkennung => Fehler 'dict object' has no attribute 'primary'

  • Hallo zusammen,


    wie ich im yaVDR ansible die Bildschirmerkennung mit sudo -H ansible-playbook yavdr07.yml -b -i 'localhost_inventory' --connection=local --tags="yavdr-xorg" -v anstoße, bekomme ich folgende Fehlermeldung (übrigens auch wenn ich die VDR-Installation mit sudo -H ./install-yavdr.sh starte):


    Code
    1. TASK [yavdr-xorg : create xorg.conf (for nvidia driver)] ***********************************************************************************************
    2. fatal: [localhost]: FAILED! => {
    3. "changed": false
    4. }
    5. MSG:
    6. AnsibleUndefinedVariable: 'dict object' has no attribute 'primary'


    EDIT:

    Mit folgendem Output



    TV ist dabei angeschlossen und eingeschaltet. Was läuft falsch?


    Viele Grüße

    Frank

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

    Im Aufbau: VDR-UHD mit nVidia GT1030 unter Ubuntu 20.04

    The post was edited 1 time, last by r371769 ().

  • TV ist dabei angeschlossen und eingeschaltet. Was läuft falsch?

    Kannst du etwas mehr dazu schreiben, in welchem Zustand sich das System befand? Wurde das System neu installiert oder ist das eine bestehende Installation? Wurden eventuell Updates des nvidia-Treibers installiert, ohne dass ein Neustart erfolgt ist?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Kannst du etwas mehr dazu schreiben, in welchem Zustand sich das System befand? Wurde das System neu installiert oder ist das eine bestehende Installation? Wurden eventuell Updates des nvidia-Treibers installiert, ohne dass ein Neustart erfolgt ist?

    Ich bin folgendermaßen vorgegangen:

    1.) Das System wurde neu aufgesetzt

    2.) Es wurde betriebsfertig gemacht: channels.conf, Fernbedienung mit serial_ir

    3.) Bild mit softhddevice war da

    4.) Anschließend softhdcuvid installiert

    5.) mit vdrctl disable softhddevice deaktiviert

    6.) VDR neu gestartet, es kam kein Bild

    7.) mit sudo -H ansible-playbook yavdr07.yml -b -i 'localhost_inventory' --connection=local --tags="yavdr-xorg" -v die Bildschirmerkennung neu gestartet

    8.) mit sudo -H ./install-yavdr.sh das System "erneut" installiert bzw. upgedatetet


    Es kamen die Meldungen wie im ersten Beitrag beschrieben.

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

    Im Aufbau: VDR-UHD mit nVidia GT1030 unter Ubuntu 20.04

  • Was sagt den dkms status und nvidia-smi und was steht in den /var/log/Xorg.0.log* Dateien, wenn du die Bildschirmerkennung frisch durchgeführt hast?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Was sagt den dkms status und nvidia-smi und was steht in den /var/log/Xorg.0.log* Dateien, wenn du die Bildschirmerkennung frisch durchgeführt hast?

    dkms status sagt

    Code
    1. nvidia, 435.21, 4.15.0-96-generic, x86_64: installed
    2. nvidia, 435.21, 4.15.0-99-generic, x86_64: installed

    und nvidia-smi

    sowie in der /var/log/Xorg.0.log

    Xorg.0.log

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

    Im Aufbau: VDR-UHD mit nVidia GT1030 unter Ubuntu 20.04

  • 1.) Das System wurde neu aufgesetzt

    Da das ja noch bionic zu sein scheint: mit welchem ISO? Eventuell dem Cloud-Server ISO mit Ubiquity-Installer? Was sagt

    apt policy cloud-init?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Da das ja noch bionic zu sein scheint: mit welchem ISO? Eventuell dem Cloud-Server ISO mit Ubiquity-Installer? Was sagt

    apt policy cloud-init?

    apt policy cloud-init meldet

    Code
    1. cloud-init:
    2. Installed: (none)
    3. Candidate: 19.4-33-gbb4131a2-0ubuntu1~18.04.1
    4. Version table:
    5. 19.4-33-gbb4131a2-0ubuntu1~18.04.1 500
    6. 500 http://de.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
    7. 100 /var/lib/dpkg/status
    8. 18.2-14-g6d48d265-0ubuntu1 500
    9. 500 http://de.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

    Das ISO ist ubuntu-server 18.04 (Stand vor ca. 2 Monaten), nach Installation habe ich ein apt-get dist-upgrade gemacht


    Soll ich es mit einem aktuellerem Ubuntu versuchen?

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

    Im Aufbau: VDR-UHD mit nVidia GT1030 unter Ubuntu 20.04

  • Soll ich es mit einem aktuellerem Ubuntu versuchen?

    Ja, focal wäre einen Versuch wert, dafür gibt es ja auch ein Playbook (und man braucht kein extra PPA für softhdvaapi und softhdcuvid ist auch direkt verfügbar): https://github.com/yavdr/yavdr-ansible/tree/focal

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Ja, focal wäre einen Versuch wert, dafür gibt es ja auch ein Playbook (und man braucht kein extra PPA für softhdvaapi und softhdcuvid ist auch direkt verfügbar): https://github.com/yavdr/yavdr-ansible/tree/focal

    Frage: Um das Playbook für focal zu nutzen ist der einzige Unterschied zu bionic, beim git checkout focal anzugeben. Richtig?

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

    Im Aufbau: VDR-UHD mit nVidia GT1030 unter Ubuntu 20.04

  • Ja, oder gleich den focal-Branch beim Klonen holen:

    Code
    1. sudo apt-get install git
    2. git clone -b focal https://github.com/yavdr/yavdr-ansible
    3. cd yavdr-ansible

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ja, focal wäre einen Versuch wert, dafür gibt es ja auch ein Playbook (und man braucht kein extra PPA für softhdvaapi und softhdcuvid ist auch direkt verfügbar): https://github.com/yavdr/yavdr-ansible/tree/focal

    Mit focal bekomme ich leider schon mit softhddevice kein Bild.


    Die nachträglich nochmal gestartete Bildschirmerkennung bringt folgenden Fehler:

    playbook-Output

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

    Im Aufbau: VDR-UHD mit nVidia GT1030 unter Ubuntu 20.04

  • UPDATE:

    Ich habe im Bios testhalber auf GT 1030 als primary Adapter umgestellt (bisher hat softhddevice ohne diese Umstellung ein Bild gebracht) und siehe an, nachdem ich die Installation mit sudo -H ./install-yavdr.sh nochmals gestartet habe, bekomme ich mit softhddevice ein Bild.


    EDIT-1:

    Leider bekomme ich mit softhdcuvid kein Bild


    EDIT-2:

    Nachdem ich dann den service vdr gestoppt habe, um die Zeitzone richtig einzustellen und dann den service vdr gestartet habe, bekomme ich jetzt ein Bild :/ . Ich habe sonst nichts geändert. Jetzt muss ich leider das Playbook nochmal starten, um serial_ir einzubinden. Mal schauen, was dann passiert ...

    4x yaVDR 0.7: ASUS P5N7A-VM // 2*TeVii S460 // Atric mit Lirc // 4*1,5TB // 7" TFT

    Im Aufbau: VDR-UHD mit nVidia GT1030 unter Ubuntu 20.04

    The post was edited 1 time, last by r371769 ().