ansible: Fernbedienung parametrieren?

  • Hallo,


    nachdem ich die letzten Jahre die Einstellungen für die Fernbedienung immer über die Weboberfläche gemacht habe:

    Wo muss ich jetzt sowas wie die serielle Schnittstelle etc. eintragen?


    Ich kann doch sicher das anlernen sparen und die entsprechende Konfigurationen der Tasten von meinem alten vdr0.6 übernehmen. Was muss ich dazu alles kopieren?



    Danke!

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030

  • Gegenüber yaVDR 0.6 hat sich da einiges verändert - neuere Kernel bringen den serial_ir Treiber mit, der Empfänger funktioniert damit ganz ohne lircd als rc-core Gerät. Die lircd.conf ist leider nicht ohne weiteres auf die Keymap übertragbar.


    Da es nicht ganz einfach ist eine seriellen Empfänger zuverlässig automatisch zu erkennen, musst man die Rolle gezielt im Playbook aktivieren: https://github.com/yavdr/yavdr…ob/bionic/yavdr07.yml#L39 und ggf. die Serielle Schnittstelle angeben, wenn es nicht ttyS0 (COM1) ist: https://github.com/yavdr/yavdr…ionic/group_vars/all#L138


    Standardmäßig wird wie in https://github.com/yavdr/yavdr…plates/rc_maps.cfg.j2#L36 festgelegt eine Keymap für RC-6A Microsoft MCE geladen.


    Zum Anlernen gibt es in https://www.yavdr.org/document…mentation.html#orgd5d9066 ein Python-Skript, wenn man das nicht zu Fuß machen will (BUTTONS Variable vorher auf die gewünschten Tasten anpassen, dann eventlircd.service und eventlircd.socket stoppen).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Die Rolle hatte ich schonmal sicherheitshalber einkommentiert.


    Wenn ich ein ir-keytable aufrufe, findet er sowohl den home-brew Empfänger als auch den Empfänger der Terratec Karte:


    Auch evtest findet beide:

    Code
    1. /dev/input/event11:     Terratec Cinergy S2 Dual (tuner 1)
    2. /dev/input/event12:     Serial IR type home-brew
    3. /dev/input/event13:     HDA NVidia HDMI/DP,pcm=3
    4. /dev/input/event14:     HDA NVidia HDMI/DP,pcm=7
    5. /dev/input/event15:     Terratec Cinergy S2 Dual (tuner 2)


    Mit evtest bekomme ich die Tastenquittungen der Terratec Fernbedienung angezeigt, beim home-brew tut sich aber nichts.


    ir-keytable liefert aber nichts. Auch nicht wenn ich mit -c die alte Konfig lösche und mit -p nec auf das bei der Terratec angegebene NEC Protokoll wechsle.

    Der Versuch auf das JVC Protokoll zu wechseln wird mit einer Fehlermeldung quittiert:

    Can't find jvc bpf protocol in /etc/rc_keymaps/protocols or /lib/udev/rc_keymaps/protocols

    ... hat er Recht, das erste Verzeichnis ist leer und im zweiten auch nichts von JVC (Allerdings auch nichts von NEC oder RC6 etc).

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030

  • Hast du bei ir-keytable das gewünschte Gerät (z.B. -s rc1) angegeben? Standardmäßig arbeitet das mit dem ersten Empfänger (rc0), was bei dir einer der Empfänger der Terratec Karte zu sein scheint.


    Der Versuch auf das JVC Protokoll zu wechseln wird mit einer Fehlermeldung quittiert:

    Can't find jvc bpf protocol in /etc/rc_keymaps/protocols or /lib/udev/rc_keymaps/protocols

    Wie sah da dein ir-keytable Aufruf aus?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • ir-keytable -c -p jvc -t, ergibt die obige Fehlermeldung.



    Verwende ich ir-keytable -c -s rc1 -t, kommt wiederum keine Ausgabe.


    Das einzige was funktioniert ist ir-keytable -c -p nec -s rc2 -t, dieser verwendet dann den Empfänger auf der Terratec-

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030

    The post was edited 1 time, last by warhammer ().

  • keiner ne Idee? :(

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030

  • Du du könntest mal die hier vorgestellte Lösung ausprobieren.

  • Hallo,


    ich habe mich gestern mal aus Neugier eine Testinstallation auf einer "alten" HDD gewagt.
    Bei mir hängt ein Atric V5 an einer internen seriellen Schnittstelle vom Board. Fernbedienung ist eine Phillips SRU 6008 Prestigo. Beides hatte ich bei Erwerb vor Jahren mal konfiguriert und läuft seit dem an einem mittlerweile Yavdr 0.6 / Ubuntu 14.04.6 LTS. Ich muss gestehen, dass ich vergessen habe auf was (Protokoll) ich die Fernbedienung damals programmiert hatte. Aber es muss nec gewesen sein, auf dem Protokoll bekomme ich zumindest ergebnisse


    Mein Vorgehen(nach Tüfteln)


    yavdr07.yml Kommentarzeichen # for - serial-ir entfernt


    in der group_vars/all bzw. host_vars/localhost steht jeweils sertial_ir_device: ttyS0


    in der /etc/re_maps.cfg habe ich

    serial_ir rc-rc6-mce /lib/udev/rc-keymaps/rc-rc6-mce

    gegen

    serial_ir rc-rc6-mce /lib/udev/rc-keymaps/prestigo

    geändert.



    Reaktionen bekomme ich hier nur auf /event4. Auf /event7 wird bei Tastendruck nichts angezeigt.


    nach durchprobieren einiger Protokolle brachte ir-keytable -c -p nec endlich Ergebnisse.


    Mit ir-keytable -t habe ich die gesendeten/empfangenen codes in die /lib/udev/rc-keymaps/prestigo entsprechend meiner Wünsche eingetragen.



    Zwichendurch mal ein ir-keytable -c -p nec -w /lib/udev/rc_keymaps/prestigo zum testen ob die eingetragenen Codes richtig angewendet werden.


    Das ist sicher nicht die gedachte Vorgehensweise, habs so aber zu funktionieren gebracht :)


    Gruß R.

    VDR-SW: yavdr 0.4
    VDR-HW: 2x TeVii S464 DVB-S/S2, Dell E8400, Nvidia 210 (218), Philips SRU 6008

  • Danke, mein Problem scheint ja irgendwie ein grundlegendes zu sein.

    Denn ir-keytable -p meckert ja bei jedem Protokoll (ausser nec):

    Can't find rc-mm bpf protocol in /etc/rc_keymaps/protocols or /lib/udev/rc_keymaps/protocols (Oder welches Protokoll auch immer ich angegeben habe)...


    Ich finde einfach keine Lösung was da schief läuft...

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030

    The post was edited 1 time, last by warhammer ().

  • Hallo viduus,


    was hast Du gemacht nachdem Du die yavdr07 und die localhost angepasst hast?


    Bei mir gibt es z.B. gar keine re_maps.cfg...



    Danke!

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030

  • Arbeitest du als root? Vielleicht ist es ein Berechtigungsproblem. Versuch es mal mit sudo ir-keytable...

    Hast du vorher eventlirc gestoppt?

  • Hallo,

    Quote

    Bei mir gibt es z.B. gar keine re_maps.cfg...

    sry, das ist ein typo gemeint ist /etc/rc_maps.cfg, siehe auch Post #2


    ansonsten habe ich nichts weiter geändert, außer zum testen mit evtest systemctl stop eventlircd.{service,socket}

    VDR-SW: yavdr 0.4
    VDR-HW: 2x TeVii S464 DVB-S/S2, Dell E8400, Nvidia 210 (218), Philips SRU 6008

  • Eigentlich passt yavdr-ansible-lirc-mit-atric genau zu deinem Problem.

  • ... mal eine generelle Frage:

    Sollte in cat /proc/bus/input/devices auch dann ein Homebrew Eintrag auftauchen wenn gar kein Empfänger angeschlossen ist?

    ... obwohl ich gerade gar keinen Empfänger angeschlossen habe, wird trotzdem ein entsprechender Eintrag angezeigt...


    JoeBar :

    Sorry, aber tut es leider nicht - oder ich sehe gerade den Wald vor Bäumen nicht mehr.

    Zu keinem meiner zwei Probleme.


    Problem a) Das Wechseln auf ein anderes Protokoll wirft eine Fehlermeldung. In Deinem verlinkten Beitrag funktioniert das aber mit dem Umstellen auf rc5.

    Spannenderweise habe ich gerade mit den gleichen Einstellungen in yavdr07.yml und in der localhost einen neuen VDR aufgesetzt. Dort kann ich jetzt ohne Fehler auf andere Protokolle umstellen. Was immer in der ersten Installation falsch gelaufen ist.


    Problem b) Die Lösung geht davon aus, das es eine fertige Keytable gibt. Die gibt es bei mir aber nicht und im Gegensatz zu dem dargestellen Problem reagiert bei mir weder evtest noch ir-keytable auf irgend eine Fernbedienung.

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030

    The post was edited 2 times, last by warhammer ().

  • Existiert jetzt nur noch Problem B? Oder doch noch beide?


    Falls A jetzt gelöst ist, wurde vorher wahrscheinlich das modul serial_ir nicht geladen.


    Wahrscheinlich wird der serielle Empfänger konfiguriert und ist deshalb vorhanden. Denke nicht dass der Seriele Port Hotplug fähig ist und sich dem System irgendwie zu erkennen gibt wie es USB tut.

  • In der Installation die bis auf die Fernbedienung fertig ist und funktioniert, existieren beide Probleme.


    Bei einer zweiten Parallelinstallation nur b).

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030

  • Pass doch einfach mal die ansible Rolle an und lass sie nochmal drüberlaufen evtl. Ist dann bei der ersten Installation auch nur noch Fehler B vorhanden.

  • Naja, solange Fehler B in beiden vorhanden ist, mag ich mir nicht die ansonsten fertige Installation zerschiessen. ;)


    Aber gerade ausprobiert: Die Einträge in input/devices kommen erst mit dem ausführen der Rolle serial-ir hinzu und sind unabhängig von irgendwelchen physischen Gegebenheiten.


    Damit ist die Frage wie man technische Probleme ausschliessen kann.

    Ich weiss das der Empfänger funktioniert (Tut es an meinem alten vdr0.6 ohne Probleme).

    Ich weiss das die serielle Schnittstelle auf dem Board eingeschalten ist (Ist die ausgeschalten, gibt es keine tty0 Meldungen in dmesg).

    Aber ob die restliche Verkabelung passt?

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030

  • Bei den Seriellen Empfängern kannst ja nicht viel verkehrt machen die IR-Reciver haben auch nur drei Anschlüsse den kannst also nur drehen... für die Pfostenstecker gibt es zwei unterschiedliche Belegungen Asus z.B. weicht da ab. Was für ein Board hast du denn?

  • Nen Asrock. Natürlich ist die Chance das auf dem Board was kaputt ist, der Pfostenstecker keinen Kontakt gibt oder das Kabel zum Stecker defekt ist nahe 0.


    Nur weiss ich halt absolut nicht mehr wieso das Mistding einfach keine Tastencodes ausgeben will.

    yavdr 0.6: Gigabyte GA H61M, Pentium 645, 4GB RAM, 1x3 TB, 1x64 GB SSD, 1x CineS2 V6, 1x Hauppauge S2-1600 , Nvidia GF210

    ansible@focal: Asrock Z370 Exteme4, Intel i3, 8GB RAM, 1x64GB SSD, 1x2TB HDD, 1xTerratec Cinergy S2 PCIe Dual, GF1030