Bildstörungen mit Kernel > 4.9.x

  • CvH Ist der aufgeführte Fix nicht schon seit 06/2019 im rpi-kernel?

  • der Patch ist seit 19.03. auch im media_tree git von linuxtv. Ansonsten auch in Kernel 5.4.28, 5.5.13 und 5.6-rc7

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Uwe . Ich habe mal mit "rpi-update 9dbd67c91d371171c9d8a624e90dba1190645a2a" den Kernel 4.19.108-v7+ installiert und dann die Dateien aus deinem Paket in den Ordner "lib" und "boot" kopiert. Problem besteht bei mir weiterhin. Ist denn die Vorgehensweise mit dem einfachen kopieren richtig?

    CvH . Ich kann den neuesten Kernel den es für den rpi gibt installieren. Trotzdem gibt es Bildstörungen.

    Unser Problem ist auch nicht das die Karte sich abschaltet. Ich denke das ist ein anderes Problem wie das welches du beschreibst. Ich glaube es betrifft auch nur den rpi.

    RPI3, DVB-Sky S960, VDR 2.2.0, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.

  • Uwe . Ich habe mal mit "rpi-update 9dbd67c91d371171c9d8a624e90dba1190645a2a" den Kernel 4.19.108-v7+ installiert und dann die Dateien aus deinem Paket in den Ordner "lib" und "boot" kopiert. Problem besteht bei mir weiterhin. Ist denn die Vorgehensweise mit dem einfachen kopieren richtig?

    Das rpi-update hättest du nicht machen müssen, alles Kernel-Relevante ist in meinem Paket ;)

    Poste mal bitte die Ausgabe von: uname -a 

    Ich bekomme hier folgende Ausgabe:

    Linux raspberrypi 4.19.108-v7+ #1 SMP Tue Mar 24 18:46:23 CET 2020 armv7l GNU/Linux

  • Ich komm gerade nicht an den pi ran, aber ich habe mal mit rpi-update den neuesten kernel installiert. Ein uname -r brachte 4.19.113. Danach hatte ich deine Dateien kopiert und nach einem reboot war ich auf 4.19.108-v7. Ich gehe davon aus das damit dein patch aktiv sein müsste. Die Bildstörungen bleiben trotzdem.

    RPI3, DVB-Sky S960, VDR 2.2.0, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.

  • Sollte passen, ich kann das aktuell nur mit der SD-Karte testen, wo auch raspbian drauf installiert ist.
    Welche weiteren Plugins nutzt du? markad?
    Welche HDD hast du angeschlossen?

    Ist noch mehr über USB angeschlossen? Display z.B.?

  • Hallo zusammen,


    ich habe 2 Raspi3 auf denen ich über OSMC (Tobi Repo) den VDR nutze. Ich nutze nur IPTV über die Telekom und die Raspi machen keine Aufnahmen. Ich schaue Aufnahmen via NFS und Live Fernsehen. Ich hab solche Aussetzer auch schon ewig und hab festgestellt das diese immer beim EPG Scan mit epg2vdr auftraten. Früher nicht nur mit leichten Bildaussetzern, sondern auch mit kurzen Audio Aussetzern. Fehler tritt bei mir Kernel 4.14 und aktuell 4.19 auf. Ich hatte das Problem nur beim LiveTV. Bei Aufnahmen die ich in erster Linie nutzte gibt es keine Probleme.


    Ich habe dann damals die epg.data auf einem tmpfs ausgelagert und die Zeitspanne des epg Scans vergrößert so das die Probleme fast nicht mehr auftraten und die Aussetzer auch nicht mehr so schlimm waren (Ton lief syncron weiter) und ich das nicht weiter verfolgt habe. Ich kann es aber immer noch nachstellen wenn ich über das epg2vdr plugin ein manuelles Update der EPG Daten anstosse.


    Ich kann also solche Bildaussetzer auf dem raspi unabhängig von irgendwelchen Empfangdevice bestätigen, wenn auf der SD Karte geschrieben wird. Bin mir aber nicht sicher ob das hier die gleiche Ursache ist.

  • Hi,

    Der Raspi 1-3 sind ja USB-technisch lahm, der 4 soll ziemlich schnell sein.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • USB-technisch habe ich hier ein Sundtek-Dual-Tuner am USB eines rpi3 und hier gibt es keine Bildfehler ... Ich muss die Tage mal eine USB-HDD zusätzlich anschließen und VDR darauf aufnehmen lassen... (...ich will noch nicht glauben, dass USB2.0 bei den rpi2-3 der begrenzende Faktor ist... ;) )

    Aber sicherlich ist USB3 besser ... ;)

  • Habe jetzt eine USB-HDD gefunden, mit ext4 formatiert und über die fstab eingebunden.

    Gerade nehme ich drei HD-Sender auf ARD HD, ZDF HD und arte HD.

    Nun schaue ich mir die arte HD Aufnahme an und kann diese Bildstörungen bisher nicht erkennen. Habe jetzt knapp 10min geschaut ...

    Der VDR Prozess läuft im Tool top mit ~60% CPU-Usage... :) Der Test lief mit vdr-2.4.1 + device.patch + rpihddevice Plugin. Mehr Plugins habe ich aktuell auch nicht installiert.


    Jetzt müsste ich noch die Gegenprobe mit den beiden DVBSky Tunern machen .... aber da komme ich erst nächste Woche zu.


    Gruß

    Uwe

  • Hi,

    Der Raspi 1-3 sind ja USB-technisch lahm, der 4 soll ziemlich schnell sein.

    Mfg Stefan

    Wir haben 320 Mbit via USB 2.0 (4x DVB-S/S2 via Single USB 2.0 Port) auf einem Raspberry PI 3 getestet, das zum Stichwort lahm.


    USB 3.0 eignet sich für 8x USB Tuner, wobei wir auf dem Raspberry PI 3 "nur" 7 Tuner zum Laufen gebracht haben, beim 8. Tuner wurde das USB Keyboard gelockt, nach Beendigung des Streams funktionierte das Keyboard wieder. Hier könnte man natürlich noch Hardware PID Filter einsetzen das würde dann wohl auch mit 8 Streams ohne Probleme funktionieren.

  • Am besten sieht man es bei mir wenn ich einen HD Film schneide und während der Schnitt läuft einen anderen HD Sender schaue. Wobei das eigentlich egal ist ob das schneiden auf der internen SD oder auf USB erfolgt. Und nein, es liegt nicht am schneiden. Da sieht man es am besten. Die Störungen kommen auch wenn ich einen Sender schaue und beispielsweise eine grosse Datei auf oder vom PI kopiere.

    RPI3, DVB-Sky S960, VDR 2.2.0, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.

  • Hallo Asta,


    danke für die Info, habe ich gerade mal getestet... bisher keine Fehler mit dem Sundtek Tuner...

    Sind die Fehler auch in den Aufnahmen gespeichert? Das würde dann bedeuten, dass diese fehlerhaft vom Tuner kommen... oder?

  • Hi,

    Der Grund wird sein, dass der RPi nur 1 USB hat, an dem alles dran hängt. Und die alten halt nur 1x 2.0.

    Ich vermute, wenn es früher mit älteren Versionen ging, dass das Dateisystem jetzt mehr CPU - Zugriff braucht als früher oder so etwas ( in Richtung DMA...) Alles reines Halbwissen.

    Mfg Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • Hallo Asta,


    danke für die Info, habe ich gerade mal getestet... bisher keine Fehler mit dem Sundtek Tuner...

    Sind die Fehler auch in den Aufnahmen gespeichert? Das würde dann bedeuten, dass diese fehlerhaft vom Tuner kommen... oder?

    Hallo Uwe. Ja, wenn ich mit Buster Aufnahmen mache, dann sind Störungen auch in den Aufnahmen zu sehen. Die Probleme kommen eindeutig von der DVB Sky.

    RPI3, DVB-Sky S960, VDR 2.2.0, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.

  • Asta Ich versuche mal den Test mit der DVBSky bald nachzuholen...

    Immerhin geht es mit dem Sundtek Dual Tuner... sogar mit USB-HDD ... ohne Bildfehler. :)

  • ...Ich versuche mal den Test mit der DVBSky bald nachzuholen...

    So, habe jetzt mal die DVBSky Tuner (2 Stück) angeschlossen und kann die Bildfehler hier auch mit den höheren Buffern nachvollziehen...


    Edit: eine Gegenprobe mit dem Sundtek Tuner erzeugt hier keine Bildfehler...

  • Ok, dann würde ich sagen das die letzte stabile Version mit einer DVBSky S960 raspbian Jessie mit Kernel 4.9.x ist. Das wird vermutlich auch so lange bleiben bis die Leute von DVBSky nachbessern, was vermutlich nicht passieren wird. Somit ist erst mal das Thema erledigt. Vielen Dank für eure Hilfe, besonders an Uwe .

    RPI3, DVB-Sky S960, VDR 2.2.0, Raspbian Jessie, Onkyo AV Receiver, Panasonic Plasma.